aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2012-09-11 10:25:33 +0800
committerbdrewery <bdrewery@FreeBSD.org>2012-09-11 10:25:33 +0800
commitf57053d12ae4edc5727731c123cd2f6fc288d1dc (patch)
treea707414156c1bdf2aaf05bf446973afa5f28172d /net-mgmt
parent48b54d79922289bfeabf3123c7faa52c080a8b4c (diff)
downloadfreebsd-ports-gnome-f57053d12ae4edc5727731c123cd2f6fc288d1dc.tar.gz
freebsd-ports-gnome-f57053d12ae4edc5727731c123cd2f6fc288d1dc.tar.zst
freebsd-ports-gnome-f57053d12ae4edc5727731c123cd2f6fc288d1dc.zip
- Convert to new options framework
- Remove ABI version from LIB_DEPENDS - Switch to using bsd.port.options.mk Approved by: eadler, bapt (mentors, implicit)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cflowd/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-mgmt/cflowd/Makefile b/net-mgmt/cflowd/Makefile
index 53722999ed2e..dc5ccb41ee3a 100644
--- a/net-mgmt/cflowd/Makefile
+++ b/net-mgmt/cflowd/Makefile
@@ -16,7 +16,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S|.|-|g}
MAINTAINER= ports@FreeBSD.org
COMMENT= Flow analysis tool used for analyzing Cisco's NetFlow switching
-LIB_DEPENDS= Arts.0:${PORTSDIR}/net-mgmt/arts++
+LIB_DEPENDS= Arts:${PORTSDIR}/net-mgmt/arts++
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
@@ -28,11 +28,12 @@ CONFIGURE_ARGS= --enable-shared --with-artspp=${LOCALBASE}
MANL= cfdases.l cfdifmatrix.l cfdnets.l cfdnexthops.l \
cfdportmatrix.l cfdprotos.l cfdtos.l flowdump.l flowwatch.l
-OPTIONS= FLOWSCAN "FlowScan patch" off
+OPTIONS_DEFINE= FLOWSCAN
+FLOWSCAN_DESC= FlowScan patch
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FLOWSCAN)
+.if ${PORT_OPTIONS:MFLOWSCAN}
PATCH_SITES+= http://net.doit.wisc.edu/~plonka/cflowd/
PATCHFILES+= cflowd-${PORTVERSION:S|.|-|g}-djp.patch
.endif
@@ -60,4 +61,4 @@ post-install:
${INSTALL_SCRIPT} ${FILESDIR}/cflowd.sh \
${PREFIX}/etc/rc.d/cflowd-base.sh.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>