aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/ktorrent
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-28 20:06:41 +0800
committermakc <makc@FreeBSD.org>2013-03-28 20:06:41 +0800
commitd90b2206729deb5268d72c670428860cc872885a (patch)
treea9dec9479dc4b1755c2ac3aed919395de377c55b /net-p2p/ktorrent
parentc79271066a9f7733f7834ccb5e3ec9ec0506abd7 (diff)
downloadfreebsd-ports-gnome-d90b2206729deb5268d72c670428860cc872885a.tar.gz
freebsd-ports-gnome-d90b2206729deb5268d72c670428860cc872885a.tar.zst
freebsd-ports-gnome-d90b2206729deb5268d72c670428860cc872885a.zip
- Change dependency type for Boost: required only at build stage
- Adjust USE_QT4 components - Switch to out-of-source build ktorrent only: - Explicitly depend on math/gmp - Fix potential build failure
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 9dfcb82548ec..327e5dc1bc59 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -3,19 +3,23 @@
PORTNAME= ktorrent
DISTVERSION= 4.3.1
+PORTREVISION= 1
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION}/
MAINTAINER= makc@FreeBSD.org
COMMENT= BitTorrent client for KDE
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/bind.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib \
+ gmp:${PORTSDIR}/math/gmp \
ktorrent.5:${PORTSDIR}/net-p2p/libktorrent
USE_BZIP2= yes
USE_KDE4= kdelibs kdehier kdeprefix automoc4 pimlibs workspace
-USE_QT4= qmake_build moc_build rcc_build uic_build
-USES= cmake
+USE_QT4= corelib gui network qt3support qtestlib webkit \
+ qmake_build moc_build rcc_build uic_build
+USES= cmake:outsource
USE_GETTEXT= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
@@ -28,4 +32,8 @@ PLIST_SUB+= SHLIB_VER=${SHLIB_VER} \
CMAKE_ARGS+= -DENABLE_KIO_MAGNET=1
+post-patch:
+ ${REINPLACE_CMD} -e 's,ktorrent,$${LIBKTORRENT_LIBRARIES},' \
+ ${WRKSRC}/plugins/ipfilter/tests/CMakeLists.txt
+
.include <bsd.port.mk>