aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/libtorrent
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-08-26 14:38:02 +0800
committerKurt Jaeger <pi@FreeBSD.org>2016-08-26 14:38:02 +0800
commitdbf6e7a24158b8612a639cbd13724f785af7c034 (patch)
treeeed51fd1ca7a0538e5ffe63625d989225acb1739 /net-p2p/libtorrent
parent454e1cdcbdd0177acb5dc6a54d6c93a7ce5df833 (diff)
downloadfreebsd-ports-gnome-dbf6e7a24158b8612a639cbd13724f785af7c034.tar.gz
freebsd-ports-gnome-dbf6e7a24158b8612a639cbd13724f785af7c034.tar.zst
freebsd-ports-gnome-dbf6e7a24158b8612a639cbd13724f785af7c034.zip
net-p2p/libtorrent: Explicitly link with libcrypto
- make sure that net-p2p/libtorrent links with libcrypto PR: 211223 Submitted by: Tobias Kortkamp <t@tobik.me> Approved by: pipfstarrd@opmbx.org (maintainer)
Diffstat (limited to 'net-p2p/libtorrent')
-rw-r--r--net-p2p/libtorrent/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 7ff9d1921ba2..9008fe295d88 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libtorrent
PORTVERSION= 0.13.6
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://rtorrent.net/downloads/
@@ -16,7 +17,8 @@ CONFLICTS_INSTALL= rblibtorrent-[0-9]* rblibtorrent-devel-[0-9]*
USES= compiler:c++11-lang libtool pathfix pkgconfig ssl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
-CONFIGURE_ENV= OPENSSL_LIBS="-L${OPENSSLBASE}/lib -ssl -crypto" OPENSSL_CFLAGS="-I${OPENSSLBASE}/include"
+CONFIGURE_ENV= OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto" OPENSSL_CFLAGS="-I\
+ ${OPENSSLINC}"
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
@@ -24,6 +26,10 @@ OPTIONS_DEFINE= IPV6 KQUEUE
OPTIONS_DEFAULT=KQUEUE
KQUEUE_DESC= Use kqueue(2) support
+# This makes sure that /usr/local/lib appears before /usr/lib when
+# linking libtorrent to avoid linking with base's libcrypto.
+MAKE_ARGS= LDFLAGS="${LDFLAGS}"
+
IPV6_CONFIGURE_ENABLE= ipv6
KQUEUE_CONFIGURE_WITH= kqueue
@@ -43,7 +49,6 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-clang
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
@${FIND} ${WRKSRC} \( -name '*.h' -o -name '*.cc' \) -type f \
-exec ${REINPLACE_CMD} -e 's/tr1::/std::/g' {} \; \