aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/litecoin
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-13 01:26:26 +0800
committerJohn Marino <marino@FreeBSD.org>2016-09-13 01:26:26 +0800
commit2b9a346ff3b70aff5877ebc815fc48b6c3687334 (patch)
tree6325d54d8fabd484fa55a3c59542e2236d7b813c /net-p2p/litecoin
parentb5c8f27d993c00412ffe8f53d22cc96306bdb714 (diff)
downloadfreebsd-ports-gnome-2b9a346ff3b70aff5877ebc815fc48b6c3687334.tar.gz
freebsd-ports-gnome-2b9a346ff3b70aff5877ebc815fc48b6c3687334.tar.zst
freebsd-ports-gnome-2b9a346ff3b70aff5877ebc815fc48b6c3687334.zip
net-p2p/litecoin: Set SSL flags
Note for SSL_DEFAULT=libressl: configure: error: Detected LibreSSL: This is not supported, and may break consensus compatibility It might be worth detecting that via SSL_DEFAULT and setting the port to IGNORE. Or perhaps a newer version of litecoin will support LibreSSL officially. Approved by: SSL blanket
Diffstat (limited to 'net-p2p/litecoin')
-rw-r--r--net-p2p/litecoin/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index 31627b26d18e..f2ebe156d526 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -85,6 +85,10 @@ CONFIGURE_ENV= CRYPTO_CFLAGS="-I${OPENSSLINC}" CRYPTO_LIBS="-L${OPENSSLLIB} -lcr
CONFIGURE_ENV+= OBJC="${CC}" OBJCFLAGS="${CFLAGS}" OBJCXX="${CXX}" OBJCXXFLAGS="${CXXFLAGS}"
+CPPFLAGS+= -I${OPENSSLINC}
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
PLIST_FILES?= bin/litecoin-qt share/applications/litecoin-qt.desktop \
share/pixmaps/litecoin128.png