aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/opendchub
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-02-13 19:24:54 +0800
committerdanfe <danfe@FreeBSD.org>2005-02-13 19:24:54 +0800
commitefd734651f7460f91ef77076418a7000a4523bd7 (patch)
treebc584d63d511325d3afe2c807d6450c9deddd199 /net-p2p/opendchub
parent2d8243dee6f858aedc15652465135e0ab892d816 (diff)
downloadfreebsd-ports-gnome-efd734651f7460f91ef77076418a7000a4523bd7.tar.gz
freebsd-ports-gnome-efd734651f7460f91ef77076418a7000a4523bd7.tar.zst
freebsd-ports-gnome-efd734651f7460f91ef77076418a7000a4523bd7.zip
- Fix buffer overflow [1]
- Fix telnet vulnerability [2] - Unbreak and unforbid - Bump PORTREVISION VuXML: cdf14b68-3ff9-11d9-8405-00065be4b5b6 [1] Obtained from: Gentoo CVS [1] project's patch tracker at sf.net [2]
Diffstat (limited to 'net-p2p/opendchub')
-rw-r--r--net-p2p/opendchub/Makefile6
-rw-r--r--net-p2p/opendchub/files/patch-buffer_overflow_fix11
-rw-r--r--net-p2p/opendchub/files/patch-telnet_chat_fix11
3 files changed, 23 insertions, 5 deletions
diff --git a/net-p2p/opendchub/Makefile b/net-p2p/opendchub/Makefile
index e090c1df9f6f..418101c52d92 100644
--- a/net-p2p/opendchub/Makefile
+++ b/net-p2p/opendchub/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opendchub
PORTVERSION= 0.7.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,10 +21,6 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
-FORBIDDEN= "http://vuxml.freebsd.org/cdf14b68-3ff9-11d9-8405-00065be4b5b6.html"
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${FORBIDDEN}
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/net-p2p/opendchub/files/patch-buffer_overflow_fix b/net-p2p/opendchub/files/patch-buffer_overflow_fix
new file mode 100644
index 000000000000..305b6c5d9558
--- /dev/null
+++ b/net-p2p/opendchub/files/patch-buffer_overflow_fix
@@ -0,0 +1,11 @@
+--- src/commands.c.orig Sun Feb 13 17:16:37 2005
++++ src/commands.c Sun Feb 13 17:17:18 2005
+@@ -2842,7 +2842,7 @@
+ {
+ char move_string[MAX_HOST_LEN+20];
+
+- sprintf(move_string, "$ForceMove %s", buf);
++ snprintf(move_string, MAX_HOST_LEN, "$ForceMove %s", buf);
+
+ send_to_humans(move_string, REGULAR | REGISTERED | OP, user);
+ remove_all(UNKEYED | NON_LOGGED | REGULAR | REGISTERED | OP, 1, 1);
diff --git a/net-p2p/opendchub/files/patch-telnet_chat_fix b/net-p2p/opendchub/files/patch-telnet_chat_fix
new file mode 100644
index 000000000000..79ade0c6ef26
--- /dev/null
+++ b/net-p2p/opendchub/files/patch-telnet_chat_fix
@@ -0,0 +1,11 @@
+--- src/main.c.orig Sun Feb 13 16:54:21 2005
++++ src/main.c Sun Feb 13 16:55:31 2005
+@@ -1056,7 +1056,7 @@
+ /* The chat command, starts with <nick> */
+ else if(*temp == '<')
+ {
+- if((user->type & (SCRIPT | UNKEYED | LINKED | NON_LOGGED)) == 0)
++ if((user->type & (SCRIPT | UNKEYED | LINKED | NON_LOGGED | NON_LOGGED_ADM)) == 0)
+ chat(temp, user);
+ }
+