aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-12-30 00:18:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-12-30 00:18:48 +0800
commitf652013516dcf468dd78ad36d169ac66c827a6a7 (patch)
treebf9e13cd89ad9094e04fe681d845626a3a171994 /net-p2p/qbittorrent
parentcbe78da6980c7dae29dc8a950cfc7ef6a3e91e99 (diff)
downloadfreebsd-ports-gnome-f652013516dcf468dd78ad36d169ac66c827a6a7.tar.gz
freebsd-ports-gnome-f652013516dcf468dd78ad36d169ac66c827a6a7.tar.zst
freebsd-ports-gnome-f652013516dcf468dd78ad36d169ac66c827a6a7.zip
- Update to 3.3.10
PR: 215575 Submitted by: matthew@reztek.cz Approved by: yuri@rawbw.com (maintainer)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Makefile3
-rw-r--r--net-p2p/qbittorrent/distinfo6
-rw-r--r--net-p2p/qbittorrent/files/patch-src_base_bittorrent_session.cpp64
-rw-r--r--net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp4
4 files changed, 71 insertions, 6 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index b1bdffb13268..a60e626e4888 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qbittorrent
-PORTVERSION= 3.3.7
-PORTREVISION= 1
+PORTVERSION= 3.3.10
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/net-p2p/qbittorrent/distinfo b/net-p2p/qbittorrent/distinfo
index 9bcbd5e5a99b..8984a390d500 100644
--- a/net-p2p/qbittorrent/distinfo
+++ b/net-p2p/qbittorrent/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1473733537
-SHA256 (qbittorrent-3.3.7.tar.xz) = 72dc824a90fadc0825e6be6f1c215e38f976262c7f83b625061d542b2b664c40
-SIZE (qbittorrent-3.3.7.tar.xz) = 2884792
+TIMESTAMP = 1482707995
+SHA256 (qbittorrent-3.3.10.tar.xz) = 2c657ceacdc84033da044a0a9ecba7e0fdb35858324dc097546f989166f1a8d2
+SIZE (qbittorrent-3.3.10.tar.xz) = 2959380
diff --git a/net-p2p/qbittorrent/files/patch-src_base_bittorrent_session.cpp b/net-p2p/qbittorrent/files/patch-src_base_bittorrent_session.cpp
new file mode 100644
index 000000000000..91ef012887e1
--- /dev/null
+++ b/net-p2p/qbittorrent/files/patch-src_base_bittorrent_session.cpp
@@ -0,0 +1,64 @@
+Revert the following commit until libtorrent 1.1.2 is released:
+
+From 729c80f9104a3d01ec724351bd6910b4b8d14c6c Mon Sep 17 00:00:00 2001
+From: sledgehammer999 <hammered999@gmail.com>
+Date: Mon, 31 Oct 2016 02:31:56 +0200
+Subject: [PATCH] Use new libtorrent 1.1.2+ utility function to generate client
+ ID instead.
+
+--- src/base/bittorrent/session.cpp.orig 2016-12-17 18:02:06 UTC
++++ src/base/bittorrent/session.cpp
+@@ -45,6 +45,7 @@
+ #include <QTimer>
+
+ #include <cstdlib>
++#include <sstream>
+ #include <queue>
+ #include <vector>
+
+@@ -194,6 +195,36 @@ namespace
+
+ template <typename T>
+ LowerLimited<T> lowerLimited(T limit, T ret) { return LowerLimited<T>(limit, ret); }
++
++#if LIBTORRENT_VERSION_NUM >= 10100
++ std::string makeFingerprint(const char* peerId, int major, int minor, int revision, int tag)
++ {
++ Q_ASSERT(peerId);
++ Q_ASSERT(major >= 0);
++ Q_ASSERT(minor >= 0);
++ Q_ASSERT(revision >= 0);
++ Q_ASSERT(tag >= 0);
++ Q_ASSERT(std::strlen(peerId) == 2);
++
++ auto versionToChar = [](int v) -> char
++ {
++ if (v >= 0 && v < 10) return static_cast<char>('0' + v);
++ if (v >= 10) return static_cast<char>('A' + (v - 10));
++ Q_ASSERT(false);
++ return '0';
++ };
++
++ std::ostringstream buf;
++ buf << '-'
++ << peerId
++ << versionToChar(major)
++ << versionToChar(minor)
++ << versionToChar(revision)
++ << versionToChar(tag)
++ << '-';
++ return buf.str();
++ }
++#endif
+ }
+
+ // Session
+@@ -334,7 +365,7 @@ Session::Session(QObject *parent)
+ dispatchAlerts(alertPtr.release());
+ });
+ #else
+- std::string peerId = libt::generate_fingerprint(PEER_ID, VERSION_MAJOR, VERSION_MINOR, VERSION_BUGFIX, VERSION_BUILD);
++ std::string peerId = makeFingerprint(PEER_ID, VERSION_MAJOR, VERSION_MINOR, VERSION_BUGFIX, VERSION_BUILD);
+ libt::settings_pack pack;
+ pack.set_int(libt::settings_pack::alert_mask, alertMask);
+ pack.set_str(libt::settings_pack::peer_fingerprint, peerId);
diff --git a/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp b/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp
index 429fc8a308dc..f03a2a6041dd 100644
--- a/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp
+++ b/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp
@@ -1,4 +1,6 @@
---- src/base/utils/string.cpp.orig 2016-09-23 15:05:18 UTC
+Avoid use of thread local storage on versions prior to which it was supported.
+
+--- src/base/utils/string.cpp.orig 2016-12-17 18:02:06 UTC
+++ src/base/utils/string.cpp
@@ -37,7 +37,7 @@
#ifdef QBT_USES_QT5