aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/shx
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-13 04:36:54 +0800
committermarino <marino@FreeBSD.org>2016-09-13 04:36:54 +0800
commit81b6f3058ee584e6e2049b961126cc4369dbcec5 (patch)
tree191460d58c432a8bb5d106c9370a62ca86395b32 /net-p2p/shx
parent12e1c11d82ebd2a06229f352cc458be2c0d93656 (diff)
downloadfreebsd-ports-gnome-81b6f3058ee584e6e2049b961126cc4369dbcec5.tar.gz
freebsd-ports-gnome-81b6f3058ee584e6e2049b961126cc4369dbcec5.tar.zst
freebsd-ports-gnome-81b6f3058ee584e6e2049b961126cc4369dbcec5.zip
net-p2p/shx: Document SSH reqirement, handle no EGD case (LibreSSL)
While here, convert options to modern framework Approved by: SSL and infrastructure blankets
Diffstat (limited to 'net-p2p/shx')
-rw-r--r--net-p2p/shx/Makefile54
-rw-r--r--net-p2p/shx/files/patch-src_main.c20
2 files changed, 36 insertions, 38 deletions
diff --git a/net-p2p/shx/Makefile b/net-p2p/shx/Makefile
index 2889880e137c..722bbdda3872 100644
--- a/net-p2p/shx/Makefile
+++ b/net-p2p/shx/Makefile
@@ -27,46 +27,24 @@ HAL_DESC= Compile MegaHAL (enables hal command)
XMMS_DESC= Enable trackname command
NOIPV4_DESC= IPv6 support (disables IPv4 support)
-USES= readline tar:tgz
+USES= readline ssl tar:tgz
MAKEFILE= makefile
GNU_CONFIGURE= yes
-CONFIGURE_ARGS=
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MWARNINGS}
-CONFIGURE_ARGS+= --enable-warnings
-.endif
-
-.if ${PORT_OPTIONS:MHTXF_PTHREAD}
-CONFIGURE_ARGS+= --enable-htxf-pthread
-.endif
-
-.if ! ${PORT_OPTIONS:MHFS}
-CONFIGURE_ARGS+= --disable-hfs
-.endif
-
-.if ${PORT_OPTIONS:MHOPE}
-CONFIGURE_ARGS+= --enable-hope
-.if ${PORT_OPTIONS:MCIPHER}
-CONFIGURE_ARGS+= --enable-cipher
-.endif
-.if ${PORT_OPTIONS:MCOMPRESS}
-CONFIGURE_ARGS+= --enable-compress
-.endif
-.endif
-
-.if ${PORT_OPTIONS:MHAL}
-CONFIGURE_ARGS+= --enable-hal
-.endif
-
-.if ${PORT_OPTIONS:MXMMS}
-CONFIGURE_ARGS+= --enable-xmms
-.endif
-
-.if ${PORT_OPTIONS:MNOIPV4}
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
+CIPHER_IMPLIES= HOPE
+COMPRESS_IMPLIES= HOPE
+
+CIPHER_CONFIGURE_ENABLE= cipher
+COMPRESS_CONFIGURE_ENABLE= compress
+HAL_CONFIGURE_ENABLE= hal
+HFS_CONFIGURE_ENABLE= hfs
+HOPE_CONFIGURE_ENABLE= hope
+HTXF_PTHREAD_CONFIGURE_ENABLE= htxf-pthread
+NOIPV4_CONFIGURE_ENABLE= ipv6
+XMMS_CONFIGURE_ENABLE= xmms
+WARNINGS_CONFIGURE_ENABLE= warnings
PLIST_FILES= bin/hx \
share/examples/shx/hxrc \
diff --git a/net-p2p/shx/files/patch-src_main.c b/net-p2p/shx/files/patch-src_main.c
new file mode 100644
index 000000000000..7a5a182c22e5
--- /dev/null
+++ b/net-p2p/shx/files/patch-src_main.c
@@ -0,0 +1,20 @@
+--- src/main.c.orig 2002-12-17 19:28:19 UTC
++++ src/main.c
+@@ -296,7 +296,7 @@ loopZ (void)
+ #if defined(CONFIG_CIPHER)
+ #include "cipher.h"
+
+-#if USE_OPENSSL
++#if USE_OPENSSL && !defined(OPENSSL_NO_EGD)
+ #include <openssl/rand.h>
+
+ static char *egd_path = 0;
+@@ -324,7 +324,7 @@ set_egd_path (char **egd_pathp, const ch
+ static void
+ cipher_init (void)
+ {
+-#if USE_OPENSSL
++#if USE_OPENSSL && !defined(OPENSSL_NO_EGD)
+ variable_add(&egd_path, set_egd_path, "egd_path");
+ #else
+ srand(getpid()*clock());