aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/tribler
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-24 21:32:58 +0800
committerbapt <bapt@FreeBSD.org>2014-07-24 21:32:58 +0800
commita8844613fabe6f02880be5a2bbab4d9af2853c2d (patch)
treeffddb673c48038e781d69f6c3d08ec8855ad33a5 /net-p2p/tribler
parent12f33c255d02d5e8b350ff2daf6aa8ed112b6508 (diff)
downloadfreebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.tar.gz
freebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.tar.zst
freebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.zip
Only use libevent2
Remove libevent as libevent2 is providing a good compatibility interface as well as providing better performances. Remove custom patches from libevent2 and install libevent2 the regular way Mark ports abusing private fields of the libevent1 API as broken Import a patch from fedora to have honeyd working with libevent2 Remove most of the patches necessary to find the custom installation we used to have for libevent2 With hat: portmgr
Diffstat (limited to 'net-p2p/tribler')
-rw-r--r--net-p2p/tribler/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-p2p/tribler/Makefile b/net-p2p/tribler/Makefile
index b493dfbd93df..222cf7dca3d7 100644
--- a/net-p2p/tribler/Makefile
+++ b/net-p2p/tribler/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tribler
PORTVERSION= 6.0.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-p2p
#MASTER_SITES= http://dl.tribler.org/
MASTER_SITES= GENTOO/distfiles \
@@ -20,7 +20,7 @@ LICENSE= LGPL21 MIT
LICENSE_COMB= multi
EXTRACT_DEPENDS=${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= libevent-2.0.so:${PORTSDIR}/devel/libevent2 \
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2 \
libvlc.so:${PORTSDIR}/multimedia/vlc
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}netifaces>0:${PORTSDIR}/net/py-netifaces \
@@ -65,9 +65,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-O2|| ; \
s|CPPFLAGS|CXXFLAGS| ; \
s|-g -I$${LIBEVENT_HOME}/include|-I$${LOCALBASE}/include| ; \
- s|-levent -lstdc++|-levent-2.0| ; \
+ s|-lstdc++|| ; \
s|g++|$${CXX}| ; \
- s|$${LIBEVENT_HOME}/lib|$${LOCALBASE}/lib/event2|g' \
+ s|$${LIBEVENT_HOME}/lib|$${LOCALBASE}/lib|g' \
${WRKDIR}/usr/share/tribler/Tribler/SwiftEngine/Makefile
@${REINPLACE_CMD} 's|linux|freebsd|' \
${WRKDIR}/usr/share/tribler/Tribler/vlc.py