aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/twister
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2014-07-06 02:36:55 +0800
committerthierry <thierry@FreeBSD.org>2014-07-06 02:36:55 +0800
commit56b9406e1890d318c60aee32fe8d7def6ac6d34e (patch)
tree1d1acec6c855af1051347101ea56c8402fb8c984 /net-p2p/twister
parent9b5fa2b8df05b572935347112bdb2b9fc5eee933 (diff)
downloadfreebsd-ports-gnome-56b9406e1890d318c60aee32fe8d7def6ac6d34e.tar.gz
freebsd-ports-gnome-56b9406e1890d318c60aee32fe8d7def6ac6d34e.tar.zst
freebsd-ports-gnome-56b9406e1890d318c60aee32fe8d7def6ac6d34e.zip
Fix build on FreeBSD-9.
Diffstat (limited to 'net-p2p/twister')
-rw-r--r--net-p2p/twister/Makefile7
-rw-r--r--net-p2p/twister/files/patch-src_makefile.freebsd11
-rw-r--r--net-p2p/twister/files/patch-src_scrypt.cpp12
3 files changed, 29 insertions, 1 deletions
diff --git a/net-p2p/twister/Makefile b/net-p2p/twister/Makefile
index 611286f0cac7..566d238497e9 100644
--- a/net-p2p/twister/Makefile
+++ b/net-p2p/twister/Makefile
@@ -45,13 +45,18 @@ BUILD_WRKSRC= ${WRKSRC}/src
MAKE_ENV= BOOST_INCLUDE_PATH=${LOCALBASE}/include \
BOOST_LIB_PATH=${LOCALBASE}/lib \
BDB_INCLUDE_PATH=${BDB_INCLUDE_DIR} \
- BDB_LIB_PATH=${BDB_LIB_DIR}
+ BDB_LIB_PATH=${BDB_LIB_DIR} \
+ ICONV_LIB="${ICONV_LIB}"
PLIST_FILES= bin/twisterd
PORTDOCS= README.md
.include <bsd.port.options.mk>
+.if (${OPSYS} == FreeBSD && ${OSVERSION} < 1000000)
+WITH_OPENSSL_PORT= yes
+.endif
+
pre-configure:
(cd ${CONFIGURE_WRKSRC} && ./autotool.sh)
.if ${PORT_OPTIONS:MUPNP}
diff --git a/net-p2p/twister/files/patch-src_makefile.freebsd b/net-p2p/twister/files/patch-src_makefile.freebsd
new file mode 100644
index 000000000000..d763662b74fa
--- /dev/null
+++ b/net-p2p/twister/files/patch-src_makefile.freebsd
@@ -0,0 +1,11 @@
+--- src/makefile.freebsd.orig 2014-06-28 13:26:56.000000000 +0200
++++ src/makefile.freebsd 2014-07-05 20:16:28.000000000 +0200
+@@ -40,7 +40,7 @@
+ -l boost_thread$(BOOST_LIB_SUFFIX) \
+ -l boost_locale$(BOOST_LIB_SUFFIX) \
+ -l db_cxx$(BDB_LIB_SUFFIX) \
+- -l ssl \
++ $(ICONV_LIB) -l ssl \
+ -l crypto \
+ -l rt
+
diff --git a/net-p2p/twister/files/patch-src_scrypt.cpp b/net-p2p/twister/files/patch-src_scrypt.cpp
new file mode 100644
index 000000000000..85d877a60d29
--- /dev/null
+++ b/net-p2p/twister/files/patch-src_scrypt.cpp
@@ -0,0 +1,12 @@
+--- src/scrypt.cpp.orig 2014-06-28 13:26:56.000000000 +0200
++++ src/scrypt.cpp 2014-07-05 19:42:46.000000000 +0200
+@@ -33,6 +33,9 @@
+ #include <stdint.h>
+ #include <string.h>
+ #include <openssl/sha.h>
++#if defined(__FreeBSD__) && (__FreeBSD_version < 100000)
++#include <sys/endian.h>
++#endif
+
+ #ifndef __FreeBSD__
+ /* Allready defined in sys/endian.h */
be74677a0b916dcdc7a1'>- Update to 1.10.10clsung2008-04-082-6/+5 * Migration from bison 1.x to 2.xade2007-10-171-1/+2 * - Update to 1.10.9clsung2007-07-262-4/+4 * - Set --mandir and --infodir in CONFIGURE_ARGS if the configure scriptrafan2007-07-231-1/+1 * - update to 1.10.8clsung2007-04-117-64/+10 * dd@ has had his port bit taken for safekeeping. Therefore, return theselinimon2007-03-041-1/+1 * Remove USE_REINPLACE from categories starting with Tedwin2006-05-131-1/+0 * Conversion to a single libtool environment.ade2006-02-231-1/+1 * SHA256ifyedwin2006-01-241-0/+1 * Avoid clobbering a modified dict.conf on deinstall.dd2006-01-082-3/+6 * Upgrade to 1.10.4.dd2006-01-022-4/+4 * Mass-conversion to the USE_AUTOTOOLS New World Order. The code presentade2005-11-151-1/+1 * Upgrade to 1.10.1. Drop the dependency on ltdl; the client never useddd2005-06-143-15/+3 * Upgrade to 1.9.15dd2005-01-302-3/+3 * Upgrade to 1.9.14dd2004-09-033-14/+3 * Sync with new bsd.autotools.mkade2004-06-051-2/+1 * Upgrade to 1.9.13dd2004-05-112-3/+3 * Add missing file and manpagekris2004-04-15