aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /net-p2p
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule-devel/Makefile4
-rw-r--r--net-p2p/amule/Makefile4
-rw-r--r--net-p2p/bitcoin/Makefile10
-rw-r--r--net-p2p/dogecoin/Makefile4
-rw-r--r--net-p2p/eiskaltdcpp-qt/Makefile12
-rw-r--r--net-p2p/ktorrent-kde4/Makefile4
-rw-r--r--net-p2p/ktorrent/Makefile4
-rw-r--r--net-p2p/libktorrent-kde4/Makefile4
-rw-r--r--net-p2p/libktorrent/Makefile4
-rw-r--r--net-p2p/litecoin/Makefile10
-rw-r--r--net-p2p/namecoin/Makefile6
-rw-r--r--net-p2p/qbittorrent/Makefile9
-rw-r--r--net-p2p/qtum/Makefile4
-rw-r--r--net-p2p/retroshare/Makefile4
-rw-r--r--net-p2p/torrent-file-editor/Makefile6
-rw-r--r--net-p2p/transmission-qt4/Makefile5
-rw-r--r--net-p2p/transmission-qt5/Makefile5
-rw-r--r--net-p2p/valknut/Makefile4
-rw-r--r--net-p2p/zetacoin/Makefile10
19 files changed, 56 insertions, 57 deletions
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index f54a484d5bc0..fa01722a840e 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -89,8 +89,8 @@ MMAP_CONFIGURE_ON= --enable-mmap
MONOLITHIC_CONFIGURE_OFF= --disable-monolithic
PLASMAMULE_CONFIGURE_ON= --enable-plasmamule
-PLASMAMULE_USES= kde:4
-PLASMAMULE_USE= KDE=kdelibs QT4=dbus,gui,moc_build
+PLASMAMULE_USES= kde:4 qt:4
+PLASMAMULE_USE= KDE=kdelibs QT=dbus,gui,moc_build
PLASMAMULE_CONFIGURE_ENV= \
ac_cv_path_KDE4_CONFIG=${KDE_PREFIX}/bin/kde4-config \
KBUILDSYCOCA=${KDE_PREFIX}/bin/kbuildsycoca4 \
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index af2e50c167ce..6da98b226f4b 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -87,8 +87,8 @@ MMAP_CONFIGURE_ON= --enable-mmap
MONOLITHIC_CONFIGURE_OFF= --disable-monolithic
PLASMAMULE_CONFIGURE_ON= --enable-plasmamule
-PLASMAMULE_USES= kde:4
-PLASMAMULE_USE= KDE=kdelibs QT4=dbus,gui,moc_build
+PLASMAMULE_USES= kde:4 qt:4
+PLASMAMULE_USE= KDE=kdelibs QT=dbus,gui,moc_build
PLASMAMULE_CONFIGURE_ENV= \
ac_cv_path_KDE4_CONFIG=${KDE_PREFIX}/bin/kde4-config \
KBUILDSYCOCA=${KDE_PREFIX}/bin/kbuildsycoca4 \
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 2640193f9df8..897fc26b3e8a 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
BROKEN_powerpc64= fails to compile: util.cpp: undefined reference to boost::program_options::to_internal
-USES= autoreconf compiler:c++11-lib gmake libtool pkgconfig shebangfix ssl
+USES= autoreconf compiler:c++11-lib gmake libtool pkgconfig qt:5 shebangfix ssl
USE_GITHUB= yes
GNU_CONFIGURE= yes
@@ -25,13 +25,14 @@ SLAVE_PORT?= no
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
USES+= desktop-file-utils
-USE_QT5= core gui network widgets \
+USE_QT= core gui network widgets \
buildtools_build linguisttools_build qmake_build
BUILD_DEPENDS+= protoc:devel/protobuf
LIB_DEPENDS+= libprotobuf.so:devel/protobuf
-TESTS_USE= QT5=testlib
+TESTS_USES= qt:5
+TESTS_USE= QT=testlib
TESTS_PLIST_FILES= bin/test_bitcoin-qt \
bin/test_bitcoin
.endif
@@ -51,7 +52,8 @@ WALLET_BDBMODERN_DESC= Wallet using modern BDB 5.x or 6.x
ZMQ_DESC= Block and transaction broadcasting with ZeroMQ
DBUS_CONFIGURE_WITH= dbus
-DBUS_USE= QT5=dbus
+DBUS_USES= qt:5
+DBUS_USE= QT=dbus
DEBUG_CONFIGURE_ENABLE= debug
DEBUG_INSTALL_TARGET_OFF= install-strip
diff --git a/net-p2p/dogecoin/Makefile b/net-p2p/dogecoin/Makefile
index 6c5a9c0b3826..e2966a4c4e5b 100644
--- a/net-p2p/dogecoin/Makefile
+++ b/net-p2p/dogecoin/Makefile
@@ -39,8 +39,8 @@ CONFIGURE_ARGS+= --with-incompatible-bdb --disable-tests
GUI_CONFIGURE_ARGS= --with-gui=qt5
GUI_CONFIGURE_OFF= --with-gui=no
-GUI_USE= QT5=buildtools,core,dbus,gui,linguist_build,network,printsupport,testlib,widgets
-GUI_USES= desktop-file-utils
+GUI_USE= QT=buildtools,core,dbus,gui,linguist_build,network,printsupport,testlib,widgets
+GUI_USES= desktop-file-utils qt:5
QRCODES_CONFIGURE_WITH= qrencode
QRCODES_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
diff --git a/net-p2p/eiskaltdcpp-qt/Makefile b/net-p2p/eiskaltdcpp-qt/Makefile
index 5fb86af82865..d2404cc8b506 100644
--- a/net-p2p/eiskaltdcpp-qt/Makefile
+++ b/net-p2p/eiskaltdcpp-qt/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libeiskaltdcpp.so:net-p2p/eiskaltdcpp-lib
MASTERDIR= ${.CURDIR}/../eiskaltdcpp-lib
-USES= cmake gettext compiler:c++11-lib desktop-file-utils ssl
-USE_QT4= gui xml network qmake_build uic_build \
+USES= cmake gettext compiler:c++11-lib desktop-file-utils qt:4 ssl
+USE_QT= gui xml network qmake_build uic_build \
moc_build rcc_build linguisttools_build
OPTIONS_DEFINE= ASPELL FREE_SPACE DBUS_NOTIFY QTSCRIPT QML SQLITE
@@ -41,17 +41,17 @@ ASPELL_CMAKE_BOOL= USE_ASPELL
FREE_SPACE_CMAKE_BOOL= FREE_SPACE_BAR_C
-DBUS_NOTIFY_USE= QT4=dbus
+DBUS_NOTIFY_USE= QT=dbus
DBUS_NOTIFY_CMAKE_BOOL= DBUS_NOTIFY
-QTSCRIPT_USE= QT4=script
+QTSCRIPT_USE= QT=script
QTSCRIPT_RUN_DEPENDS= ${LOCALBASE}/lib/qt4/plugins/script/libqtscript_core.so:devel/qtscriptgenerator
QTSCRIPT_CMAKE_BOOL= USE_JS
-QML_USE= QT4=declarative
+QML_USE= QT=declarative
QML_CMAKE_BOOL= USE_QT_QML
-SQLITE_USE= QT4=sql-sqlite3
+SQLITE_USE= QT=sql-sqlite3
SQLITE_CMAKE_BOOL= USE_QT_SQLITE
.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/ktorrent-kde4/Makefile b/net-p2p/ktorrent-kde4/Makefile
index 3d284a4ad325..6ffffd83b918 100644
--- a/net-p2p/ktorrent-kde4/Makefile
+++ b/net-p2p/ktorrent-kde4/Makefile
@@ -16,9 +16,9 @@ LIB_DEPENDS= libtag.so:audio/taglib \
libgmp.so:math/gmp \
libktorrent.so:net-p2p/libktorrent-kde4
-USES= cmake:outsource gettext kde:4 tar:bzip2
+USES= cmake:outsource gettext kde:4 qt:4 tar:bzip2
USE_KDE= kdelibs automoc4 pimlibs workspace
-USE_QT4= corelib gui network qt3support qtestlib webkit \
+USE_QT= corelib gui network qt3support qtestlib webkit \
qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 5f366eee46c1..28b73526c7ff 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION:R}/
MAINTAINER= kde@FreeBSD.org
COMMENT= BitTorrent client for KDE
-USES= cmake:outsource gettext kde:5 tar:xz
+USES= cmake:outsource gettext kde:5 qt:5 tar:xz
LIB_DEPENDS= libKF5Torrent.so:net-p2p/libktorrent \
libgcrypt.so:security/libgcrypt \
@@ -23,7 +23,7 @@ USE_KDE= archive auth bookmarks codecs completion config configwidgets \
notifyconfig parts plotting service \
solid sonnet syndication textwidgets widgetsaddons \
windowsystem xmlgui
-USE_QT5= core dbus gui network phonon4 script webkit widgets xml \
+USE_QT= core dbus gui network phonon4 script webkit widgets xml \
buildtools_build qmake_build
.include <bsd.port.mk>
diff --git a/net-p2p/libktorrent-kde4/Makefile b/net-p2p/libktorrent-kde4/Makefile
index 37dcf8ffc645..7ccd8c4cad1f 100644
--- a/net-p2p/libktorrent-kde4/Makefile
+++ b/net-p2p/libktorrent-kde4/Makefile
@@ -15,9 +15,9 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgmp.so:math/gmp \
libqca.so:devel/qca
-USES= cmake:outsource gettext kde:4 tar:bzip2
+USES= cmake:outsource gettext kde:4 qt:4 tar:bzip2
USE_KDE= kdelibs automoc4
-USE_QT4= qtestlib_build qmake_build moc_build rcc_build uic_build
+USE_QT= qtestlib_build qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
SHLIB_VER= 5.0.1
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 6c4dd7b9a29c..52426809b629 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -15,10 +15,10 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgmp.so:math/gmp \
libqca-qt5.so:devel/qca@qt5
-USES= cmake:outsource gettext kde:5
+USES= cmake:outsource gettext kde:5 qt:5
USE_KDE= archive completion config coreaddons crash ecm i18n \
jobwidgets kio service solid widgetsaddons
-USE_QT5= core gui network testlib xml \
+USE_QT= core gui network testlib xml \
buildtools_build qmake_build
USE_GITHUB= yes
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index 3b82784da39a..34db7b551d1f 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -19,7 +19,7 @@ NOT_FOR_ARCHS_REASON= fails to configure: "Big Endian not supported"
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libevent.so:devel/libevent
-USES+= autoreconf compiler:c++11-lib gmake libtool pkgconfig ssl
+USES+= autoreconf compiler:c++11-lib gmake libtool pkgconfig qt:5 ssl
USE_GITHUB= yes
GNU_CONFIGURE= yes
@@ -27,13 +27,14 @@ SLAVE_PORT?= no
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
USES+= desktop-file-utils
-USE_QT5= core gui network widgets \
+USE_QT= core gui network widgets \
buildtools_build linguisttools_build qmake_build
BUILD_DEPENDS+= protoc:devel/protobuf
LIB_DEPENDS+= libprotobuf.so:devel/protobuf
-TESTS_USE= QT5=testlib
+TESTS_USES= qt:5
+TESTS_USE= QT=testlib
TESTS_PLIST_FILES= bin/test_litecoin-qt \
bin/test_litecoin
.endif
@@ -49,7 +50,8 @@ WALLET_DESC= Wallet Management Support
ZMQ_DESC= Block and transaction broadcasting with ZeroMQ
DBUS_CONFIGURE_WITH= dbus
-DBUS_USE= QT5=dbus
+DBUS_USES= qt:5
+DBUS_USE= QT=dbus
DEBUG_CONFIGURE_ENABLE= debug
DEBUG_INSTALL_TARGET_OFF= install-strip
diff --git a/net-p2p/namecoin/Makefile b/net-p2p/namecoin/Makefile
index 9e89f8148df8..24b9b220fcbe 100644
--- a/net-p2p/namecoin/Makefile
+++ b/net-p2p/namecoin/Makefile
@@ -26,7 +26,7 @@ QRCODES_DESC= QR code display support
USE_GITHUB= yes
-USES= bdb:48 gmake compiler:c++11-lib ssl
+USES= bdb:48 gmake compiler:c++11-lib qt:4 ssl
MAKE_JOBS_UNSAFE=yes
CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
@@ -36,7 +36,7 @@ CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
-USE_QT4= corelib network gui qmake_build linguist_build uic_build moc_build rcc_build
+USE_QT= corelib network gui qmake_build linguist_build uic_build moc_build rcc_build
BINARY= namecoin-qt
LIB_DEPENDS+= libprotobuf.so:devel/protobuf
@@ -54,7 +54,7 @@ QMAKE_USE_QRCODE=0
.endif
.if ${PORT_OPTIONS:MDBUS}
-USE_QT4+= dbus
+USE_QT+= dbus
QMAKE_USE_DBUS= 1
.else
QMAKE_USE_DBUS= 0
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 782c16dcca5c..0e79fa8ecf11 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -24,16 +24,15 @@ default_LIB_DEPENDS= libGeoIP.so:net/GeoIP
nox_PKGNAMESUFFIX= -nox
nox_PLIST= ${NONEXISTENT}
-USES= compiler:c++11-lib pkgconfig tar:xz
+USES= compiler:c++11-lib pkgconfig qmake:no_env qt:5 tar:xz
GNU_CONFIGURE= yes
-USE_QT5= core network xml buildtools_build linguisttools_build qmake_build
+USE_QT= core network xml buildtools_build linguisttools_build qmake_build
CONFIGURE_ARGS= CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
-QT_NONSTANDARD= yes
DESTDIRNAME= INSTALL_ROOT
.if ${FLAVOR} == default
USES+= desktop-file-utils
-USE_QT5+= concurrent gui svg widgets
+USE_QT+= concurrent gui svg widgets
USE_GL= gl
.endif
@@ -50,7 +49,7 @@ OPTIONS_DEFAULT= DBUS
DEBUG_CONFIGURE_ENABLE= debug
DBUS_CONFIGURE_ENABLE= qt-dbus
-DBUS_USE= qt5=dbus
+DBUS_USE= qt=dbus
PORTDOCS= AUTHORS Changelog README.md
diff --git a/net-p2p/qtum/Makefile b/net-p2p/qtum/Makefile
index 0e3685534f5a..17a675737e48 100644
--- a/net-p2p/qtum/Makefile
+++ b/net-p2p/qtum/Makefile
@@ -36,8 +36,8 @@ CONFIGURE_ARGS= --disable-man \
--with-qrencode \
--without-libs
-USES= autoreconf bdb:5+ compiler:c++11-lib gmake libtool pkgconfig ssl
-USE_QT5= buildtools core dbus gui linguisttools network testlib widgets
+USES= autoreconf bdb:5+ compiler:c++11-lib gmake libtool pkgconfig qt:5 ssl
+USE_QT= buildtools core dbus gui linguisttools network testlib widgets
USE_GITHUB= yes
GH_TUPLE= qtumproject:qtum:${DISTVERSIONPREFIX}${PORTVERSION} \
qtumproject:cpp-eth-qtum:8db7fc170f7c0a475bc40c:cppeth/src/cpp-ethereum
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 4dc6d873812b..d4be9f3a6fdc 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -25,13 +25,13 @@ LIB_DEPENDS= libsqlcipher.so:databases/sqlcipher \
libcurl.so:ftp/curl \
libmicrohttpd.so:www/libmicrohttpd
-USES= compiler:features desktop-file-utils dos2unix pkgconfig qmake ssl
+USES= compiler:features desktop-file-utils dos2unix pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
GH_ACCOUNT= RetroShare
GH_PROJECT= RetroShare
USE_GNOME= libxml2 libxslt
USE_GL= gl
-USE_QT5= core gui multimedia printsupport network widgets xml \
+USE_QT= core gui multimedia printsupport network widgets xml \
buildtools_build uitools_build
DOS2UNIX_FILES= retroshare-nogui/src/retroshare-nogui.pro
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
index b0703a3ebff7..53504d9e3c65 100644
--- a/net-p2p/torrent-file-editor/Makefile
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -29,8 +29,10 @@ QT5_DESC= Build against Qt 5 instead of Qt 4
DONATION_CMAKE_OFF= -DDISABLE_DONATION:BOOL=ON
-QT5_USE= QT5=${_QT5_DEPS:ts,}
-QT5_USE_OFF= QT4=${_QT4_DEPS:ts,}
+QT5_USES= qt:5
+QT5_USES_OFF= qt:4
+QT5_USE= QT=${_QT5_DEPS:ts,}
+QT5_USE_OFF= QT=${_QT4_DEPS:ts,}
QT5_LIB_DEPENDS_OFF= libqjson.so:devel/qjson@qt4
QT5_CMAKE_ON= -DQT5_BUILD:BOOL=ON
diff --git a/net-p2p/transmission-qt4/Makefile b/net-p2p/transmission-qt4/Makefile
index 9c6fa44b162c..7fafc40e110d 100644
--- a/net-p2p/transmission-qt4/Makefile
+++ b/net-p2p/transmission-qt4/Makefile
@@ -17,10 +17,9 @@ MASTERDIR= ${.CURDIR}/../transmission-cli
PLIST= ${.CURDIR}/pkg-plist
SLAVEPORT= qt4
-QT_NONSTANDARD= yes
-USE_QT4= moc_build qmake_build uic_build rcc_build \
+USE_QT= moc_build qmake_build uic_build rcc_build \
corelib gui dbus network xml
-USES= compiler:c++11-lib desktop-file-utils
+USES= compiler:c++11-lib desktop-file-utils qmake:no_env qt:4
EXTRA_CONF_ARGS=--disable-cli \
--disable-daemon \
diff --git a/net-p2p/transmission-qt5/Makefile b/net-p2p/transmission-qt5/Makefile
index 3fa921fb7a48..fd04d9c8d2fe 100644
--- a/net-p2p/transmission-qt5/Makefile
+++ b/net-p2p/transmission-qt5/Makefile
@@ -17,9 +17,8 @@ MASTERDIR= ${.CURDIR}/../transmission-cli
PLIST= ${.CURDIR}/pkg-plist
SLAVEPORT= qt5
-QT_NONSTANDARD= yes
-USE_QT5= buildtools_build qmake_build core dbus gui network widgets
-USES= compiler:c++11-lib desktop-file-utils
+USE_QT= buildtools_build qmake_build core dbus gui network widgets
+USES= compiler:c++11-lib desktop-file-utils qmake:no_env qt:5
EXTRA_CONF_ARGS=--disable-cli \
--disable-daemon \
diff --git a/net-p2p/valknut/Makefile b/net-p2p/valknut/Makefile
index 72d091829aba..639a1e357cf8 100644
--- a/net-p2p/valknut/Makefile
+++ b/net-p2p/valknut/Makefile
@@ -17,9 +17,9 @@ LIB_DEPENDS= libdc.so:net-p2p/dclib \
WRKSRC= ${WRKDIR}/${DISTNAME}
-USE_QT4= corelib gui network qt3support \
+USE_QT= corelib gui network qt3support \
moc_build uic_build rcc_build linguisttools_build
-USES= gmake perl5 pkgconfig tar:bzip2
+USES= gmake perl5 pkgconfig qt:4 tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/net-p2p/zetacoin/Makefile b/net-p2p/zetacoin/Makefile
index 0cbf3248cf7c..c3c7d2900c2a 100644
--- a/net-p2p/zetacoin/Makefile
+++ b/net-p2p/zetacoin/Makefile
@@ -44,9 +44,9 @@ X11_CONFIGURE_ON= --without-daemon
X11_CONFIGURE_OFF= --with-daemon
X11_BUILD_DEPENDS= protoc:devel/protobuf
X11_LIB_DEPENDS= libprotobuf.so:devel/protobuf
-X11_USE= qt4=corelib,network,gui,qmake_build,linguisttools_build \
- qt4=uic_build,moc_build,rcc_build,qtestlib_build
-X11_USES= desktop-file-utils
+X11_USE= qt=corelib,network,gui,qmake_build,linguisttools_build \
+ qt=uic_build,moc_build,rcc_build,qtestlib_build
+X11_USES= desktop-file-utils qmake:no_env qt:4
WALLET_CONFIGURE_ENABLE=wallet
WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR}
@@ -78,10 +78,6 @@ PLIST_SUB+= EXECUTABLE_QT=bin/${QT_BINARY} \
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MX11}
-QT_NONSTANDARD= yes
-.endif
-
# tests will currently fail
.if ${PORT_OPTIONS:MTEST}
BROKEN= automated testing fails