aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /net-p2p
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/eiskaltdcpp-gtk/Makefile1
-rw-r--r--net-p2p/eiskaltdcpp-gtk/files/patch-eiskaltdcpp-gtk_src_notify.cc11
-rw-r--r--net-p2p/transmission-gtk2/Makefile4
3 files changed, 14 insertions, 2 deletions
diff --git a/net-p2p/eiskaltdcpp-gtk/Makefile b/net-p2p/eiskaltdcpp-gtk/Makefile
index 72485e51604b..cd3bf20f9068 100644
--- a/net-p2p/eiskaltdcpp-gtk/Makefile
+++ b/net-p2p/eiskaltdcpp-gtk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= eiskaltdcpp-gtk
PORTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
diff --git a/net-p2p/eiskaltdcpp-gtk/files/patch-eiskaltdcpp-gtk_src_notify.cc b/net-p2p/eiskaltdcpp-gtk/files/patch-eiskaltdcpp-gtk_src_notify.cc
new file mode 100644
index 000000000000..ae4fd4637498
--- /dev/null
+++ b/net-p2p/eiskaltdcpp-gtk/files/patch-eiskaltdcpp-gtk_src_notify.cc
@@ -0,0 +1,11 @@
+--- eiskaltdcpp-gtk/src/notify.cc.orig 2011-08-12 11:54:13.000000000 +0200
++++ eiskaltdcpp-gtk/src/notify.cc 2011-08-12 11:54:24.000000000 +0200
+@@ -69,7 +69,7 @@ void Notify::init()
+ {
+ #ifdef USE_LIBNOTIFY
+ notify_init(g_get_application_name());
+- notification = notify_notification_new("template", "template", NULL, NULL);
++ notification = notify_notification_new("template", "template", NULL);
+ #endif // USE_LIBNOTIFY
+ action = FALSE;
+ }
diff --git a/net-p2p/transmission-gtk2/Makefile b/net-p2p/transmission-gtk2/Makefile
index f173d1f944e6..bc62edd95848 100644
--- a/net-p2p/transmission-gtk2/Makefile
+++ b/net-p2p/transmission-gtk2/Makefile
@@ -5,14 +5,14 @@
# $FreeBSD$
#
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -gtk2
MAINTAINER= crees@FreeBSD.org
COMMENT= A fast and lightweight GTK+2 BitTorrent client
LIB_DEPENDS= ${GEN_LIB_DEPENDS} \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= ${GEN_RUN_DEPENDS} \
xdg-open:${PORTSDIR}/devel/xdg-utils