aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2010-07-01 15:19:44 +0800
committerdougb <dougb@FreeBSD.org>2010-07-01 15:19:44 +0800
commit7ce860f22a4e9e1f9373848e8dcf894f152e04e5 (patch)
tree835c41afc6a96b59a1fc2fceaf69c5806ebd6da7 /net-p2p
parent2380e67bb87b5295a6502445a885fdd051a854f8 (diff)
downloadfreebsd-ports-gnome-7ce860f22a4e9e1f9373848e8dcf894f152e04e5.tar.gz
freebsd-ports-gnome-7ce860f22a4e9e1f9373848e8dcf894f152e04e5.tar.zst
freebsd-ports-gnome-7ce860f22a4e9e1f9373848e8dcf894f152e04e5.zip
Add a slave port for the python binding
Major effort from the PR, tweaks and bugs from me PR: ports/144337 Submitted by: lioux Feature safe: yes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/libtorrent-rasterbar-15-python/Makefile48
-rw-r--r--net-p2p/libtorrent-rasterbar-15-python/pkg-plist1
3 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 4d5d0ca67b7c..4e7baa04ad46 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -64,6 +64,7 @@
SUBDIR += libtorrent-devel
SUBDIR += libtorrent-rasterbar-14
SUBDIR += libtorrent-rasterbar-15
+ SUBDIR += libtorrent-rasterbar-15-python
SUBDIR += limewire
SUBDIR += linux-agsatellite
SUBDIR += linux-edonkey-core
diff --git a/net-p2p/libtorrent-rasterbar-15-python/Makefile b/net-p2p/libtorrent-rasterbar-15-python/Makefile
new file mode 100644
index 000000000000..1b359875c978
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-15-python/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: libtorrent-rasterbar-15-python
+# Date created: Mon Apr 29 01:53:20 UTC 2010
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+#
+# $FreeBSD$
+
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+COMMENT= Python bindings for libtorrent-rasterbar-15
+CATEGORIES= net-p2p python
+
+CONFLICTS+= py*-libtorrent-rasterbar-0.14.*
+
+USE_PYTHON= 2.5+
+
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>=0.6:${PORTSDIR}/devel/py-setuptools
+LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python-libs \
+ torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15
+
+BUILD_WRKSRC= ${WRKSRC}/bindings/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+PLIST= ${.CURDIR}/pkg-plist
+
+INSTALLS_EGGINFO= yes
+PYDISTUTILS_EGGINFO= python_libtorrent-${PORTVERSION}-py${PYTHON_VER}.egg-info
+
+NOPORTDOCS= yes
+
+slave-post-patch:
+ @${REINPLACE_CMD} -E -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/bindings/python/setup.py.in
+
+slave-post-install:
+# fix installation permissions
+ @${CHMOD} ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/libtorrent.so
+
+MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar-15
+.include "${MASTERDIR}/Makefile"
+
+##
+# information available after <bsd.port.pre.mk>
+##
+# insure python paths are correctly identified
+CONFIGURE_ENV+= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
+ PYTHON_VERSION="${PYTHON_VERSION}"
+# prefix PKGNAME with python- so that the egg info file is properly named.
+PYDISTUTILS_PKGNAME= python-${PORTNAME}
diff --git a/net-p2p/libtorrent-rasterbar-15-python/pkg-plist b/net-p2p/libtorrent-rasterbar-15-python/pkg-plist
new file mode 100644
index 000000000000..128a4b8d4812
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-15-python/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/libtorrent.so