aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-11-06 20:55:31 +0800
committernemysis <nemysis@FreeBSD.org>2013-11-06 20:55:31 +0800
commitb4f88ab851c809921a2e4b12ed83ab7fb3fd1592 (patch)
tree1ff063745e853036c70e77f6e8944256b763b5eb /net-p2p
parent75d23ea77d28c2dc325b34c0363f0cc27bf51c31 (diff)
downloadfreebsd-ports-gnome-b4f88ab851c809921a2e4b12ed83ab7fb3fd1592.tar.gz
freebsd-ports-gnome-b4f88ab851c809921a2e4b12ed83ab7fb3fd1592.tar.zst
freebsd-ports-gnome-b4f88ab851c809921a2e4b12ed83ab7fb3fd1592.zip
net-p2p/qbittorrent
- Update to 3.1.2 - Change dependency to net-p2p/libtorrent-rasterbar - USE_QT4 add linguist_build uic_build - Change from QB_NOX_SLAVE to SLAVE_PORT - Add do-configure - Support STAGEDIR net-p2p/qbittorrent-nox11 - Change from QB_NOX_SLAVE to SLAVE_PORT - Support STAGEDIR - Change and cleanup qbittorrent-nox11 to not conflict with master port - Add SLAVE_PORT=yes - Remove pkg-descr Approved by: wg (mentor)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent-nox11/Makefile12
-rw-r--r--net-p2p/qbittorrent-nox11/pkg-descr21
-rw-r--r--net-p2p/qbittorrent/Makefile43
-rw-r--r--net-p2p/qbittorrent/distinfo4
-rw-r--r--net-p2p/qbittorrent/pkg-plist2
5 files changed, 32 insertions, 50 deletions
diff --git a/net-p2p/qbittorrent-nox11/Makefile b/net-p2p/qbittorrent-nox11/Makefile
index ff00ec115808..643404a2355d 100644
--- a/net-p2p/qbittorrent-nox11/Makefile
+++ b/net-p2p/qbittorrent-nox11/Makefile
@@ -7,13 +7,13 @@ COMMENT= Bittorrent client using libtorrent-rasterbar, web UI version
MASTERDIR= ${.CURDIR}/../qbittorrent
-DESCR= ${.CURDIR}/pkg-descr
-PLIST= ${.CURDIR}/pkg-plist
-PLIST_FILES+= bin/qbittorrent-nox
+DESCR= ${.CURDIR}/../qbittorrent/pkg-descr
+PLIST_FILES+= bin/qbittorrent-nox \
+ man/man1/qbittorrent-nox.1.gz
+PLIST= ${NONEXISTENT}
-MAN1= qbittorrent-nox.1
+SLAVE_PORT= yes
-QB_NOX_SLAVE= true
+OPTIONS_EXCLUDE= DOCS
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/qbittorrent-nox11/pkg-descr b/net-p2p/qbittorrent-nox11/pkg-descr
deleted file mode 100644
index 5d4b44000157..000000000000
--- a/net-p2p/qbittorrent-nox11/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-qBittorrent is the closest open source (GNU GPL v2 licensed) equivalent to
-popular uTorrent. It is based on libtorrent-rasterbar.
-
-Features:
-
- - Remote control through a Web user interface (nearly identical to
- the the regular UI, all in Ajax)
- - Well-integrated and extensible Search Engine
- - Simultaneous search in most famous BitTorrent search sites
- - Per-category-specific search requests (e.g. Books, Music, Movies)
- - All BitTorrent extensions: DHT, Peer Exchange, Full encryption,
- Magnet URI, uTP
- - Advanced control over trackers, peers, and torrents: queueing and
- prioritizing, content selection and prioritizing
- - UPnP/NAT-PMP port forwarding support
- - Available in ~25 languages (Unicode support)
- - uTorrent spoofing to bypass private trackers whitelisting
- - Advanced RSS support with download filters (inc. regex)
- - IP Filtering (eMule and PeerGuardian compatible)
-
-WWW: http://www.qbittorrent.org/
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 5f7185d365d4..69c27fe4a79f 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qbittorrent
-PORTVERSION= 3.0.11
+PORTVERSION= 3.1.2
PORTREVISION?= 0
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
@@ -13,49 +13,50 @@ COMMENT?= Bittorrent client using Qt4 and libtorrent-rasterbar
LICENSE= GPLv2
# ABI versions specified on purpose for libtorrent-rasterbar
-LIB_DEPENDS= libtorrent-rasterbar.so:${PORTSDIR}/net-p2p/libtorrent-rasterbar-16 \
- libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+LIB_DEPENDS= libtorrent-rasterbar.so:${PORTSDIR}/net-p2p/libtorrent-rasterbar \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
USES= pkgconfig
-HAS_CONFIGURE= yes
-USE_QT4= corelib network qmake_build moc_build rcc_build
+USE_QT4= corelib network qmake_build linguist_build moc_build rcc_build uic_build
QT_NONSTANDARD= yes
+DESTDIRNAME= INSTALL_ROOT
-MAN1?= qbittorrent.1
-
-.if !defined(QB_NOX_SLAVE)
+.if !defined(SLAVE_PORT)
LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
-USE_QT4+= gui xml uic_build
+USE_QT4+= gui xml
INSTALLS_ICONS= yes
OPTIONS_DEFINE= DBUS
-.else
-CONFIGURE_ARGS+= --disable-gui
.endif
PORTDOCS= AUTHORS Changelog README TODO
OPTIONS_DEFINE= DOCS DBUS
-NO_STAGE= yes
+DBUS_CONFIGURE_ENABLE= qt-dbus
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDBUS}
USE_QT4+= dbus
+.endif
+
+do-configure:
+.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "no"
+ @cd ${WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} ./configure --prefix=${PREFIX}
.else
-CONFIGURE_ARGS+= --disable-qt-dbus
+ @cd ${WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} ./configure --prefix=${PREFIX} --disable-gui
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.if !defined(QB_NOX_SLAVE)
- @${STRIP_CMD} ${PREFIX}/bin/qbittorrent
+.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "no"
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qbittorrent
+ ${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
.else
- @${STRIP_CMD} ${PREFIX}/bin/qbittorrent-nox
- ${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent-nox.1 ${MAN1PREFIX}/man/man1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qbittorrent-nox
+ ${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent-nox.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
.endif
.include <bsd.port.mk>
diff --git a/net-p2p/qbittorrent/distinfo b/net-p2p/qbittorrent/distinfo
index a0d2f614ebd2..656c003f8a59 100644
--- a/net-p2p/qbittorrent/distinfo
+++ b/net-p2p/qbittorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qbittorrent-3.0.11.tar.gz) = bce32693c265bb330776337da6e88be3e5e50cf218b2fa8c5cd6c515e7158480
-SIZE (qbittorrent-3.0.11.tar.gz) = 5097233
+SHA256 (qbittorrent-3.1.2.tar.gz) = a72e8ff9e2ccc49653b2fe78fc3e1213ed474c393578f39aa8a3d70cf43e3c8b
+SIZE (qbittorrent-3.1.2.tar.gz) = 3883015
diff --git a/net-p2p/qbittorrent/pkg-plist b/net-p2p/qbittorrent/pkg-plist
index d8b05885d17c..cb46909da9c4 100644
--- a/net-p2p/qbittorrent/pkg-plist
+++ b/net-p2p/qbittorrent/pkg-plist
@@ -1,4 +1,5 @@
bin/qbittorrent
+man/man1/qbittorrent.1.gz
share/applications/qBittorrent.desktop
share/icons/hicolor/128x128/apps/qbittorrent.png
share/icons/hicolor/16x16/apps/qbittorrent.png
@@ -12,3 +13,4 @@ share/icons/hicolor/64x64/apps/qbittorrent.png
share/icons/hicolor/72x72/apps/qbittorrent.png
share/icons/hicolor/96x96/apps/qbittorrent.png
share/pixmaps/qbittorrent.png
+@dirrmtry share/applications