aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2015-07-16 04:59:19 +0800
committerpgollucci <pgollucci@FreeBSD.org>2015-07-16 04:59:19 +0800
commitc36e756587a215ce43d318cd5da41c7cb458786a (patch)
tree01f3a6ec83a3b4594ef06c5cdb9b8baccf177b38 /net-p2p
parentd5d968974aa0905ca57b5a07a51103721a58f602 (diff)
downloadfreebsd-ports-gnome-c36e756587a215ce43d318cd5da41c7cb458786a.tar.gz
freebsd-ports-gnome-c36e756587a215ce43d318cd5da41c7cb458786a.tar.zst
freebsd-ports-gnome-c36e756587a215ce43d318cd5da41c7cb458786a.zip
net-p2p/zetacoin: cleanup
- Remove Qt build tools from runtime dependencies; - Use qt4-linguisttools instead of qt4-linguist; - Add explicit dependency on qt4-network; - Regen patches. PR: 201024 Submitted by: s3erios@gmail.com Approved by: bradleythughes (maintainer)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/zetacoin/Makefile3
-rw-r--r--net-p2p/zetacoin/files/patch-src_Makefile.include (renamed from net-p2p/zetacoin/files/patch-Makefile_include_editSedCommands.patch)4
-rw-r--r--net-p2p/zetacoin/files/patch-src_qt_Makefile.am (renamed from net-p2p/zetacoin/files/patch-qt_makefile_am_editSedCommands.patch)6
3 files changed, 5 insertions, 8 deletions
diff --git a/net-p2p/zetacoin/Makefile b/net-p2p/zetacoin/Makefile
index 33e1cad09e4a..b487efa32893 100644
--- a/net-p2p/zetacoin/Makefile
+++ b/net-p2p/zetacoin/Makefile
@@ -34,7 +34,8 @@ X11_CONFIGURE_WITH= gui
X11_CONFIGURE_ON= --without-daemon
X11_CONFIGURE_OFF= --with-daemon
X11_BUILD_DEPENDS= protoc:${PORTSDIR}/devel/protobuf
-X11_USE= qt4=corelib,gui,qmake_build,linguist,uic,moc,rcc,qtestlib_build
+X11_USE= qt4=corelib,network,gui,qmake_build,linguisttools_build \
+ qt4=uic_build,moc_build,rcc_build,qtestlib_build
X11_USES= desktop-file-utils
WALLET_CONFIGURE_ENABLE= wallet
diff --git a/net-p2p/zetacoin/files/patch-Makefile_include_editSedCommands.patch b/net-p2p/zetacoin/files/patch-src_Makefile.include
index 4727e95faeef..0360627faa04 100644
--- a/net-p2p/zetacoin/files/patch-Makefile_include_editSedCommands.patch
+++ b/net-p2p/zetacoin/files/patch-src_Makefile.include
@@ -1,6 +1,4 @@
-diff --git a/src/Makefile.include b/src/Makefile.include
-index 2fc6cd7..cdd16f5 100644
---- a/src/Makefile.include
+--- src/Makefile.include.orig 2014-12-12 22:22:31 UTC
+++ src/Makefile.include
@@ -40,18 +40,18 @@ $(LIBBITCOINQT):
ui_%.h: %.ui
diff --git a/net-p2p/zetacoin/files/patch-qt_makefile_am_editSedCommands.patch b/net-p2p/zetacoin/files/patch-src_qt_Makefile.am
index 8a72618f8aec..9c9cb0da5ddb 100644
--- a/net-p2p/zetacoin/files/patch-qt_makefile_am_editSedCommands.patch
+++ b/net-p2p/zetacoin/files/patch-src_qt_Makefile.am
@@ -1,8 +1,6 @@
-diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
-index 648971b..97b2ec4 100644
---- a/src/qt/Makefile.am
+--- src/qt/Makefile.am.orig 2014-12-12 22:22:31 UTC
+++ src/qt/Makefile.am
-@@ -373,7 +373,7 @@ translate: bitcoinstrings.cpp $(QT_FORMS_UI) $(QT_FORMS_UI) $(BITCOIN_QT_CPP) $(
+@@ -373,7 +373,7 @@ translate: bitcoinstrings.cpp $(QT_FORMS
$(QT_QRC_CPP): $(QT_QRC) $(QT_QM) $(QT_FORMS_H) $(RES_ICONS) $(RES_IMAGES) $(RES_MOVIES) $(PROTOBUF_H)
@cd $(abs_srcdir); test -f $(RCC) && QT_SELECT=$(QT_SELECT) $(RCC) -name bitcoin -o $(abs_builddir)/$@ $< || \
echo error: could not build $@