aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-02-02 06:26:42 +0800
committerswills <swills@FreeBSD.org>2014-02-02 06:26:42 +0800
commite60d9ca00a591f0ea8856c7ebed9a2c007ca7e84 (patch)
tree88d4dbac330f390aa8e6ec169e9d50b206bb5cdb /net-p2p
parent564a829363a43864ea1602748f186da12371be99 (diff)
downloadfreebsd-ports-gnome-e60d9ca00a591f0ea8856c7ebed9a2c007ca7e84.tar.gz
freebsd-ports-gnome-e60d9ca00a591f0ea8856c7ebed9a2c007ca7e84.tar.zst
freebsd-ports-gnome-e60d9ca00a591f0ea8856c7ebed9a2c007ca7e84.zip
- Update to 1.5.0
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dogecoin/Makefile19
-rw-r--r--net-p2p/dogecoin/distinfo4
-rw-r--r--net-p2p/dogecoin/files/extra-patch-endian47
-rw-r--r--net-p2p/dogecoin/files/extra-patch-src__leveldb__Makefile20
-rw-r--r--net-p2p/dogecoin/files/patch-src__qt__qtipcserver.cpp11
-rw-r--r--net-p2p/dogecoin/files/patch-src__serialize.h22
6 files changed, 79 insertions, 44 deletions
diff --git a/net-p2p/dogecoin/Makefile b/net-p2p/dogecoin/Makefile
index ac89c38e160f..4fe2a0ad6344 100644
--- a/net-p2p/dogecoin/Makefile
+++ b/net-p2p/dogecoin/Makefile
@@ -2,12 +2,8 @@
# $FreeBSD$
PORTNAME= dogecoin
-PORTVERSION= 1.4
-PORTREVISION= 2
+PORTVERSION= 1.5.0
CATEGORIES= net-p2p finance
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://people.freebsd.org/~swills/ \
- GH
MAINTAINER= swills@FreeBSD.org
COMMENT= Virtual Peer-to-Peer Currency Client
@@ -24,10 +20,9 @@ UPNP_DESC= Build with UPNP support
QRCODES_DESC= Build with QR code display
USE_GITHUB= yes
-GH_ACCOUNT= dogecoin
-GH_PROJECT= dogecoin
-GH_COMMIT= d484474
-GH_TAGNAME= ${GH_COMMIT}
+GH_ACCOUNT= ${PORTNAME}
+GH_COMMIT= be94b62
+GH_TAGNAME= v${PORTVERSION}
USES= gmake compiler:c++11-lib
USE_OPENSSL= yes
@@ -40,6 +35,12 @@ CXXFLAGS+= -Wno-invalid-offsetof
.include <bsd.port.options.mk>
+.if ${OSVERSION} >= 1000000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-endian
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__leveldb__Makefile
+.endif
+
.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
USE_QT4= corelib gui qmake_build linguist uic moc rcc
BINARY= dogecoin-qt
diff --git a/net-p2p/dogecoin/distinfo b/net-p2p/dogecoin/distinfo
index d85e6a37eb4a..6cc37b37ec76 100644
--- a/net-p2p/dogecoin/distinfo
+++ b/net-p2p/dogecoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dogecoin-1.4.tar.gz) = ddc026ecb6a8f00b7f8693d93302bc59074802160f8f7818d972529bca9c30fa
-SIZE (dogecoin-1.4.tar.gz) = 13191784
+SHA256 (dogecoin-1.5.0.tar.gz) = 43832d6a147471b759599b4dd080b88ed4d39c119231129d1febd2f1e991cf06
+SIZE (dogecoin-1.5.0.tar.gz) = 3509184
diff --git a/net-p2p/dogecoin/files/extra-patch-endian b/net-p2p/dogecoin/files/extra-patch-endian
new file mode 100644
index 000000000000..8a016d89daad
--- /dev/null
+++ b/net-p2p/dogecoin/files/extra-patch-endian
@@ -0,0 +1,47 @@
+--- src/scrypt.cpp.orig 2013-12-09 18:10:12.046606050 +0000
++++ src/scrypt.cpp 2013-12-09 18:10:25.898605023 +0000
+@@ -34,22 +34,6 @@
+ #include <string.h>
+ #include <openssl/sha.h>
+
+-static inline uint32_t be32dec(const void *pp)
+-{
+- const uint8_t *p = (uint8_t const *)pp;
+- return ((uint32_t)(p[3]) + ((uint32_t)(p[2]) << 8) +
+- ((uint32_t)(p[1]) << 16) + ((uint32_t)(p[0]) << 24));
+-}
+-
+-static inline void be32enc(void *pp, uint32_t x)
+-{
+- uint8_t *p = (uint8_t *)pp;
+- p[3] = x & 0xff;
+- p[2] = (x >> 8) & 0xff;
+- p[1] = (x >> 16) & 0xff;
+- p[0] = (x >> 24) & 0xff;
+-}
+-
+ typedef struct HMAC_SHA256Context {
+ SHA256_CTX ictx;
+ SHA256_CTX octx;
+--- src/scrypt.h.orig 2013-12-09 15:26:17.343282984 +0000
++++ src/scrypt.h 2013-12-09 15:45:11.032205545 +0000
+@@ -17,19 +17,4 @@
+ PBKDF2_SHA256(const uint8_t *passwd, size_t passwdlen, const uint8_t *salt,
+ size_t saltlen, uint64_t c, uint8_t *buf, size_t dkLen);
+
+-static inline uint32_t le32dec(const void *pp)
+-{
+- const uint8_t *p = (uint8_t const *)pp;
+- return ((uint32_t)(p[0]) + ((uint32_t)(p[1]) << 8) +
+- ((uint32_t)(p[2]) << 16) + ((uint32_t)(p[3]) << 24));
+-}
+-
+-static inline void le32enc(void *pp, uint32_t x)
+-{
+- uint8_t *p = (uint8_t *)pp;
+- p[0] = x & 0xff;
+- p[1] = (x >> 8) & 0xff;
+- p[2] = (x >> 16) & 0xff;
+- p[3] = (x >> 24) & 0xff;
+-}
+ #endif
diff --git a/net-p2p/dogecoin/files/extra-patch-src__leveldb__Makefile b/net-p2p/dogecoin/files/extra-patch-src__leveldb__Makefile
new file mode 100644
index 000000000000..dfe8b2cc4009
--- /dev/null
+++ b/net-p2p/dogecoin/files/extra-patch-src__leveldb__Makefile
@@ -0,0 +1,20 @@
+--- src/leveldb/Makefile.orig 2014-02-01 18:59:21.000000000 +0000
++++ src/leveldb/Makefile 2014-02-01 18:59:30.000000000 +0000
+@@ -98,7 +98,7 @@
+
+ $(LIBRARY): $(LIBOBJECTS)
+ rm -f $@
+- $(AR) -rs $@ $(LIBOBJECTS)
++ $(AR) -s $@ $(LIBOBJECTS)
+
+ db_bench: db/db_bench.o $(LIBOBJECTS) $(TESTUTIL)
+ $(CXX) $(LDFLAGS) db/db_bench.o $(LIBOBJECTS) $(TESTUTIL) -o $@ $(LIBS)
+@@ -174,7 +174,7 @@
+
+ $(MEMENVLIBRARY) : $(MEMENVOBJECTS)
+ rm -f $@
+- $(AR) -rs $@ $(MEMENVOBJECTS)
++ $(AR) -s $@ $(MEMENVOBJECTS)
+
+ memenv_test : helpers/memenv/memenv_test.o $(MEMENVLIBRARY) $(LIBRARY) $(TESTHARNESS)
+ $(CXX) $(LDFLAGS) helpers/memenv/memenv_test.o $(MEMENVLIBRARY) $(LIBRARY) $(TESTHARNESS) -o $@ $(LIBS)
diff --git a/net-p2p/dogecoin/files/patch-src__qt__qtipcserver.cpp b/net-p2p/dogecoin/files/patch-src__qt__qtipcserver.cpp
deleted file mode 100644
index 55632684e4be..000000000000
--- a/net-p2p/dogecoin/files/patch-src__qt__qtipcserver.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/qt/qtipcserver.cpp.orig 2014-01-18 05:21:31.335425774 +0000
-+++ src/qt/qtipcserver.cpp 2014-01-18 05:22:33.976421840 +0000
-@@ -21,7 +21,7 @@
-
- static void ipcThread2(void* pArg);
-
--#ifdef MAC_OSX
-+#if defined(MAC_OSX) || defined(__FreeBSD__)
- // URI handling not implemented on OSX yet
-
- void ipcInit() { }
diff --git a/net-p2p/dogecoin/files/patch-src__serialize.h b/net-p2p/dogecoin/files/patch-src__serialize.h
deleted file mode 100644
index e13520bf9f7d..000000000000
--- a/net-p2p/dogecoin/files/patch-src__serialize.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./src/serialize.h.orig 2013-09-24 01:50:35.661706153 +0000
-+++ ./src/serialize.h 2013-09-24 01:50:52.913703572 +0000
-@@ -895,19 +895,6 @@
- iterator insert(iterator it, const char& x=char()) { return vch.insert(it, x); }
- void insert(iterator it, size_type n, const char& x) { vch.insert(it, n, x); }
-
-- void insert(iterator it, const_iterator first, const_iterator last)
-- {
-- assert(last - first >= 0);
-- if (it == vch.begin() + nReadPos && (unsigned int)(last - first) <= nReadPos)
-- {
-- // special case for inserting at the front when there's room
-- nReadPos -= (last - first);
-- memcpy(&vch[nReadPos], &first[0], last - first);
-- }
-- else
-- vch.insert(it, first, last);
-- }
--
- void insert(iterator it, std::vector<char>::const_iterator first, std::vector<char>::const_iterator last)
- {
- assert(last - first >= 0);