aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-09-02 19:29:31 +0800
committerAdriaan de Groot <adridg@FreeBSD.org>2019-09-02 19:29:31 +0800
commitf0aa0449dbf5189769c0cde4bb9ab19eaa32e9b5 (patch)
tree83dd3ea2cbf780961540da2a106cfeda3cc72b28 /net-p2p
parent3516236cdbfa38dc0cd4e75b53f0844e6f9e5c44 (diff)
downloadfreebsd-ports-gnome-f0aa0449dbf5189769c0cde4bb9ab19eaa32e9b5.tar.gz
freebsd-ports-gnome-f0aa0449dbf5189769c0cde4bb9ab19eaa32e9b5.tar.zst
freebsd-ports-gnome-f0aa0449dbf5189769c0cde4bb9ab19eaa32e9b5.zip
Update ktorrent to latest upstream release, 5.1.2
- also chase attendant libktorrent - switch libktorrent to release tarballs instead of GitHub From the release announcement, Fixes: * Fix HTTP seeding. * Fix memory corruption in ScanFolder plugin. * Fix a few issues found by clang-tidy. * Some build fixes (missing include headers) that get triggered on certain versions of Qt/KF5 frameworks.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Makefile8
-rw-r--r--net-p2p/ktorrent/distinfo6
-rw-r--r--net-p2p/ktorrent/files/patch-gentoo-kf5-5.61-headers24
-rw-r--r--net-p2p/libktorrent/Makefile14
-rw-r--r--net-p2p/libktorrent/distinfo6
-rw-r--r--net-p2p/libktorrent/pkg-plist60
6 files changed, 76 insertions, 42 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 522a0b746e84..07e70ae1bb3f 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -1,13 +1,13 @@
# $FreeBSD$
-# TODO: once plasma5 ports are in, re-add dependency on workspace.
-
PORTNAME= ktorrent
-DISTVERSION= 5.1.1
-PORTREVISION= 5
+DISTVERSION= 5.1.2
CATEGORIES= net-p2p kde
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}/
+# Since libktorrent is released with ktorrent, it lives in a
+# strange download directory; keep this in-sync with net-p2p/libktorrent.
+
MAINTAINER= kde@FreeBSD.org
COMMENT= BitTorrent client for KDE
diff --git a/net-p2p/ktorrent/distinfo b/net-p2p/ktorrent/distinfo
index 7b316552fbd4..a1b5dc52505b 100644
--- a/net-p2p/ktorrent/distinfo
+++ b/net-p2p/ktorrent/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1537292923
-SHA256 (ktorrent-5.1.1.tar.xz) = b54149cf1dd3ed59cb7be54c326469a64e152f39f2d7db01de9fdd6b2ce3562a
-SIZE (ktorrent-5.1.1.tar.xz) = 2049392
+TIMESTAMP = 1567422739
+SHA256 (ktorrent-5.1.2.tar.xz) = 641427a3d6ecb18b0b28c1cc2ec3ba54612abf684df5e10e6c953cd7af058d4f
+SIZE (ktorrent-5.1.2.tar.xz) = 2048604
diff --git a/net-p2p/ktorrent/files/patch-gentoo-kf5-5.61-headers b/net-p2p/ktorrent/files/patch-gentoo-kf5-5.61-headers
deleted file mode 100644
index d9b8348e4469..000000000000
--- a/net-p2p/ktorrent/files/patch-gentoo-kf5-5.61-headers
+++ /dev/null
@@ -1,24 +0,0 @@
-From 909215cc912d89fbc8573f2f98e3b433472d8eae Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 9 Aug 2019 20:54:52 +0200
-Subject: [PATCH] Add missing QVector
-
----
- libktcore/plugin/pluginmanager.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/libktcore/plugin/pluginmanager.h b/libktcore/plugin/pluginmanager.h
-index 50eaa768..3a04a729 100644
---- libktcore/plugin/pluginmanager.h
-+++ libktcore/plugin/pluginmanager.h
-@@ -23,6 +23,7 @@
-
- #include <QList>
- #include <QStringList>
-+#include <QVector>
-
- #include <KPluginInfo>
- #include <KPluginMetaData>
---
-2.22.0
-
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 27c83cd50332..5f333a6b2e10 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -1,10 +1,12 @@
# $FreeBSD$
PORTNAME= libktorrent
-DISTVERSION= 2.1.0
-PORTREVISION= 10
+DISTVERSION= 2.1.1
CATEGORIES= net-p2p kde
-DIST_SUBDIR= KDE/${PORTNAME}
+MASTER_SITES= KDE/stable/ktorrent/5.1.2/
+
+# Since libktorrent is released with ktorrent, it lives in a
+# strange download directory; keep this in-sync with net-p2p/ktorrent.
MAINTAINER= kde@FreeBSD.org
COMMENT= Torrent library from KTorrent project
@@ -15,14 +17,10 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgmp.so:math/gmp \
libqca-qt5.so:devel/qca
-USES= cmake compiler:c++11-lang gettext kde:5 qt:5
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= archive completion config coreaddons crash ecm i18n \
jobwidgets kio service solid widgetsaddons
USE_QT= core gui network testlib xml \
buildtools_build qmake_build
-USE_GITHUB= yes
-GH_ACCOUNT= KDE
-GH_TAGNAME= eb79ad2
-
.include <bsd.port.mk>
diff --git a/net-p2p/libktorrent/distinfo b/net-p2p/libktorrent/distinfo
index 5cfbbc2c6c0a..2f0663b88e2a 100644
--- a/net-p2p/libktorrent/distinfo
+++ b/net-p2p/libktorrent/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514050432
-SHA256 (KDE/libktorrent/KDE-libktorrent-2.1.0-eb79ad2_GH0.tar.gz) = dd254caed92bf301c373d61e26130f1330e89949570ae8a61ec6c04b8cb466df
-SIZE (KDE/libktorrent/KDE-libktorrent-2.1.0-eb79ad2_GH0.tar.gz) = 376051
+TIMESTAMP = 1567422939
+SHA256 (libktorrent-2.1.1.tar.xz) = 5cc45c0b50a1b6b2ce64ad0384128f4ac3bc0e4a1417eb58e5e992b510fca100
+SIZE (libktorrent-2.1.1.tar.xz) = 357516
diff --git a/net-p2p/libktorrent/pkg-plist b/net-p2p/libktorrent/pkg-plist
index 23fe452538cc..c2f1713db3ed 100644
--- a/net-p2p/libktorrent/pkg-plist
+++ b/net-p2p/libktorrent/pkg-plist
@@ -192,3 +192,63 @@ lib/cmake/KF5Torrent/KF5TorrentTargets.cmake
lib/libKF5Torrent.so
lib/libKF5Torrent.so.6
lib/libKF5Torrent.so.6.0.0
+share/locale/ar/LC_MESSAGES/libktorrent5.mo
+share/locale/ast/LC_MESSAGES/libktorrent5.mo
+share/locale/be/LC_MESSAGES/libktorrent5.mo
+share/locale/bg/LC_MESSAGES/libktorrent5.mo
+share/locale/bs/LC_MESSAGES/libktorrent5.mo
+share/locale/ca/LC_MESSAGES/libktorrent5.mo
+share/locale/ca@valencia/LC_MESSAGES/libktorrent5.mo
+share/locale/cs/LC_MESSAGES/libktorrent5.mo
+share/locale/da/LC_MESSAGES/libktorrent5.mo
+share/locale/de/LC_MESSAGES/libktorrent5.mo
+share/locale/el/LC_MESSAGES/libktorrent5.mo
+share/locale/en_GB/LC_MESSAGES/libktorrent5.mo
+share/locale/eo/LC_MESSAGES/libktorrent5.mo
+share/locale/es/LC_MESSAGES/libktorrent5.mo
+share/locale/et/LC_MESSAGES/libktorrent5.mo
+share/locale/eu/LC_MESSAGES/libktorrent5.mo
+share/locale/fi/LC_MESSAGES/libktorrent5.mo
+share/locale/fr/LC_MESSAGES/libktorrent5.mo
+share/locale/ga/LC_MESSAGES/libktorrent5.mo
+share/locale/gl/LC_MESSAGES/libktorrent5.mo
+share/locale/hi/LC_MESSAGES/libktorrent5.mo
+share/locale/hne/LC_MESSAGES/libktorrent5.mo
+share/locale/hr/LC_MESSAGES/libktorrent5.mo
+share/locale/hu/LC_MESSAGES/libktorrent5.mo
+share/locale/ia/LC_MESSAGES/libktorrent5.mo
+share/locale/is/LC_MESSAGES/libktorrent5.mo
+share/locale/it/LC_MESSAGES/libktorrent5.mo
+share/locale/ja/LC_MESSAGES/libktorrent5.mo
+share/locale/kk/LC_MESSAGES/libktorrent5.mo
+share/locale/km/LC_MESSAGES/libktorrent5.mo
+share/locale/ko/LC_MESSAGES/libktorrent5.mo
+share/locale/ku/LC_MESSAGES/libktorrent5.mo
+share/locale/lt/LC_MESSAGES/libktorrent5.mo
+share/locale/lv/LC_MESSAGES/libktorrent5.mo
+share/locale/mr/LC_MESSAGES/libktorrent5.mo
+share/locale/ms/LC_MESSAGES/libktorrent5.mo
+share/locale/nb/LC_MESSAGES/libktorrent5.mo
+share/locale/nds/LC_MESSAGES/libktorrent5.mo
+share/locale/nl/LC_MESSAGES/libktorrent5.mo
+share/locale/nn/LC_MESSAGES/libktorrent5.mo
+share/locale/oc/LC_MESSAGES/libktorrent5.mo
+share/locale/pl/LC_MESSAGES/libktorrent5.mo
+share/locale/pt/LC_MESSAGES/libktorrent5.mo
+share/locale/pt_BR/LC_MESSAGES/libktorrent5.mo
+share/locale/ro/LC_MESSAGES/libktorrent5.mo
+share/locale/ru/LC_MESSAGES/libktorrent5.mo
+share/locale/se/LC_MESSAGES/libktorrent5.mo
+share/locale/si/LC_MESSAGES/libktorrent5.mo
+share/locale/sk/LC_MESSAGES/libktorrent5.mo
+share/locale/sl/LC_MESSAGES/libktorrent5.mo
+share/locale/sr/LC_MESSAGES/libktorrent5.mo
+share/locale/sr@ijekavian/LC_MESSAGES/libktorrent5.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/libktorrent5.mo
+share/locale/sr@latin/LC_MESSAGES/libktorrent5.mo
+share/locale/sv/LC_MESSAGES/libktorrent5.mo
+share/locale/tr/LC_MESSAGES/libktorrent5.mo
+share/locale/ug/LC_MESSAGES/libktorrent5.mo
+share/locale/uk/LC_MESSAGES/libktorrent5.mo
+share/locale/zh_CN/LC_MESSAGES/libktorrent5.mo
+share/locale/zh_TW/LC_MESSAGES/libktorrent5.mo