aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-03 16:45:51 +0800
committeraz <az@FreeBSD.org>2013-08-03 16:45:51 +0800
commitf8d84df2018f0071d586d8c74fe89b3ebe61cbfc (patch)
treebea626d8d7aaa3973f00760684b26d2ddcce74eb /net-p2p
parent5ff0965a6a20416caf6012b02767e66ac0694085 (diff)
downloadfreebsd-ports-gnome-f8d84df2018f0071d586d8c74fe89b3ebe61cbfc.tar.gz
freebsd-ports-gnome-f8d84df2018f0071d586d8c74fe89b3ebe61cbfc.tar.zst
freebsd-ports-gnome-f8d84df2018f0071d586d8c74fe89b3ebe61cbfc.zip
- Convert to new perl framework
- Trim Makefile header
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitflu/Makefile2
-rw-r--r--net-p2p/gtk-gnutella/Makefile3
-rw-r--r--net-p2p/mldonkey-perlreactor/Makefile3
-rw-r--r--net-p2p/mldonkey-urlslave/Makefile3
4 files changed, 4 insertions, 7 deletions
diff --git a/net-p2p/bitflu/Makefile b/net-p2p/bitflu/Makefile
index da9c480b0905..8e47d5619b23 100644
--- a/net-p2p/bitflu/Makefile
+++ b/net-p2p/bitflu/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
PLUGINSDIR_BASE=lib/perl5
PLUGINSDIR= ${PLUGINSDIR_BASE}/Bitflu
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
SUB_FILES= pkg-message
diff --git a/net-p2p/gtk-gnutella/Makefile b/net-p2p/gtk-gnutella/Makefile
index 90c12a077a9d..cc26caee8820 100644
--- a/net-p2p/gtk-gnutella/Makefile
+++ b/net-p2p/gtk-gnutella/Makefile
@@ -54,8 +54,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_GNOME= glib20 libxml2
-USE_PERL5= yes
-USES= bison
+USES= bison perl5
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -O -Dyacc='bison -y' -Dprefix=${PREFIX} \
diff --git a/net-p2p/mldonkey-perlreactor/Makefile b/net-p2p/mldonkey-perlreactor/Makefile
index 14becbaaf4c0..2fbb1b1513b0 100644
--- a/net-p2p/mldonkey-perlreactor/Makefile
+++ b/net-p2p/mldonkey-perlreactor/Makefile
@@ -13,10 +13,9 @@ COMMENT= Automatically add links found in web pages to MLDonkey queue
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-USE_PERL5= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES$=${BINARY_NAME}
BINARY_NAME= perlreactor
diff --git a/net-p2p/mldonkey-urlslave/Makefile b/net-p2p/mldonkey-urlslave/Makefile
index 4918922325d0..34a2e9186c53 100644
--- a/net-p2p/mldonkey-urlslave/Makefile
+++ b/net-p2p/mldonkey-urlslave/Makefile
@@ -14,9 +14,8 @@ COMMENT= GTK+ enabled Perl script for adding ed2k:// links to MLDonkey
BUILD_DEPENDS= p5-Gtk>=0:${PORTSDIR}/x11-toolkits/p5-Gtk
-USE_PERL5= yes
NO_BUILD= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= ${BINARY_NAME}
BINARY_NAME= mlurlslave