aboutsummaryrefslogtreecommitdiffstats
path: root/net/3proxy/Makefile
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-08-08 03:20:15 +0800
committerKai Knoblich <kai@FreeBSD.org>2019-08-08 03:20:15 +0800
commitd3a63d096ec694f359a9b77f2b0c2d11788e259f (patch)
tree9d7c889d24dc8fb9674aad2b8cb85fc197218c4a /net/3proxy/Makefile
parent3d339c27552b0a1e8999545bd73a99a3de90f1d1 (diff)
downloadfreebsd-ports-gnome-d3a63d096ec694f359a9b77f2b0c2d11788e259f.tar.gz
freebsd-ports-gnome-d3a63d096ec694f359a9b77f2b0c2d11788e259f.tar.zst
freebsd-ports-gnome-d3a63d096ec694f359a9b77f2b0c2d11788e259f.zip
net/3proxy: Update to 0.8.13
* Sort variables according the PHB while I'm here. Changelog: * Fixed: Out-of-bound write and few minor bugs on configuration saving in admin * Fixed: $ is not correctly handled in the beginning of quoted line on configuration parsing https://github.com/z3APA3A/3proxy/releases/tag/0.8.13 PR: 239677 Submitted by: timp87@gmail.com (maintainer) MFH: 2019Q3 (bugfix blanket)
Diffstat (limited to 'net/3proxy/Makefile')
-rw-r--r--net/3proxy/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/net/3proxy/Makefile b/net/3proxy/Makefile
index 37e3d63c8f1f..e435b466d054 100644
--- a/net/3proxy/Makefile
+++ b/net/3proxy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= 3proxy
-PORTVERSION= 0.8.12
+PORTVERSION= 0.8.13
CATEGORIES= net
MAINTAINER= timp87@gmail.com
@@ -11,19 +11,21 @@ COMMENT= Proxy servers set (support HTTP(S), FTP, SOCKS, POP3, TCP & UDP)
LICENSE= APACHE20 BSD3CLAUSE GPLv2+ LGPL21+
LICENSE_COMB= dual
-OPTIONS_DEFINE= DOCS
-
-3PROXY_LOGDIR= /var/log/${PORTNAME}
-
-MAKEFILE= Makefile.unix
USE_RC_SUBR= 3proxy
USE_GITHUB= yes
GH_ACCOUNT= z3APA3A
+
+MAKEFILE= Makefile.unix
+
PLIST_SUB= PORTNAME=${PORTNAME} \
3PROXY_LOGDIR=${3PROXY_LOGDIR}
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
+3PROXY_LOGDIR= /var/log/${PORTNAME}
+
post-patch:
@${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e 's|%%3PROXY_LOGDIR%%|${3PROXY_LOGDIR}|' ${WRKSRC}/cfg/3proxy.cfg.sample