aboutsummaryrefslogtreecommitdiffstats
path: root/net/anet
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-02-27 21:47:48 +0800
committermarino <marino@FreeBSD.org>2014-02-27 21:47:48 +0800
commitdbb9f717768809102b142766d116ee28cbea54d1 (patch)
treec242d19786c80111127b9c1bdfe2da9a2ee9561b /net/anet
parent2c521d37f476965fe127f976ef2eb98205423df1 (diff)
downloadfreebsd-ports-gnome-dbb9f717768809102b142766d116ee28cbea54d1.tar.gz
freebsd-ports-gnome-dbb9f717768809102b142766d116ee28cbea54d1.tar.zst
freebsd-ports-gnome-dbb9f717768809102b142766d116ee28cbea54d1.zip
net/anet: Fix properly
The problem with ahven was caused by a typo in the build targets. The target "build_lib" was desired, but "build_all" was defined. Fix target and return ahven to an optional dependency. Tested in Reports, 8x pass
Diffstat (limited to 'net/anet')
-rw-r--r--net/anet/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/anet/Makefile b/net/anet/Makefile
index 44fdad260d70..6e6e64736add 100644
--- a/net/anet/Makefile
+++ b/net/anet/Makefile
@@ -3,6 +3,7 @@
PORTNAME= anet
PORTVERSION= 0.2.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.codelabs.ch/download/
DISTNAME= libanet-${PORTVERSION}
@@ -15,7 +16,7 @@ LICENSE_COMB= multi
USES= ada
USE_BZIP2= yes
-ALL_TARGET= build_all
+ALL_TARGET= build_lib
MAKE_ARGS+= NUM_CPUS=${MAKE_JOBS_NUMBER} \
LIBRARY_KIND=static
@@ -28,8 +29,8 @@ TEST_DESC= Run unit test suite before installation
IGNORE= will not build; atomics are not supported on DF i386
.endif
-BUILD_DEPENDS+= ${LOCALBASE}/lib/gnat/ahven.gpr:${PORTSDIR}/devel/ahven
.if ${PORT_OPTIONS:MTEST}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/gnat/ahven.gpr:${PORTSDIR}/devel/ahven
ALL_TARGET+= tests
.endif