aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-04-01 21:14:39 +0800
committerflo <flo@FreeBSD.org>2012-04-01 21:14:39 +0800
commitd2b99de58e35d974a1343231fd045af241813953 (patch)
tree675b46c8de490e2828183a504cd13bc8c805dd74 /net/asterisk/Makefile
parent6535546983b1146368e4b13de51eab828f6343ff (diff)
downloadfreebsd-ports-gnome-d2b99de58e35d974a1343231fd045af241813953.tar.gz
freebsd-ports-gnome-d2b99de58e35d974a1343231fd045af241813953.tar.zst
freebsd-ports-gnome-d2b99de58e35d974a1343231fd045af241813953.zip
- update to 1.8.11.0 [1]
- add OPTION for LDAP support, fixing pkg-plist entry for res_config_ldap [2] - add PORTSCOUT hint PR: ports/166403 [2] Submitted by: zi [1] Reported by: gpalmer [2] Feature safe: yes
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 393ee6ea5e82..d06313c9f923 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.10.1
+PORTVERSION= 1.8.11.0
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -61,9 +61,12 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
CURL "Enable CURL support" on \
SPANDSP "Enable Spandsp faxing support" off \
EXCHANGE "Enable Exchange calendar support" off \
- NEWG711 "Enable new G711 Codec" off \
- SRTP "Enable SecureRTP support" off \
- LUA "Enable LUA extensions support" off
+ NEWG711 "Enable new G711 Codec" off \
+ SRTP "Enable SecureRTP support" off \
+ LUA "Enable LUA extensions support" off \
+ LDAP "Enable Ldap support" off
+
+PORTSCOUT= limit:^1\.8\.
ASTERISK_USER?= asterisk
ASTERISK_GROUP?= asterisk
@@ -269,6 +272,15 @@ CONFIGURE_ARGS+= --without-lua
PLIST_SUB+= WITH_LUA="@comment "
.endif
+.if defined(WITH_LDAP)
+CONFIGURE_ARGS+= --with-ldap
+USE_OPENLDAP= yes
+PLIST_SUB+= WITH_LDAP=""
+.else
+CONFIGURE_ARGS+= --without-ldap
+PLIST_SUB+= WITH_LDAP="@comment "
+.endif
+
post-extract:
${FIND} ${WRKSRC} -name '*.d' -delete