aboutsummaryrefslogtreecommitdiffstats
path: root/net/asterisk16/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-10-20 17:26:28 +0800
committersobomax <sobomax@FreeBSD.org>2003-10-20 17:26:28 +0800
commitb6bdcc29654bd86e25b241de0d98f1727d94c7b6 (patch)
tree6a42029601af5edbe2817067c74cb657e5a9aa5c /net/asterisk16/Makefile
parent45d4082d88de04ecd980b9e3c2ccf0e1c3050f13 (diff)
downloadfreebsd-ports-gnome-b6bdcc29654bd86e25b241de0d98f1727d94c7b6.tar.gz
freebsd-ports-gnome-b6bdcc29654bd86e25b241de0d98f1727d94c7b6.tar.zst
freebsd-ports-gnome-b6bdcc29654bd86e25b241de0d98f1727d94c7b6.zip
- Fix problem with speex shared library version;
- build/install h323 channel module.
Diffstat (limited to 'net/asterisk16/Makefile')
-rw-r--r--net/asterisk16/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 89b4dbc958c9..3ecd86e63f8b 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -15,8 +15,11 @@ MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
-BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
+BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client \
+ ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build \
+ ${NONEXISTENT}:${PORTSDIR}/net/openh323:build
+LIB_DEPENDS= speex.2:${PORTSDIR}/audio/speex \
+ ldap.2:${PORTSDIR}/net/openldap20-client
RUN_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
GNU_CONFIGURE= yes
@@ -24,6 +27,10 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
- MKDIR="${MKDIR}"
+ MKDIR="${MKDIR}" \
+ PWLIBDIR=${WRKDIR}/../../../devel/pwlib/work/pwlib \
+ OPENH323DIR=${WRKDIR}/../../../net/openh323/work/openh323 \
+ OSVERSION=${OSVERSION} \
+ CXX="${CXX}"
.include <bsd.port.mk>