aboutsummaryrefslogtreecommitdiffstats
path: root/net/beanstalkd
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2009-02-05 18:49:05 +0800
committervsevolod <vsevolod@FreeBSD.org>2009-02-05 18:49:05 +0800
commit85bebe89239097c30df7027ba6d39c5df6485620 (patch)
tree09d7af1e6c110f2618be02a76861a7d0b5cebeff /net/beanstalkd
parentc5bc5016bdad22da69be587b7b527996363c1ab6 (diff)
downloadfreebsd-ports-gnome-85bebe89239097c30df7027ba6d39c5df6485620.tar.gz
freebsd-ports-gnome-85bebe89239097c30df7027ba6d39c5df6485620.tar.zst
freebsd-ports-gnome-85bebe89239097c30df7027ba6d39c5df6485620.zip
- Update beanstalkd to 1.2
Diffstat (limited to 'net/beanstalkd')
-rw-r--r--net/beanstalkd/Makefile14
-rw-r--r--net/beanstalkd/distinfo6
-rw-r--r--net/beanstalkd/files/patch-Makefile11
3 files changed, 12 insertions, 19 deletions
diff --git a/net/beanstalkd/Makefile b/net/beanstalkd/Makefile
index dbb98130fccc..30f457cec34e 100644
--- a/net/beanstalkd/Makefile
+++ b/net/beanstalkd/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= beanstalkd
-PORTVERSION= 1.0
+PORTVERSION= 1.2
PORTREVISION= 0
CATEGORIES= net
-MASTER_SITES= http://xph.us/software/beanstalkd/rel/
+MASTER_SITES= http://xph.us/dist/beanstalkd/ \
+ http://xph.us/software/beanstalkd/rel/
MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Fast, distributed, in-memory workqueue service
@@ -17,15 +18,18 @@ COMMENT= Fast, distributed, in-memory workqueue service
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
USE_RC_SUBR= beanstalkd
-USE_GMAKE= yes
-MAKE_ENV+= EVENT_CFLAGS=-I${LOCALBASE}/include EVENT_LDFLAGS=-L${LOCALBASE}/lib
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_ENV+= EVENT_CFLAGS=-I${LOCALBASE}/include EVENT_LDFLAGS=-L${LOCALBASE}/lib
PLIST_FILES= bin/beanstalkd
PORTDOCS= protocol.txt
+MAN1= beanstalkd.1
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/beanstalkd ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/beanstalkd ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
@${MKDIR} ${DOCSDIR}
diff --git a/net/beanstalkd/distinfo b/net/beanstalkd/distinfo
index 785d581aeed2..24a4fa13722e 100644
--- a/net/beanstalkd/distinfo
+++ b/net/beanstalkd/distinfo
@@ -1,3 +1,3 @@
-MD5 (beanstalkd-1.0.tar.gz) = 4549822ffec2d90da6a575a292f0e472
-SHA256 (beanstalkd-1.0.tar.gz) = 5043f1d9271e6c9a35df945132356996a5ac7bc4640fb87fcbfa5cfe8e13a0c4
-SIZE (beanstalkd-1.0.tar.gz) = 46063
+MD5 (beanstalkd-1.2.tar.gz) = 7b30b840069e679526e564b42796630b
+SHA256 (beanstalkd-1.2.tar.gz) = 6bf5b2a066d05e8effe96b7b9103e88c117cf5cbb134dbb11992f7228519f5f0
+SIZE (beanstalkd-1.2.tar.gz) = 116172
diff --git a/net/beanstalkd/files/patch-Makefile b/net/beanstalkd/files/patch-Makefile
index 42d78351afae..e69de29bb2d1 100644
--- a/net/beanstalkd/files/patch-Makefile
+++ b/net/beanstalkd/files/patch-Makefile
@@ -1,11 +0,0 @@
---- Makefile.orig 2008-04-11 16:41:58.835397096 +0400
-+++ Makefile 2008-04-11 16:42:36.908051673 +0400
-@@ -1,6 +1,6 @@
- program := beanstalkd
--export CFLAGS := $(CFLAGS) -Wall -Werror
--export LDFLAGS := $(LDFLAGS) -levent
-+export CFLAGS := $(CFLAGS) -Wall -Werror $(EVENT_CFLAGS)
-+export LDFLAGS := $(LDFLAGS) $(EVENT_LDFLAGS) -levent
-
- sources := $(shell ls *.c | fgrep -v $(program))
- objects := $(sources:.c=.o)