aboutsummaryrefslogtreecommitdiffstats
path: root/net/bind9
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2001-02-07 20:36:27 +0800
committerDoug Barton <dougb@FreeBSD.org>2001-02-07 20:36:27 +0800
commite77ea8ac3fd832ed08d1a81ea86b55eddeb26aa8 (patch)
tree15d2ca68072aa5bbfd3a5b1404980e41eae79592 /net/bind9
parentb188ac4586f3be8282c68702d6bdd586bb4af89f (diff)
downloadfreebsd-ports-gnome-e77ea8ac3fd832ed08d1a81ea86b55eddeb26aa8.tar.gz
freebsd-ports-gnome-e77ea8ac3fd832ed08d1a81ea86b55eddeb26aa8.tar.zst
freebsd-ports-gnome-e77ea8ac3fd832ed08d1a81ea86b55eddeb26aa8.zip
Major overhaul, including an updated man/plist, patching the man pages
to make the location of etc/ files prefix-safe. Install a sample rndc.conf file. Since rndc won't start without one the user should have an example to work from. Add the installation of various docs wrapped in a NOPORTDOCS test. Last but not least, add a patch that turns off the debugging code ISC left on by default. This should help solve the problems with misbehaving assert's, related to nmap and other causes.
Diffstat (limited to 'net/bind9')
-rw-r--r--net/bind9/Makefile35
-rw-r--r--net/bind9/files/patch-assertions.h15
-rw-r--r--net/bind9/pkg-plist25
3 files changed, 71 insertions, 4 deletions
diff --git a/net/bind9/Makefile b/net/bind9/Makefile
index 30794176c933..f3bdaa4e124d 100644
--- a/net/bind9/Makefile
+++ b/net/bind9/Makefile
@@ -16,18 +16,45 @@ MAINTAINER= DougB@FreeBSD.org
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
-MAN1= host.1 dig.1
+MAN1= dig.1 host.1 named-checkconf.1 named-checkzone.1
MAN5= rndc.conf.5
MAN8= lwresd.8 named.8 nsupdate.8 rndc.8 dnssec-keygen.8 dnssec-makekeyset.8 \
dnssec-signkey.8 dnssec-signzone.8
-pre-configure:
- ${PERL} -pi -e "s@{INSTALL_PROGRAM}@{INSTALL_DATA} -m 555@g" ${WRKSRC}/Makefile.in
+DIR= ${WRKSRC}/doc/man/bin
+post-patch:
+.for FILE in named-checkconf.1 named.8 nsupdate.8 rndc.8 rndc.conf.5
+ @ ${MV} ${DIR}/${FILE} ${DIR}/${FILE}.Dist
+ @ ${SED} -e 's#/etc/named.conf#${PREFIX}/etc/named.conf#g' \
+ -e 's#/etc/rndc.conf#${PREFIX}/etc/rndc.conf#g' \
+ ${DIR}/${FILE}.Dist > ${DIR}/${FILE}
+.endfor
+
+ @ ${MV} ${WRKSRC}/doc/man/dnssec/dnssec-signzone.8 \
+ ${WRKSRC}/doc/man/dnssec/dnssec-signzone.8.Dist
+ @ ${SED} -e 's#/etc/named.conf#${PREFIX}/etc/named.conf#g' \
+ ${WRKSRC}/doc/man/dnssec/dnssec-signzone.8.Dist \
+ > ${WRKSRC}/doc/man/dnssec/dnssec-signzone.8
+
+ @ ${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.Dist
+ @ ${SED} -e 's#{INSTALL_PROGRAM}#{INSTALL_DATA} -m 555#g' \
+ ${WRKSRC}/Makefile.in.Dist > ${WRKSRC}/Makefile.in
post-install:
.for NUM in 1 5 8
${INSTALL_MAN} ${WRKSRC}/doc/man/bin/*.${NUM} ${MANPREFIX}/man/man${NUM}
.endfor
- ${INSTALL_MAN} ${WRKSRC}/doc/man/dnssec/* ${MANPREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/dnssec/*.8 ${MANPREFIX}/man/man8
+ ${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
+ ${PREFIX}/etc/rndc.conf.sample
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/bind9/arm
+ ${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM*html \
+ ${PREFIX}/share/doc/bind9/arm/
+ ${CP} -R ${WRKSRC}/doc/misc ${PREFIX}/share/doc/bind9/
+ ${CP} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ \
+ ${WRKSRC}/README ${PREFIX}/share/doc/bind9/
+.endif
.include <bsd.port.mk>
diff --git a/net/bind9/files/patch-assertions.h b/net/bind9/files/patch-assertions.h
new file mode 100644
index 000000000000..109fd263a8f3
--- /dev/null
+++ b/net/bind9/files/patch-assertions.h
@@ -0,0 +1,15 @@
+--- lib/isc/include/isc/assertions.h.ISC Wed Jan 17 15:42:19 2001
++++ lib/isc/include/isc/assertions.h Tue Feb 6 22:20:19 2001
+@@ -51,6 +51,12 @@
+ #define ISC_CHECK_INVARIANT 1
+ #endif
+
++/*
++ Turn off ISC debugging code to avoid a possible DOS attack
++ related to nmap TCP connect() scanning.
++*/
++#define ISC_CHECK_NONE
++
+ #ifdef ISC_CHECK_NONE
+ #define ISC_CHECK_REQUIRE 0
+ #define ISC_CHECK_ENSURE 0
diff --git a/net/bind9/pkg-plist b/net/bind9/pkg-plist
index ad4fe5d3d2a6..afa0a8ee9b12 100644
--- a/net/bind9/pkg-plist
+++ b/net/bind9/pkg-plist
@@ -3,6 +3,7 @@ bin/host
bin/isc-config.sh
bin/nslookup
bin/nsupdate
+etc/rndc.conf.sample
include/dns/a6.h
include/dns/acl.h
include/dns/adb.h
@@ -177,7 +178,31 @@ sbin/dnssec-signkey
sbin/dnssec-signzone
sbin/lwresd
sbin/named
+sbin/named-checkconf
+sbin/named-checkzone
sbin/rndc
+%%PORTDOCS%%share/doc/bind9/CHANGES
+%%PORTDOCS%%share/doc/bind9/COPYRIGHT
+%%PORTDOCS%%share/doc/bind9/FAQ
+%%PORTDOCS%%share/doc/bind9/README
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch01.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch02.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch03.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch04.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch05.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch06.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch07.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch08.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.ch09.html
+%%PORTDOCS%%share/doc/bind9/arm/Bv9ARM.html
+%%PORTDOCS%%share/doc/bind9/misc/dnssec
+%%PORTDOCS%%share/doc/bind9/misc/ipv6
+%%PORTDOCS%%share/doc/bind9/misc/migration
+%%PORTDOCS%%share/doc/bind9/misc/options
+%%PORTDOCS%%share/doc/bind9/misc/sdb
+%%PORTDOCS%%@dirrm share/doc/bind9/arm
+%%PORTDOCS%%@dirrm share/doc/bind9/misc
+%%PORTDOCS%%@dirrm share/doc/bind9
@dirrm include/omapi
@dirrm include/lwres
@dirrm include/isc