aboutsummaryrefslogtreecommitdiffstats
path: root/net/bird6
diff options
context:
space:
mode:
authorAlexander V. Chernikov <melifaro@FreeBSD.org>2013-12-05 06:08:35 +0800
committerAlexander V. Chernikov <melifaro@FreeBSD.org>2013-12-05 06:08:35 +0800
commit226a5e36ca184b52e444a0a7c7602df92da80a03 (patch)
tree3fe704ae474a49a2e8d85718d43c80d1af75c07b /net/bird6
parent2bf6d35ef17fd41884743a86335eb64daedd3ab4 (diff)
downloadfreebsd-ports-gnome-226a5e36ca184b52e444a0a7c7602df92da80a03.tar.gz
freebsd-ports-gnome-226a5e36ca184b52e444a0a7c7602df92da80a03.tar.zst
freebsd-ports-gnome-226a5e36ca184b52e444a0a7c7602df92da80a03.zip
* net/bird6 is now slave port for net/bird
* Add source address selection fix from upstream * Bump PORTREVISION Reviewed by: timur
Diffstat (limited to 'net/bird6')
-rw-r--r--net/bird6/Makefile27
-rw-r--r--net/bird6/distinfo2
-rw-r--r--net/bird6/files/bird6.in32
-rw-r--r--net/bird6/files/patch-tools-Makefile.in15
4 files changed, 7 insertions, 69 deletions
diff --git a/net/bird6/Makefile b/net/bird6/Makefile
index 72c564cb7da9..2ce4aabdae60 100644
--- a/net/bird6/Makefile
+++ b/net/bird6/Makefile
@@ -2,30 +2,17 @@
# $FreeBSD$
PORTNAME= bird6
-PORTVERSION= 1.4.0
-CATEGORIES= net
-MASTER_SITES= ftp://bird.network.cz/pub/bird/ \
- http://bird.mpls.in/distfiles/bird/
-DISTNAME= bird-${PORTVERSION}
-
-MAINTAINER= melifaro@ipfw.ru
COMMENT= Dynamic IP routing daemon (IPv6 version)
+DISTNAME= bird-${PORTVERSION}
-LICENSE= GPLv2
+MASTERDIR= ${.CURDIR}/../bird
-USES= bison gmake
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-ipv6 --localstatedir=/var
-USE_CSTD= gnu89
+OPTIONS_DEFINE=
-MAKE_JOBS_UNSAFE= yes
+USE_RC_SUBR= ${PORTNAME}
-USE_RC_SUBR= bird6
+PLIST_SUB= VER="6"
-NO_STAGE= yes
-post-install:
- @if [ ! -f ${PREFIX}/etc/bird6.conf ]; then \
- ${CP} -p ${PREFIX}/etc/bird6.conf.example ${PREFIX}/etc/bird6.conf ; \
- fi
+CONFIGURE_ARGS= --enable-ipv6
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/net/bird6/distinfo b/net/bird6/distinfo
deleted file mode 100644
index abe4022ccdbe..000000000000
--- a/net/bird6/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (bird-1.4.0.tar.gz) = da1b41cab26388b01d861c30afe41678df22dc9ea0110a14c1cc7b7bffc693c5
-SIZE (bird-1.4.0.tar.gz) = 1242728
diff --git a/net/bird6/files/bird6.in b/net/bird6/files/bird6.in
deleted file mode 100644
index 2db7094cd5de..000000000000
--- a/net/bird6/files/bird6.in
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-#
-# PROVIDE: bird6 dynamicrouting
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-# bird6_enable (bool): Set to NO by default.
-# Set it to YES to enable bird6.
-# bird6_config (path): Set to %%PREFIX%%/etc/bird6.conf
-# by default.
-#
-
-. /etc/rc.subr
-
-name="bird6"
-rcvar=bird6_enable
-
-command=%%PREFIX%%/sbin/${name}
-
-load_rc_config $name
-
-: ${bird6_enable="NO"}
-: ${bird6_config="%%PREFIX%%/etc/bird6.conf"}
-
-command_args="-c $bird6_config"
-
-run_rc_command "$1"
diff --git a/net/bird6/files/patch-tools-Makefile.in b/net/bird6/files/patch-tools-Makefile.in
deleted file mode 100644
index d4e560b1c545..000000000000
--- a/net/bird6/files/patch-tools-Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- tools/Makefile.in.orig 2012-08-07 13:15:45.000000000 +0400
-+++ tools/Makefile.in 2012-08-15 15:51:51.000000000 +0400
-@@ -61,11 +61,7 @@
- if test -n "@CLIENT@" ; then \
- $(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX@ ; \
- fi
-- if ! test -f $(DESTDIR)/@CONFIG_FILE@ ; then \
-- $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/@CONFIG_FILE@ ; \
-- else \
-- echo "Not overwriting old bird@SUFFIX@.conf" ; \
-- fi
-+ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/@CONFIG_FILE@.example
-
- install-docs:
- $(INSTALL) -d $(DESTDIR)/$(docdir)