aboutsummaryrefslogtreecommitdiffstats
path: root/net/bird
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-12-06 22:16:51 +0800
committermat <mat@FreeBSD.org>2017-12-06 22:16:51 +0800
commit9c7fea69535a23e03dc492e6d387eeb6cd9baa7c (patch)
treea45e5b81b374abebd614591146fc9300dcc85266 /net/bird
parentc4d40ba597ebd96b9f79fb80abceae751fb76843 (diff)
downloadfreebsd-ports-gnome-9c7fea69535a23e03dc492e6d387eeb6cd9baa7c.tar.gz
freebsd-ports-gnome-9c7fea69535a23e03dc492e6d387eeb6cd9baa7c.tar.zst
freebsd-ports-gnome-9c7fea69535a23e03dc492e6d387eeb6cd9baa7c.zip
Fold back net/bird6 into net/bird with FLAVORS.
With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'net/bird')
-rw-r--r--net/bird/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index 7ebe5fd78c39..45755c4fe1c3 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -1,7 +1,7 @@
# Created by: Pav Lucistnik <pav@FreeBSD.org>
# $FreeBSD$
-PORTNAME?= bird
+PORTNAME= bird
PORTVERSION= 1.6.3
PORTREVISION= 3
CATEGORIES= net
@@ -9,13 +9,16 @@ MASTER_SITES= ftp://bird.network.cz/pub/bird/ \
http://bird.mpls.in/distfiles/bird/
MAINTAINER= melifaro@ipfw.ru
-COMMENT?= Dynamic IP routing daemon (IPv4 version)
+COMMENT?= Dynamic IP routing daemon (${FLAVOR:Uipv4:S/ip/IP/} version)
LICENSE= GPLv2
+FLAVORS= ipv4 ipv6
+ipv6_PKGNAMESUFFIX= 6
+
USES= bison gmake ncurses readline
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --localstatedir=/var
+CONFIGURE_ARGS= --localstatedir=/var
OPTIONS_DEFINE?= FIREWALL
FIREWALL_DESC= Enable firewall protocol
@@ -23,11 +26,14 @@ NO_OPTIONS_SORT= yes
MAKE_JOBS_UNSAFE= yes
-USE_RC_SUBR= ${PORTNAME}
-
-SUB_LIST+= PORTNAME=${PORTNAME}
+USE_RC_SUBR= ${PKGBASE}
+.if ${FLAVOR:U} == ipv6
+CONFIGURE_ARGS+= --enable-ipv6
+PLIST_SUB= VER=6
+.else
PLIST_SUB?= VER=""
+.endif
FIREWALL_EXTRA_PATCHES+= ${FILESDIR}/firewall_support.patch