aboutsummaryrefslogtreecommitdiffstats
path: root/net/bsdec2-image-upload/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 08:19:19 +0800
committermarino <marino@FreeBSD.org>2016-09-11 08:19:19 +0800
commit292873a2cf0bd8b6c8490c2e4072c45db9cccaaf (patch)
treed555c3fd44b4e9f7710a18ba94924ef8a9a3e184 /net/bsdec2-image-upload/Makefile
parentf2509be839cb49d87b4213f35b7f03ca3285a4eb (diff)
downloadfreebsd-ports-gnome-292873a2cf0bd8b6c8490c2e4072c45db9cccaaf.tar.gz
freebsd-ports-gnome-292873a2cf0bd8b6c8490c2e4072c45db9cccaaf.tar.zst
freebsd-ports-gnome-292873a2cf0bd8b6c8490c2e4072c45db9cccaaf.zip
net/bsdec2-image-upload: Add SSL flags
Approved by: SSL blanket
Diffstat (limited to 'net/bsdec2-image-upload/Makefile')
-rw-r--r--net/bsdec2-image-upload/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/bsdec2-image-upload/Makefile b/net/bsdec2-image-upload/Makefile
index 103f7ccb9e6b..884ad1e75486 100644
--- a/net/bsdec2-image-upload/Makefile
+++ b/net/bsdec2-image-upload/Makefile
@@ -13,8 +13,9 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-USES= tar:tgz uidfix
-USE_OPENSSL= yes
+USES= ssl tar:tgz uidfix
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
# Install into ${STAGEDIR}${PREFIX}; but the build respects ${DESTDIR} so
# all we need to give is the ${PREFIX}/bin part.