aboutsummaryrefslogtreecommitdiffstats
path: root/net/bwping
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-11-02 05:06:32 +0800
committerjhale <jhale@FreeBSD.org>2012-11-02 05:06:32 +0800
commit0cc01399095b34871c890494dff2d11842258f21 (patch)
tree6ca9058a3f3445c9e10f36ae11cfc5f240f0293b /net/bwping
parentb606c00da054e2705af7c36427a9ebf99530f062 (diff)
downloadfreebsd-ports-gnome-0cc01399095b34871c890494dff2d11842258f21.tar.gz
freebsd-ports-gnome-0cc01399095b34871c890494dff2d11842258f21.tar.zst
freebsd-ports-gnome-0cc01399095b34871c890494dff2d11842258f21.zip
- Fix tinderbox build by adding IPV6 option to explicitly
enable or disable IPV6 support. Previous behavior was auto-detection which wasn't working right on tinderbox and would have caused problems anyways. Reported by: pointyhat Approved by: maintainer via private mail makc, avilla (mentors, implicit) Feature safe: yes
Diffstat (limited to 'net/bwping')
-rw-r--r--net/bwping/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/net/bwping/Makefile b/net/bwping/Makefile
index 6f9f22e6e591..c2d373efff73 100644
--- a/net/bwping/Makefile
+++ b/net/bwping/Makefile
@@ -12,11 +12,24 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-MAN8= bwping.8 bwping6.8
+MAN8= bwping.8
-PLIST_FILES= sbin/bwping sbin/bwping6
+PLIST_FILES= sbin/bwping
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ENV+= ac_cv_ipv6=yes
+MAN8+= bwping6.8
+PLIST_FILES+= sbin/bwping6
+.else
+CONFIGURE_ENV+= ac_cv_ipv6=no
+.endif
post-install:
- @${CHMOD} 4555 ${PREFIX}/sbin/bwping ${PREFIX}/sbin/bwping6
+ @${CHMOD} 4555 ${PREFIX}/sbin/bwping
+.if ${PORT_OPTIONS:MIPV6}
+ @${CHMOD} 4555 ${PREFIX}/sbin/bwping6
+.endif
.include <bsd.port.mk>