aboutsummaryrefslogtreecommitdiffstats
path: root/net/chrony
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-09-03 06:35:05 +0800
committerSteve Wills <swills@FreeBSD.org>2019-09-03 06:35:05 +0800
commit1c9d80c792a2fde122e8a946a8d5d568b9942240 (patch)
treeb2f3cf7520dc448bf3b35615e02932a549876d57 /net/chrony
parentfd653e33066eb94b0ef63c073c0a79285e037034 (diff)
downloadfreebsd-ports-gnome-1c9d80c792a2fde122e8a946a8d5d568b9942240.tar.gz
freebsd-ports-gnome-1c9d80c792a2fde122e8a946a8d5d568b9942240.tar.zst
freebsd-ports-gnome-1c9d80c792a2fde122e8a946a8d5d568b9942240.zip
net/chrony: Update to 3.5
PR: 239596 Submitted by: Colin T. <bugzilla@nulldir.e4ward.com> Approved by: maintainer timeout (yonas@fizk.net, >1 month)
Diffstat (limited to 'net/chrony')
-rw-r--r--net/chrony/Makefile3
-rw-r--r--net/chrony/distinfo6
-rw-r--r--net/chrony/files/patch-ntp__io.c65
3 files changed, 4 insertions, 70 deletions
diff --git a/net/chrony/Makefile b/net/chrony/Makefile
index 11a6f5ab7626..d26022d67e57 100644
--- a/net/chrony/Makefile
+++ b/net/chrony/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chrony
-PORTVERSION= 3.4
-PORTREVISION= 2
+PORTVERSION= 3.5
CATEGORIES= net
MASTER_SITES= http://download.tuxfamily.org/chrony/
diff --git a/net/chrony/distinfo b/net/chrony/distinfo
index 4269620a5b9e..8ab1c9d55c9e 100644
--- a/net/chrony/distinfo
+++ b/net/chrony/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540922070
-SHA256 (chrony-3.4.tar.gz) = af77e47c2610a7e55c8af5b89a8aeff52d9a867dd5983d848b52d374bc0e6b9f
-SIZE (chrony-3.4.tar.gz) = 453056
+TIMESTAMP = 1564743396
+SHA256 (chrony-3.5.tar.gz) = 4e02795b1260a4ec51e6ace84149036305cc9fc340e65edb9f8452aa611339b5
+SIZE (chrony-3.5.tar.gz) = 458226
diff --git a/net/chrony/files/patch-ntp__io.c b/net/chrony/files/patch-ntp__io.c
deleted file mode 100644
index 17b2bb9adbdb..000000000000
--- a/net/chrony/files/patch-ntp__io.c
+++ /dev/null
@@ -1,65 +0,0 @@
-From 6af39d63aa9323b4b8c39efe24ae0c88c949a901 Mon Sep 17 00:00:00 2001
-From: Miroslav Lichvar <mlichvar@redhat.com>
-Date: Mon, 3 Dec 2018 15:51:54 +0100
-Subject: ntp: don't use IP_SENDSRCADDR on bound socket
-
-On FreeBSD, sendmsg() fails when IP_SENDSRCADDR specifies a source
-address on a socket that is bound to the address. This prevents a server
-configured with the bindaddress directive from responding to clients.
-
-Add a new variable to check whether the server IPv4 socket is not bound
-before setting the source address.
---- ntp_io.c.orig 2018-09-19 14:38:15 UTC
-+++ ntp_io.c
-@@ -105,6 +105,9 @@ static int separate_client_sockets;
- disabled */
- static int permanent_server_sockets;
-
-+/* Flag indicating the server IPv4 socket is bound to an address */
-+static int bound_server_sock_fd4;
-+
- /* Flag indicating that we have been initialised */
- static int initialised=0;
-
-@@ -168,6 +171,9 @@ prepare_socket(int family, int port_number, int client
- my_addr.in4.sin_port = htons(port_number);
- my_addr_len = sizeof (my_addr.in4);
-
-+ if (!client_only)
-+ bound_server_sock_fd4 = my_addr.in4.sin_addr.s_addr != htonl(INADDR_ANY);
-+
- break;
- #ifdef FEAT_IPV6
- case AF_INET6:
-@@ -821,8 +827,8 @@ NIO_SendPacket(NTP_Packet *packet, NTP_Remote_Address
- msg.msg_flags = 0;
- cmsglen = 0;
-
-- if (local_addr->ip_addr.family == IPADDR_INET4) {
- #ifdef HAVE_IN_PKTINFO
-+ if (local_addr->ip_addr.family == IPADDR_INET4) {
- struct in_pktinfo *ipi;
-
- cmsg = CMSG_FIRSTHDR(&msg);
-@@ -837,7 +843,11 @@ NIO_SendPacket(NTP_Packet *packet, NTP_Remote_Address
- ipi->ipi_spec_dst.s_addr = htonl(local_addr->ip_addr.addr.in4);
- if (local_addr->if_index != INVALID_IF_INDEX)
- ipi->ipi_ifindex = local_addr->if_index;
-+ }
- #elif defined(IP_SENDSRCADDR)
-+ /* Specify the IPv4 source address only if the socket is not bound */
-+ if (local_addr->ip_addr.family == IPADDR_INET4 &&
-+ local_addr->sock_fd == server_sock_fd4 && !bound_server_sock_fd4) {
- struct in_addr *addr;
-
- cmsg = CMSG_FIRSTHDR(&msg);
-@@ -850,8 +860,8 @@ NIO_SendPacket(NTP_Packet *packet, NTP_Remote_Address
-
- addr = (struct in_addr *)CMSG_DATA(cmsg);
- addr->s_addr = htonl(local_addr->ip_addr.addr.in4);
--#endif
- }
-+#endif
-
- #ifdef HAVE_IN6_PKTINFO
- if (local_addr->ip_addr.family == IPADDR_INET6) {