aboutsummaryrefslogtreecommitdiffstats
path: root/net/cphone
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2002-11-27 17:44:12 +0800
committerroger <roger@FreeBSD.org>2002-11-27 17:44:12 +0800
commit3e754b97dd1924cbbf980792da5685ad5da89a5d (patch)
tree502961aaaba53a0a9a642169d3a897a3aaf7aff4 /net/cphone
parent55cfa8f87781c007d78b49088b69fc0815767db1 (diff)
downloadfreebsd-ports-gnome-3e754b97dd1924cbbf980792da5685ad5da89a5d.tar.gz
freebsd-ports-gnome-3e754b97dd1924cbbf980792da5685ad5da89a5d.tar.zst
freebsd-ports-gnome-3e754b97dd1924cbbf980792da5685ad5da89a5d.zip
Fix compilation problems with new pwlib library (reported by Kris and
bento) and get it compiling with QT3 (patch from Matt). Submitted by: Matt Douhan <mdouhan@fruitsalad.org>
Diffstat (limited to 'net/cphone')
-rw-r--r--net/cphone/Makefile3
-rw-r--r--net/cphone/files/patch-Makefile50
-rw-r--r--net/cphone/files/patch-aa27
-rw-r--r--net/cphone/files/patch-cpendpoint.cxx20
4 files changed, 72 insertions, 28 deletions
diff --git a/net/cphone/Makefile b/net/cphone/Makefile
index 5ea78b571711..4e7b1843a2c9 100644
--- a/net/cphone/Makefile
+++ b/net/cphone/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cphone
PORTVERSION= 0.1.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://download.sourceforge.net/cphone/
DISTNAME= cphone_0.1.0
@@ -20,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
NOCLEANDEPENDS= yes
USE_BISON= yes
-USE_QT_VER= 2
+USE_QT_VER= 3
USE_GMAKE= yes
ALL_TARGET= optnoshared
MAKE_ENV= QTDIR=${X11BASE} \
diff --git a/net/cphone/files/patch-Makefile b/net/cphone/files/patch-Makefile
new file mode 100644
index 000000000000..b03d520cff37
--- /dev/null
+++ b/net/cphone/files/patch-Makefile
@@ -0,0 +1,50 @@
+*** Makefile.orig Wed Nov 27 09:18:40 2002
+--- Makefile Wed Nov 27 09:19:01 2002
+*************** MOCFILES := \
+*** 59,79 ****
+ ##################################################
+
+ ifndef QTDIR
+! ifneq (,$(wildcard /usr/local/qt))
+! QTDIR=/usr/local/qt
+! else
+! ifneq (,$(wildcard /usr/lib/qt2))
+! QTDIR=/usr/lib/qt2
+! else
+! ifneq (,$(wildcard ~/qt))
+! QTDIR=~/qt
+! else
+! ifneq (,$(wildcard ../qt))
+! QTDIR=../qt
+! endif
+! endif
+! endif
+! endif
+ endif
+
+ ifndef XLIBDIR
+--- 59,65 ----
+ ##################################################
+
+ ifndef QTDIR
+! QTDIR=/usr/X11R6
+ endif
+
+ ifndef XLIBDIR
+*************** MOC = $(QTDIR)/bin/moc
+*** 87,93 ****
+
+ STDCCFLAGS += -I$(QTDIR)/include -DQT_THREAD_SUPPORT
+ LDFLAGS += -L$(QTDIR)/lib -L$(XLIBDIR)
+! ENDLDLIBS += -lqt-mt -lSM -lICE -lXext -lX11 -ldl
+
+ UISRC := $(patsubst %.ui,%.cxx,$(UIFILES))
+ UIHDRS := $(patsubst %.ui,%.h,$(UIFILES))
+--- 73,79 ----
+
+ STDCCFLAGS += -I$(QTDIR)/include -DQT_THREAD_SUPPORT
+ LDFLAGS += -L$(QTDIR)/lib -L$(XLIBDIR)
+! ENDLDLIBS += -lqt-mt -lSM -lICE -lXext -lX11
+
+ UISRC := $(patsubst %.ui,%.cxx,$(UIFILES))
+ UIHDRS := $(patsubst %.ui,%.h,$(UIFILES))
diff --git a/net/cphone/files/patch-aa b/net/cphone/files/patch-aa
deleted file mode 100644
index b216363e2aca..000000000000
--- a/net/cphone/files/patch-aa
+++ /dev/null
@@ -1,27 +0,0 @@
-*** Makefile.orig Fri May 24 15:01:19 2002
---- Makefile Fri May 24 15:15:27 2002
-*************** endif
-*** 83,93 ****
-
-
- UIC = $(QTDIR)/bin/uic
-! MOC = $(QTDIR)/bin/moc
-
-! STDCCFLAGS += -I$(QTDIR)/include -DQT_THREAD_SUPPORT
- LDFLAGS += -L$(QTDIR)/lib -L$(XLIBDIR)
-! ENDLDLIBS += -lqt-mt -lSM -lICE -lXext -lX11 -ldl
-
- UISRC := $(patsubst %.ui,%.cxx,$(UIFILES))
- UIHDRS := $(patsubst %.ui,%.h,$(UIFILES))
---- 83,93 ----
-
-
- UIC = $(QTDIR)/bin/uic
-! MOC = $(QTDIR)/bin/moc2
-
-! STDCCFLAGS += -I$(QTDIR)/include/qt2 -DQT_THREAD_SUPPORT
- LDFLAGS += -L$(QTDIR)/lib -L$(XLIBDIR)
-! ENDLDLIBS += -lqt2-mt -lSM -lICE -lXext -lX11
-
- UISRC := $(patsubst %.ui,%.cxx,$(UIFILES))
- UIHDRS := $(patsubst %.ui,%.h,$(UIFILES))
diff --git a/net/cphone/files/patch-cpendpoint.cxx b/net/cphone/files/patch-cpendpoint.cxx
new file mode 100644
index 000000000000..85fef2c8524e
--- /dev/null
+++ b/net/cphone/files/patch-cpendpoint.cxx
@@ -0,0 +1,20 @@
+*** cpendpoint.cxx.orig Fri May 10 01:53:47 2002
+--- cpendpoint.cxx Wed Nov 27 09:18:30 2002
+*************** void CpEndPoint::DeleteVideoDisplay()
+*** 151,158 ****
+
+ BOOL CpEndPoint::InitialiseVoipSettings()
+ {
+! rtpIpPortBase = 49604;
+! rtpIpPortMax = 65534;
+
+ if (!connectOpts.userName.IsEmpty())
+ SetLocalUserName(connectOpts.userName);
+--- 151,157 ----
+
+ BOOL CpEndPoint::InitialiseVoipSettings()
+ {
+! SetRtpIpPorts(49604, 65534); /* PortBase, PortMax*/
+
+ if (!connectOpts.userName.IsEmpty())
+ SetLocalUserName(connectOpts.userName);