aboutsummaryrefslogtreecommitdiffstats
path: root/net/csocks/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-08 13:42:43 +0800
committeredwin <edwin@FreeBSD.org>2007-09-08 13:42:43 +0800
commitcaa0de4e07af03deb41447f99c7df47787951b66 (patch)
treecab79c71aa0f67ba76baaa02053b1dc54a5ad938 /net/csocks/Makefile
parent72faeae498536eb01d5cc1b708cbce4b4e7acd11 (diff)
downloadfreebsd-ports-gnome-caa0de4e07af03deb41447f99c7df47787951b66.tar.gz
freebsd-ports-gnome-caa0de4e07af03deb41447f99c7df47787951b66.tar.zst
freebsd-ports-gnome-caa0de4e07af03deb41447f99c7df47787951b66.zip
New port: net/csocks SOCKS Client v4/v5 RFC Compliant with many features
This is a port of csocks, A socks client with many features WWW: http://csocks.virtuale.org PR: ports/115265 Submitted by: Raffaele De Lorenzo <raffaele.delorenzo@libero.it>
Diffstat (limited to 'net/csocks/Makefile')
-rw-r--r--net/csocks/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/csocks/Makefile b/net/csocks/Makefile
new file mode 100644
index 000000000000..e638d6244952
--- /dev/null
+++ b/net/csocks/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: csocks
+# Date created: 06 August 2007
+# Whom: Raffaele De Lorenzo - raffaele.delorenzo@libero.it
+# $FreeBSD$
+
+PORTNAME= csocks
+PORTVERSION= 1.0
+CATEGORIES= net security
+MASTER_SITES= http://csocks.virtuale.org/download/ \
+ http://csocks.altervista.org/download/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= raffaele.delorenzo@libero.it
+COMMENT= SOCKS Client v4/v5 RFC Compliant with many features
+
+ONLY_FOR_ARCHS= i386
+
+PLIST_FILES= etc/csocks.conf lib/libcsocks.so lib/libcsocks.so.1 bin/csocks
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_LDCONFIG= yes
+MAN1= csocks.1
+MAN5= csocks.conf.5
+MANCOMPRESSED= yes
+
+do-install:
+ ${CP} -p ${WRKDIR}/${DISTNAME}/freebsd/libcsocks.so.1 ${PREFIX}/lib/
+ ${LN} -fs ${PREFIX}/lib/libcsocks.so.1 ${PREFIX}/lib/libcsocks.so
+ ${CP} -p ${WRKDIR}/${DISTNAME}/freebsd/csocks ${PREFIX}/bin
+ ${CP} -p ${WRKDIR}/${DISTNAME}/freebsd/csocks.conf ${PREFIX}/etc/
+ ${CP} -p ${WRKDIR}/${DISTNAME}/man/csocks.1.gz ${MANPREFIX}/man/man1
+ ${CP} -p ${WRKDIR}/${DISTNAME}/man/csocks.conf.5.gz ${MANPREFIX}/man/man5
+.include <bsd.port.mk>