aboutsummaryrefslogtreecommitdiffstats
path: root/net/desktop-data-model
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-05-31 05:50:46 +0800
committermiwi <miwi@FreeBSD.org>2008-05-31 05:50:46 +0800
commita2c2ff7f095629163f68a0fadb038d4b8cd7b14f (patch)
tree57641e6501787542bbeb5f73bac914813d32d3af /net/desktop-data-model
parentf3f79cd71bfbdc3150ba784c2b04eb3e7d997f4d (diff)
downloadfreebsd-ports-gnome-a2c2ff7f095629163f68a0fadb038d4b8cd7b14f.tar.gz
freebsd-ports-gnome-a2c2ff7f095629163f68a0fadb038d4b8cd7b14f.tar.zst
freebsd-ports-gnome-a2c2ff7f095629163f68a0fadb038d4b8cd7b14f.zip
Engine providing live updates of online data to the desktop.
WWW: http://ftp.gnome.org/pub/GNOME/sources/desktop-data-model/ PR: ports/124078 Submitted by: Ashish Shukla <wahjava at gmail.com>
Diffstat (limited to 'net/desktop-data-model')
-rw-r--r--net/desktop-data-model/Makefile39
-rw-r--r--net/desktop-data-model/distinfo3
-rw-r--r--net/desktop-data-model/files/patch-Makefile.in11
-rw-r--r--net/desktop-data-model/pkg-descr3
-rw-r--r--net/desktop-data-model/pkg-plist25
5 files changed, 81 insertions, 0 deletions
diff --git a/net/desktop-data-model/Makefile b/net/desktop-data-model/Makefile
new file mode 100644
index 000000000000..6cb398a08dbf
--- /dev/null
+++ b/net/desktop-data-model/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: desktop-data-model
+# Date created: 2008-05-28
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= desktop-data-model
+PORTVERSION= 1.2.4
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+)(\.[0-9]+)*/\1/}
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= Engine providing live updates of online data to the desktop
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libpcre.pc:${PORTSDIR}/devel/pcre \
+ ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus \
+ ${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
+ ${LOCALBASE}/libdata/pkgconfig/sqlite3.pc:${PORTSDIR}/databases/sqlite3 \
+ ${LOCALBASE}/libdata/pkgconfig/loudmouth-1.0.pc:${PORTSDIR}/net-im/loudmouth
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
+ dbus-1.3:${PORTSDIR}/devel/dbus \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ sqlite3.8:${PORTSDIR}/databases/sqlite3 \
+ loudmouth-1.0:${PORTSDIR}/net-im/loudmouth
+
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomehack gtk20 glib20 gnomedesktop
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-maemo=no
+USE_XORG= xscrnsaver
+
+post-patch:
+ ${REINPLACE_CMD} -e s,%%LOCALBASE%%,${LOCALBASE}, ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/net/desktop-data-model/distinfo b/net/desktop-data-model/distinfo
new file mode 100644
index 000000000000..7cec1e63a654
--- /dev/null
+++ b/net/desktop-data-model/distinfo
@@ -0,0 +1,3 @@
+MD5 (desktop-data-model-1.2.4.tar.bz2) = 34481c0a2d0849b72d98f51fa366982f
+SHA256 (desktop-data-model-1.2.4.tar.bz2) = 53aab6e4bb04939bfa98f2d0552b20cc30c384b3367e47c67383328acdf7fc04
+SIZE (desktop-data-model-1.2.4.tar.bz2) = 429764
diff --git a/net/desktop-data-model/files/patch-Makefile.in b/net/desktop-data-model/files/patch-Makefile.in
new file mode 100644
index 000000000000..19fea572baea
--- /dev/null
+++ b/net/desktop-data-model/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2008-05-28 02:49:32.000000000 +0530
++++ Makefile.in 2008-05-28 02:49:38.000000000 +0530
+@@ -210,7 +210,7 @@
+ test_static_file_parser_OBJECTS = \
+ $(am_test_static_file_parser_OBJECTS)
+ test_static_file_parser_DEPENDENCIES = libddm-1.la libddm-test.la
+-DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/config
++DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/config -I%%LOCALBASE%%/include
+ depcomp = $(SHELL) $(top_srcdir)/config/depcomp
+ am__depfiles_maybe = depfiles
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
diff --git a/net/desktop-data-model/pkg-descr b/net/desktop-data-model/pkg-descr
new file mode 100644
index 000000000000..44b40902618e
--- /dev/null
+++ b/net/desktop-data-model/pkg-descr
@@ -0,0 +1,3 @@
+Engine providing live updates of online data to the desktop.
+
+WWW: http://ftp.gnome.org/pub/GNOME/sources/desktop-data-model/
diff --git a/net/desktop-data-model/pkg-plist b/net/desktop-data-model/pkg-plist
new file mode 100644
index 000000000000..a0df09c71039
--- /dev/null
+++ b/net/desktop-data-model/pkg-plist
@@ -0,0 +1,25 @@
+include/ddm-1/ddm/ddm-client-notification.h
+include/ddm-1/ddm/ddm-client.h
+include/ddm-1/ddm/ddm-data-fetch.h
+include/ddm-1/ddm/ddm-data-model-backend.h
+include/ddm-1/ddm/ddm-data-model-dbus-internal.h
+include/ddm-1/ddm/ddm-data-model-dbus.h
+include/ddm-1/ddm/ddm-data-model.h
+include/ddm-1/ddm/ddm-data-query.h
+include/ddm-1/ddm/ddm-data-resource.h
+include/ddm-1/ddm/ddm-feed.h
+include/ddm-1/ddm/ddm-notification-set.h
+include/ddm-1/ddm/ddm-qname.h
+include/ddm-1/ddm/ddm.h
+lib/libddm-1.la
+lib/libddm-1.so
+lib/libddm-1.so.0
+libdata/pkgconfig/ddm-1.pc
+libexec/desktop-data-engine
+share/dbus-1/services/org.freedesktop.od.Engine.service
+share/desktop-data-model/version
+@dirrm share/desktop-data-model
+@dirrm share/dbus-1/services
+@dirrm share/dbus-1
+@dirrm include/ddm-1/ddm
+@dirrm include/ddm-1