aboutsummaryrefslogtreecommitdiffstats
path: root/net/dhcp6/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-06-13 16:01:17 +0800
committerhrs <hrs@FreeBSD.org>2013-06-13 16:01:17 +0800
commit04f687002185dd81139d4d361807fcaf9f3d1223 (patch)
tree57716a05e07e490ca791470a85b68729b8e71a0e /net/dhcp6/Makefile
parent213acbe147394907d4066b8f8ddafc7999fb95bc (diff)
downloadfreebsd-ports-gnome-04f687002185dd81139d4d361807fcaf9f3d1223.tar.gz
freebsd-ports-gnome-04f687002185dd81139d4d361807fcaf9f3d1223.tar.zst
freebsd-ports-gnome-04f687002185dd81139d4d361807fcaf9f3d1223.zip
- Trim old-style header.
- Take maintainership. - Add LICENSE. - MAKE_JOBS_SAFE=yes. - Use OPTION_DEFINE. - Use PORTDOCS for $DOCSDIR/*.
Diffstat (limited to 'net/dhcp6/Makefile')
-rw-r--r--net/dhcp6/Makefile34
1 files changed, 19 insertions, 15 deletions
diff --git a/net/dhcp6/Makefile b/net/dhcp6/Makefile
index 1a1ca028d77a..b70eda9221e1 100644
--- a/net/dhcp6/Makefile
+++ b/net/dhcp6/Makefile
@@ -1,35 +1,39 @@
-# New ports collection makefile for: dhcp6
-# Date created: 30 July 2004
-# Whom: sumikawa
-#
+# Created by: Munechika SUMIKAWA <sumikawa@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= dhcp6
PORTVERSION= 20080615
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= SF/wide-dhcpv6/wide-dhcpv6/wide-dhcpv6-${PORTVERSION}
DISTNAME= wide-dhcpv6-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= KAME DHCP6 client, server, and relay
-WRKSRC= ${WRKDIR}/${DISTNAME}
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --sysconfdir=${LOCALBASE}/etc --with-localdbdir=/var/db
+CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --with-localdbdir=/var/db
+MAKE_JOBS_SAFE= yes
+USE_RC_SUBR= dhcp6c dhcp6relay dhcp6s
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
MAN5= dhcp6c.conf.5 dhcp6s.conf.5
MAN8= dhcp6c.8 dhcp6s.8 dhcp6relay.8 dhcp6ctl.8
-USE_RC_SUBR= dhcp6c dhcp6relay dhcp6s
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/COPYRIGHT ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} \
+ dhcp6c.conf.sample dhcp6s.conf.sample \
+ ${PREFIX}/etc
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
- ${INSTALL_DATA} ${WRKSRC}/dhcp6c.conf.sample ${PREFIX}/etc
- ${INSTALL_DATA} ${WRKSRC}/dhcp6s.conf.sample ${PREFIX}/etc
.include <bsd.port.mk>