aboutsummaryrefslogtreecommitdiffstats
path: root/net/etunnel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-05-06 03:13:42 +0800
committerkrion <krion@FreeBSD.org>2004-05-06 03:13:42 +0800
commit3c749bf8a17334aef4af39e7a3cb20361f7ba8d9 (patch)
tree532d4583874fa5a1117c7669d8643080268077df /net/etunnel
parent4a604e69148e015b37859989ec9c70566e501939 (diff)
downloadfreebsd-ports-gnome-3c749bf8a17334aef4af39e7a3cb20361f7ba8d9.tar.gz
freebsd-ports-gnome-3c749bf8a17334aef4af39e7a3cb20361f7ba8d9.tar.zst
freebsd-ports-gnome-3c749bf8a17334aef4af39e7a3cb20361f7ba8d9.zip
Add etunnel 0.0.5,
etunnel is a TCP/UDP connections tunneling tool. It can make direct tunnels or via proxy server. PR: ports/66288 Submitted by: Kostas Petrikas <expl@punktas.lt>
Diffstat (limited to 'net/etunnel')
-rw-r--r--net/etunnel/Makefile35
-rw-r--r--net/etunnel/distinfo2
-rw-r--r--net/etunnel/files/patch-etunnel.h15
-rw-r--r--net/etunnel/pkg-descr7
-rw-r--r--net/etunnel/pkg-plist3
5 files changed, 62 insertions, 0 deletions
diff --git a/net/etunnel/Makefile b/net/etunnel/Makefile
new file mode 100644
index 000000000000..fe757c232a59
--- /dev/null
+++ b/net/etunnel/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: etunnel
+# Date created: 03.05.2004
+# Whom: Kostas Petrikas <expl@punktas.lt>
+#
+# $FreeBSD$
+#
+
+PORTNAME= etunnel
+PORTVERSION= 0.0.5
+CATEGORIES= net
+MASTER_SITES= http://expl.homeunix.org/etunnel/
+
+MAINTAINER= expl@punktas.lt
+COMMENT= TCP/UDP connections tunneling tool via proxy or directly
+
+USE_REINPLACE= yes
+ALL_TARGET= ${PORTNAME}
+
+MAN1= etunnel.1
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|CC=gcc|CC?=gcc|g ; \
+ s|CFLAGS=|CFLAGS+=|g' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/etunnel/distinfo b/net/etunnel/distinfo
new file mode 100644
index 000000000000..657620d5180e
--- /dev/null
+++ b/net/etunnel/distinfo
@@ -0,0 +1,2 @@
+MD5 (etunnel-0.0.5.tar.gz) = c49e2783832dd6afc7d70a15ba1a936d
+SIZE (etunnel-0.0.5.tar.gz) = 12678
diff --git a/net/etunnel/files/patch-etunnel.h b/net/etunnel/files/patch-etunnel.h
new file mode 100644
index 000000000000..41b39a529d67
--- /dev/null
+++ b/net/etunnel/files/patch-etunnel.h
@@ -0,0 +1,15 @@
+--- etunnel.h.orig Wed May 5 21:10:21 2004
++++ etunnel.h Wed May 5 21:10:36 2004
+@@ -23,11 +23,11 @@
+ * ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
+ #include <sys/socket.h>
+-#include <sys/types.h>
+ #include <sys/wait.h>
+ #include <sys/time.h>
+ #include <netinet/in.h>
diff --git a/net/etunnel/pkg-descr b/net/etunnel/pkg-descr
new file mode 100644
index 000000000000..4701fd15cd02
--- /dev/null
+++ b/net/etunnel/pkg-descr
@@ -0,0 +1,7 @@
+This is a port of etunnel. Etunnel is a flexible TCP/UDP
+connections tunneling tool. It supports tunnels via proxy
+server (HTTP/SOCKS5), proxy servers chain (HTTP&SOCKS5) and
+directly.
+
+- Kostas Petrikas
+expl@punktas.lt
diff --git a/net/etunnel/pkg-plist b/net/etunnel/pkg-plist
new file mode 100644
index 000000000000..0556590c08ee
--- /dev/null
+++ b/net/etunnel/pkg-plist
@@ -0,0 +1,3 @@
+bin/etunnel
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%