aboutsummaryrefslogtreecommitdiffstats
path: root/net/flower
diff options
context:
space:
mode:
authorEd Schouten <ed@FreeBSD.org>2017-09-07 20:12:52 +0800
committerEd Schouten <ed@FreeBSD.org>2017-09-07 20:12:52 +0800
commita362b81898b0d7de194ec96b2fe1f5fe5ad475a7 (patch)
treef3c1944185d82b0d6f079e167b67affbe2b39cc8 /net/flower
parent919aea344fdfa16b1f7ba68c51a31a3dca6ac368 (diff)
downloadfreebsd-ports-gnome-a362b81898b0d7de194ec96b2fe1f5fe5ad475a7.tar.gz
freebsd-ports-gnome-a362b81898b0d7de194ec96b2fe1f5fe5ad475a7.tar.zst
freebsd-ports-gnome-a362b81898b0d7de194ec96b2fe1f5fe5ad475a7.zip
Add net/flower.
The latest versions of CloudABI make use of a separate daemon to facilitate connecting/listening on the network, called Flower. Add a package for this daemon, as it is a build dependency for the latest version of cloudabi-utils. Reviewed by: mat Differential Revision: https://reviews.freebsd.org/D12264
Diffstat (limited to 'net/flower')
-rw-r--r--net/flower/Makefile34
-rw-r--r--net/flower/distinfo3
-rw-r--r--net/flower/pkg-descr13
-rw-r--r--net/flower/pkg-plist19
4 files changed, 69 insertions, 0 deletions
diff --git a/net/flower/Makefile b/net/flower/Makefile
new file mode 100644
index 000000000000..795cb195be74
--- /dev/null
+++ b/net/flower/Makefile
@@ -0,0 +1,34 @@
+# Created by: Ed Schouten <ed@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= flower
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9
+CATEGORIES= net
+
+MAINTAINER= ed@FreeBSD.org
+COMMENT= Label-based networking daemon
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libarpc.so:devel/arpc \
+ libjsoncpp.so:devel/jsoncpp
+
+USES= cmake localbase:ldflags tar:xz
+USE_GITHUB= yes
+GH_ACCOUNT= NuxiNL
+
+CFLAGS+= -I${LOCALBASE}/include/jsoncpp
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100511
+IGNORE= requires various C++17 features
+.endif
+
+# Require the unit tests to pass prior to installing.
+post-build:
+ @trap '' PIPE && ${WRKSRC}/flower_unittests
+
+.include <bsd.port.post.mk>
diff --git a/net/flower/distinfo b/net/flower/distinfo
new file mode 100644
index 000000000000..baf4e8eb6da2
--- /dev/null
+++ b/net/flower/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1504764102
+SHA256 (NuxiNL-flower-v0.9_GH0.tar.gz) = e712081eb5794245f4e27e591b1a1ea296c1bd6f2941afc2536c04be01355b10
+SIZE (NuxiNL-flower-v0.9_GH0.tar.gz) = 1306944
diff --git a/net/flower/pkg-descr b/net/flower/pkg-descr
new file mode 100644
index 000000000000..71b8b9dc92e3
--- /dev/null
+++ b/net/flower/pkg-descr
@@ -0,0 +1,13 @@
+Flower is a label-based networking daemon.
+
+CloudABI applications are not permitted to call bind or connect on
+sockets directly, as that would conflict with CloudABI's security model.
+Instead, they can send RPCs to fulfill such requests to a separate
+daemon, called Flower.
+
+Like CloudABI, Flower makes use of a capability-based security model.
+This makes it easy to spawn applications in such a way that they can
+only have a limited view of the network, without requiring separate
+users or complex access control policies.
+
+WWW: https://github.com/NuxiNL/flower
diff --git a/net/flower/pkg-plist b/net/flower/pkg-plist
new file mode 100644
index 000000000000..4f9fd50cc8d4
--- /dev/null
+++ b/net/flower/pkg-plist
@@ -0,0 +1,19 @@
+bin/flower_cat
+bin/flower_egress_connect
+bin/flower_ingress_accept
+bin/flower_resolver_getaddrinfo
+bin/flower_switchboard
+include/flower/cat/configuration.proto
+include/flower/cat/configuration.ad.h
+include/flower/ingress/accept/configuration.proto
+include/flower/ingress/accept/configuration.ad.h
+include/flower/protocol/egress.proto
+include/flower/protocol/egress.ad.h
+include/flower/protocol/resolver.proto
+include/flower/protocol/resolver.ad.h
+include/flower/protocol/server.proto
+include/flower/protocol/server.ad.h
+include/flower/protocol/switchboard.proto
+include/flower/protocol/switchboard.ad.h
+include/flower/switchboard/configuration.proto
+include/flower/switchboard/configuration.ad.h