aboutsummaryrefslogtreecommitdiffstats
path: root/net/freeradius
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-02-06 23:30:14 +0800
committersem <sem@FreeBSD.org>2006-02-06 23:30:14 +0800
commit865cc19aa264561317925c1c03071677667e2cb5 (patch)
tree9b42d49a0f8e82ad22a84129f537be068fead726 /net/freeradius
parent3e9e73d257e95108c58d277fe1057f177c8fb15f (diff)
downloadfreebsd-ports-gnome-865cc19aa264561317925c1c03071677667e2cb5.tar.gz
freebsd-ports-gnome-865cc19aa264561317925c1c03071677667e2cb5.tar.zst
freebsd-ports-gnome-865cc19aa264561317925c1c03071677667e2cb5.zip
- Fix a dictionary bug affected on 64 bit archs.
- While I'm here: fix pkg-plist - remove radiusd.sh. - Bump PORTREVISION PR: ports/92887 Submitted by: Alessandro Dellavedova <alessandro.dellavedova@gmail.com> Obtained from: http://bugs.freeradius.org/show_bug.cgi?id=312
Diffstat (limited to 'net/freeradius')
-rw-r--r--net/freeradius/Makefile2
-rw-r--r--net/freeradius/files/patch-src-lib-dict.c11
-rw-r--r--net/freeradius/pkg-plist1
3 files changed, 12 insertions, 2 deletions
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
index 5bb11838a450..4184ef20e17a 100644
--- a/net/freeradius/Makefile
+++ b/net/freeradius/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freeradius
PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
http://freeradius.portal-to-web.de/
diff --git a/net/freeradius/files/patch-src-lib-dict.c b/net/freeradius/files/patch-src-lib-dict.c
new file mode 100644
index 000000000000..ace7044307be
--- /dev/null
+++ b/net/freeradius/files/patch-src-lib-dict.c
@@ -0,0 +1,11 @@
+--- src/lib/dict.c.orig Mon Feb 6 10:15:41 2006
++++ src/lib/dict.c Mon Feb 6 10:16:07 2006
+@@ -1207,7 +1207,7 @@
+ if (!name) return NULL;
+
+ hash = dict_hashname(name);
+- hash = lrad_hash_update(&attr, sizeof(&attr), hash);
++ hash = lrad_hash_update(&attr, sizeof(attr), hash);
+
+ return lrad_hash_table_finddata(values_byname, hash);
+ }
diff --git a/net/freeradius/pkg-plist b/net/freeradius/pkg-plist
index 0237bdbdf13f..e2a51b096b59 100644
--- a/net/freeradius/pkg-plist
+++ b/net/freeradius/pkg-plist
@@ -55,7 +55,6 @@ etc/raddb/realms.sample
etc/raddb/snmp.conf.sample
etc/raddb/sql.conf.sample
etc/raddb/users.sample
-etc/rc.d/radiusd.sh
lib/libeap-%%PORTVERSION%%.la
lib/libeap-%%PORTVERSION%%.so
lib/libeap.a