aboutsummaryrefslogtreecommitdiffstats
path: root/net/fspd
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-05 20:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-05 20:51:05 +0800
commit1594a2b796f83b44f0ac778d9d79c529a0e17c36 (patch)
tree413f7b40f311ee16bcc0b96d6884ec01be654394 /net/fspd
parent7c48582402b60f4e4fe1ba7c0618b09a4e78a9b8 (diff)
downloadfreebsd-ports-gnome-1594a2b796f83b44f0ac778d9d79c529a0e17c36.tar.gz
freebsd-ports-gnome-1594a2b796f83b44f0ac778d9d79c529a0e17c36.tar.zst
freebsd-ports-gnome-1594a2b796f83b44f0ac778d9d79c529a0e17c36.zip
Convert to new options framework
Diffstat (limited to 'net/fspd')
-rw-r--r--net/fspd/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/net/fspd/Makefile b/net/fspd/Makefile
index db23b0950082..04c4f46ed03a 100644
--- a/net/fspd/Makefile
+++ b/net/fspd/Makefile
@@ -34,16 +34,17 @@ USE_SCONS= yes
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
-OPTIONS= NOCLIENTS "Omit client commands" off \
- INFINITE "Infinite retry in client commands" off
+OPTIONS_DEFINE= NOCLIENTS INFINITE
+NOCLIENTS_DESC= Omit client commands
+INFINITE_DESC= Infinite retry in client commands
.include <bsd.port.pre.mk>
-.if defined(WITH_INFINITE)
+.if ${PORT_OPTIONS:MINFINITE}
SCONS_ARGS+= disable-timeout=yes
.endif
-.if !defined(WITH_NOCLIENTS)
+.if ! ${PORT_OPTIONS:MNOCLIENTS}
.for command in ${CLIENTS}
PLIST_FILES+= bin/${command}
.endfor
@@ -61,13 +62,13 @@ post-build:
@${CP} ${WRKSRC}/doc/*.html ${WRKSRC}
do-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif
-.if !defined(WITH_NOCLIENTS)
+.if ! ${PORT_OPTIONS:MNOCLIENTS}
.for command in ${CLIENTS}
${INSTALL_PROGRAM} ${WRKSRC}/clients/${command} ${PREFIX}/bin
.endfor