aboutsummaryrefslogtreecommitdiffstats
path: root/net/glflow/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 08:27:07 +0800
committermarino <marino@FreeBSD.org>2016-09-11 08:27:07 +0800
commit73c832a3279fb162dcf1618e4bce06fca05313c3 (patch)
tree2b386f07ceea5683c0f9db0c1bbf822b0bd69d96 /net/glflow/Makefile
parentea1c1133c6c04aa1c5d147023814ccf2cf142375 (diff)
downloadfreebsd-ports-gnome-73c832a3279fb162dcf1618e4bce06fca05313c3.tar.gz
freebsd-ports-gnome-73c832a3279fb162dcf1618e4bce06fca05313c3.tar.zst
freebsd-ports-gnome-73c832a3279fb162dcf1618e4bce06fca05313c3.zip
net/glflow: document SSL requirement and add SSL flags
While here, convert to USES=tar too. Approved by: SSL blanket
Diffstat (limited to 'net/glflow/Makefile')
-rw-r--r--net/glflow/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/glflow/Makefile b/net/glflow/Makefile
index ea6c50c231b7..a5f86135d7a1 100644
--- a/net/glflow/Makefile
+++ b/net/glflow/Makefile
@@ -7,11 +7,11 @@ PORTEPOCH= 1
CATEGORIES= net security
MASTER_SITES= SF
DISTNAME= glFlow-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= lx@FreeBSD.org
COMMENT= NetFlow tool for detecting DoS attacks
+USES= ssl tar:tgz
PLIST_FILES= bin/glflow
PORTDOCS= README
WRKSRC= ${WRKDIR}/${PORTNAME}-0.1
@@ -21,6 +21,10 @@ OPTIONS_DEFINE= DOCS
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-debug --with-hash=md4
+CPPFLAGS+= -I${OPENSSLINC}
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/glflow ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DOCSDIR}