aboutsummaryrefslogtreecommitdiffstats
path: root/net/glusterfs
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2020-12-28 20:11:33 +0800
committerDima Panov <fluffy@FreeBSD.org>2020-12-28 20:11:33 +0800
commit9000db9c1dcdba399a19f2b7f7d7b485ef74ccda (patch)
tree6591a024856029f90360ae31582cb7b6294ef308 /net/glusterfs
parent9524ab725aaf0a8777af12168988f4e881171475 (diff)
downloadfreebsd-ports-gnome-9000db9c1dcdba399a19f2b7f7d7b485ef74ccda.tar.gz
freebsd-ports-gnome-9000db9c1dcdba399a19f2b7f7d7b485ef74ccda.tar.zst
freebsd-ports-gnome-9000db9c1dcdba399a19f2b7f7d7b485ef74ccda.zip
net/glusterfs: unbreak build with python != 3.7
- get rid of hardcoded py37 suffixes in plist, use PYTHON_SUFFIX macro - add missed files to plist - bump PORTREVISION With hat: ports-secteam
Diffstat (limited to 'net/glusterfs')
-rw-r--r--net/glusterfs/Makefile3
-rw-r--r--net/glusterfs/pkg-plist66
2 files changed, 35 insertions, 34 deletions
diff --git a/net/glusterfs/Makefile b/net/glusterfs/Makefile
index d647171b565d..9802414764d6 100644
--- a/net/glusterfs/Makefile
+++ b/net/glusterfs/Makefile
@@ -2,7 +2,7 @@
PORTNAME= glusterfs
PORTVERSION= 8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://bits.gluster.org/pub/gluster/glusterfs/src/
@@ -51,6 +51,7 @@ SHEBANG_FILES= build-aux/pkg-version \
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
+USE_PYTHON= py3kplist
USE_RC_SUBR= glusterd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-epoll \
diff --git a/net/glusterfs/pkg-plist b/net/glusterfs/pkg-plist
index c6f94f2140bb..f694dc06b81d 100644
--- a/net/glusterfs/pkg-plist
+++ b/net/glusterfs/pkg-plist
@@ -201,13 +201,13 @@ lib/ocf/resource.d/heartbeat/ganesha_grace
lib/ocf/resource.d/heartbeat/ganesha_mon
lib/ocf/resource.d/heartbeat/ganesha_nfsd
%%PYTHON_SITELIBDIR%%/gluster/__init__.py
-%%PYTHON_SITELIBDIR%%/gluster/__pycache__/__init__.cpython-37.opt-1.pyc
-%%PYTHON_SITELIBDIR%%/gluster/__pycache__/__init__.cpython-37.pyc
+%%PYTHON_SITELIBDIR%%/gluster/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/gluster/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/gluster/cliutils/__init__.py
-%%PYTHON_SITELIBDIR%%/gluster/cliutils/__pycache__/__init__.cpython-37.opt-1.pyc
-%%PYTHON_SITELIBDIR%%/gluster/cliutils/__pycache__/__init__.cpython-37.pyc
-%%PYTHON_SITELIBDIR%%/gluster/cliutils/__pycache__/cliutils.cpython-37.opt-1.pyc
-%%PYTHON_SITELIBDIR%%/gluster/cliutils/__pycache__/cliutils.cpython-37.pyc
+%%PYTHON_SITELIBDIR%%/gluster/cliutils/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/gluster/cliutils/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/gluster/cliutils/__pycache__/cliutils.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/gluster/cliutils/__pycache__/cliutils.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/gluster/cliutils/cliutils.py
libdata/pkgconfig/glusterfs-api.pc
libdata/pkgconfig/libgfchangelog.pc
@@ -216,18 +216,18 @@ libexec/ganesha/dbus-send.sh
libexec/ganesha/ganesha-ha.sh
libexec/ganesha/generate-epoch.py
libexec/glusterfs/gfevents/__init__.py
-libexec/glusterfs/gfevents/__pycache__/__init__.cpython-37.opt-1.pyc
-libexec/glusterfs/gfevents/__pycache__/__init__.cpython-37.pyc
-libexec/glusterfs/gfevents/__pycache__/eventsapiconf.cpython-37.opt-1.pyc
-libexec/glusterfs/gfevents/__pycache__/eventsapiconf.cpython-37.pyc
-libexec/glusterfs/gfevents/__pycache__/eventtypes.cpython-37.opt-1.pyc
-libexec/glusterfs/gfevents/__pycache__/eventtypes.cpython-37.pyc
-libexec/glusterfs/gfevents/__pycache__/gf_event.cpython-37.opt-1.pyc
-libexec/glusterfs/gfevents/__pycache__/gf_event.cpython-37.pyc
-libexec/glusterfs/gfevents/__pycache__/handlers.cpython-37.opt-1.pyc
-libexec/glusterfs/gfevents/__pycache__/handlers.cpython-37.pyc
-libexec/glusterfs/gfevents/__pycache__/utils.cpython-37.opt-1.pyc
-libexec/glusterfs/gfevents/__pycache__/utils.cpython-37.pyc
+libexec/glusterfs/gfevents/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/gfevents/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/gfevents/__pycache__/eventsapiconf.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/gfevents/__pycache__/eventsapiconf.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/gfevents/__pycache__/eventtypes.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/gfevents/__pycache__/eventtypes.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/gfevents/__pycache__/gf_event.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/gfevents/__pycache__/gf_event.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/gfevents/__pycache__/handlers.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/gfevents/__pycache__/handlers.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/gfevents/__pycache__/utils.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/gfevents/__pycache__/utils.cpython-%%PYTHON_SUFFIX%%.pyc
libexec/glusterfs/gfevents/eventsapiconf.py
libexec/glusterfs/gfevents/eventtypes.py
libexec/glusterfs/gfevents/gf_event.py
@@ -239,22 +239,21 @@ libexec/glusterfs/gfind_missing_files/gfid_to_path.py
libexec/glusterfs/gfind_missing_files/gfid_to_path.sh
libexec/glusterfs/gfind_missing_files/gfind_missing_files.sh
libexec/glusterfs/glfsheal
-libexec/glusterfs/glusterfind/S57glusterfind-delete-post.py
libexec/glusterfs/glusterfind/__init__.py
-libexec/glusterfs/glusterfind/__pycache__/__init__.cpython-37.opt-1.pyc
-libexec/glusterfs/glusterfind/__pycache__/__init__.cpython-37.pyc
-libexec/glusterfs/glusterfind/__pycache__/changelogdata.cpython-37.opt-1.pyc
-libexec/glusterfs/glusterfind/__pycache__/changelogdata.cpython-37.pyc
-libexec/glusterfs/glusterfind/__pycache__/conf.cpython-37.opt-1.pyc
-libexec/glusterfs/glusterfind/__pycache__/conf.cpython-37.pyc
-libexec/glusterfs/glusterfind/__pycache__/gfind_py2py3.cpython-37.opt-1.pyc
-libexec/glusterfs/glusterfind/__pycache__/gfind_py2py3.cpython-37.pyc
-libexec/glusterfs/glusterfind/__pycache__/libgfchangelog.cpython-37.opt-1.pyc
-libexec/glusterfs/glusterfind/__pycache__/libgfchangelog.cpython-37.pyc
-libexec/glusterfs/glusterfind/__pycache__/main.cpython-37.opt-1.pyc
-libexec/glusterfs/glusterfind/__pycache__/main.cpython-37.pyc
-libexec/glusterfs/glusterfind/__pycache__/utils.cpython-37.opt-1.pyc
-libexec/glusterfs/glusterfind/__pycache__/utils.cpython-37.pyc
+libexec/glusterfs/glusterfind/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/glusterfind/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/glusterfind/__pycache__/changelogdata.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/glusterfind/__pycache__/changelogdata.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/glusterfind/__pycache__/conf.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/glusterfind/__pycache__/conf.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/glusterfind/__pycache__/gfind_py2py3.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/glusterfind/__pycache__/gfind_py2py3.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/glusterfind/__pycache__/libgfchangelog.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/glusterfind/__pycache__/libgfchangelog.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/glusterfind/__pycache__/main.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/glusterfind/__pycache__/main.cpython-%%PYTHON_SUFFIX%%.pyc
+libexec/glusterfs/glusterfind/__pycache__/utils.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+libexec/glusterfs/glusterfind/__pycache__/utils.cpython-%%PYTHON_SUFFIX%%.pyc
libexec/glusterfs/glusterfind/brickfind.py
libexec/glusterfs/glusterfind/changelog.py
libexec/glusterfs/glusterfind/changelogdata.py
@@ -263,6 +262,7 @@ libexec/glusterfs/glusterfind/gfind_py2py3.py
libexec/glusterfs/glusterfind/libgfchangelog.py
libexec/glusterfs/glusterfind/main.py
libexec/glusterfs/glusterfind/nodeagent.py
+libexec/glusterfs/glusterfind/S57glusterfind-delete-post.py
libexec/glusterfs/glusterfind/tool.conf
libexec/glusterfs/glusterfind/utils.py
libexec/glusterfs/peer_add_secret_pub