aboutsummaryrefslogtreecommitdiffstats
path: root/net/go-cs/Makefile
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-07-07 09:03:51 +0800
committerRichard Gallamore <ultima@FreeBSD.org>2017-07-07 09:03:51 +0800
commit45219604c9f30d722d56a5e05e6f257e0374c938 (patch)
tree5495849794a968f0c86512bf295098c054b001d4 /net/go-cs/Makefile
parentb23b4e69f0d9b894ee51be0efe2d2c1a7a96b7b1 (diff)
downloadfreebsd-ports-gnome-45219604c9f30d722d56a5e05e6f257e0374c938.tar.gz
freebsd-ports-gnome-45219604c9f30d722d56a5e05e6f257e0374c938.tar.zst
freebsd-ports-gnome-45219604c9f30d722d56a5e05e6f257e0374c938.zip
* Updated to 0.7
* Fixed pkg-descr * Added USES= go * Removed unnecessary code - Fix error in cs.1 PR: 220497 Submitted by: Andy Kosela <akosela@andykosela.com> (maintainer) Reviewed by: lifanov (mentor) Approved by: lifanov (mentor) Differential Revision: https://reviews.freebsd.org/D11503
Diffstat (limited to 'net/go-cs/Makefile')
-rw-r--r--net/go-cs/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/net/go-cs/Makefile b/net/go-cs/Makefile
index ceeaa9e76eaa..3afc290e18a3 100644
--- a/net/go-cs/Makefile
+++ b/net/go-cs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= go-cs
-PORTVERSION= 0.6
+PORTVERSION= 0.7
DISTVERSIONPREFIX= v
CATEGORIES= net
@@ -12,21 +12,15 @@ COMMENT= Concurrent ssh client
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${GO_CMD}:lang/go
-
+USES= go
USE_GITHUB= yes
GH_ACCOUNT= akosela
PLIST_FILES= bin/cs man/man1/cs.1.gz
-GO_CMD= ${LOCALBASE}/bin/go
-GO_ARGS= build -ldflags "${STRIP}"
-
-do-build:
- (cd ${WRKSRC}/cs && ${GO_CMD} ${GO_ARGS} cs.go)
+GO_TARGET= ${GO_PKGNAME}/cs
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cs/cs ${STAGEDIR}${PREFIX}/bin
+post-install:
${INSTALL_MAN} ${WRKSRC}/cs.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>