aboutsummaryrefslogtreecommitdiffstats
path: root/net/gq
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-07-29 07:52:35 +0800
committeredwin <edwin@FreeBSD.org>2004-07-29 07:52:35 +0800
commit34416a8a75466ab1d9edcd3f0529482cda45b64a (patch)
tree4155697e29e7d330fed301787d4f46e876e5c787 /net/gq
parent68d6c9ab900c5258bdec5af380dae4bda4a0d3f8 (diff)
downloadfreebsd-ports-gnome-34416a8a75466ab1d9edcd3f0529482cda45b64a.tar.gz
freebsd-ports-gnome-34416a8a75466ab1d9edcd3f0529482cda45b64a.tar.zst
freebsd-ports-gnome-34416a8a75466ab1d9edcd3f0529482cda45b64a.zip
Restore state restoration capabilities
Obtained from: http://sourceforge.net/mailarchive/forum.php?thread_id=4791405&forum_id=5986
Diffstat (limited to 'net/gq')
-rw-r--r--net/gq/Makefile2
-rw-r--r--net/gq/files/patch-src::state.c11
-rw-r--r--net/gq/files/patch-src::xmlparse.c24
3 files changed, 36 insertions, 1 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index de20118e5be5..bcda7fa6ef76 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gq
PORTVERSION= 1.0b1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gqclient
diff --git a/net/gq/files/patch-src::state.c b/net/gq/files/patch-src::state.c
new file mode 100644
index 000000000000..4e80d0bcbfd3
--- /dev/null
+++ b/net/gq/files/patch-src::state.c
@@ -0,0 +1,11 @@
+--- src/state.c.orig Thu Jul 29 09:44:27 2004
++++ src/state.c Thu Jul 29 09:44:51 2004
+@@ -754,7 +754,7 @@
+ }
+ }
+
+- if (n != NULL && v->type != 0) {
++ if (n != NULL && v!=NULL && v->type != 0) {
+ char *ep;
+
+ assert(v);
diff --git a/net/gq/files/patch-src::xmlparse.c b/net/gq/files/patch-src::xmlparse.c
new file mode 100644
index 000000000000..f00dca620bd6
--- /dev/null
+++ b/net/gq/files/patch-src::xmlparse.c
@@ -0,0 +1,24 @@
+--- src/xmlparse.c.orig Thu Jul 29 09:46:26 2004
++++ src/xmlparse.c Thu Jul 29 09:47:09 2004
+@@ -51,7 +51,7 @@
+ #include "xmlparse.h"
+
+ #define malloc g_malloc
+-#define calloc(n,s) g_malloc0(n * s)
++#define calloc(n,s) g_malloc0((n) * (s))
+
+ #define TAGSTACK_INCR 20
+
+@@ -162,10 +162,11 @@
+ e->attrs = NULL;
+ if (attrs) {
+ for (i = 0 ; attrs[i] ; i++) ;
+- e->attrs = calloc(i, sizeof(xmlChar *));
++ e->attrs = calloc(i+1, sizeof(xmlChar *));
+ for (i = 0 ; attrs[i] ; i++) {
+ e->attrs[i] = strdup(attrs[i]);
+ }
++ e->attrs[i] = NULL;
+ }
+
+ /* lookup handler */