aboutsummaryrefslogtreecommitdiffstats
path: root/net/gupnp
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-03-23 16:09:34 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-03-23 16:09:34 +0800
commit0640834aa49b6581be0e01fba37ea2f6035d4de6 (patch)
tree31166e80fb63403e0e628f8ce9f9b44d730a31ca /net/gupnp
parent776065be862ed71fef9d6cfa2cecfa1146ba86f3 (diff)
downloadfreebsd-ports-gnome-0640834aa49b6581be0e01fba37ea2f6035d4de6.tar.gz
freebsd-ports-gnome-0640834aa49b6581be0e01fba37ea2f6035d4de6.tar.zst
freebsd-ports-gnome-0640834aa49b6581be0e01fba37ea2f6035d4de6.zip
- Update to 0.20.1
- Use USES=pathfix - Cleanup Makefile header Changes: http://git.gnome.org/browse/gupnp/tree/NEWS
Diffstat (limited to 'net/gupnp')
-rw-r--r--net/gupnp/Makefile15
-rw-r--r--net/gupnp/distinfo4
-rw-r--r--net/gupnp/files/patch-libgupnp_gupnp-control-point.c6
-rw-r--r--net/gupnp/files/patch-libgupnp_gupnp-services.c30
4 files changed, 28 insertions, 27 deletions
diff --git a/net/gupnp/Makefile b/net/gupnp/Makefile
index 76b706523ce3..fdd07fce7a41 100644
--- a/net/gupnp/Makefile
+++ b/net/gupnp/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: gupnp
-# Date created: 2009-12-26
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gupnp
-PORTVERSION= 0.18.4
+PORTVERSION= 0.20.1
CATEGORIES= net
MASTER_SITES= GNOME
@@ -21,15 +17,16 @@ LIB_DEPENDS= gssdp-1.0:${PORTSDIR}/net/gssdp \
uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
CONFIGURE_ARGS= --enable-introspection=yes
+CONFIGURE_ENV= VAPIGEN=""
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack
+USE_GNOME= glib20
USE_LDCONFIG= yes
USE_PYTHON= yes
USE_XZ= yes
+USES= pathfix
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
- ${WRKSRC}/tools/gupnp-binding-tool
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' ${WRKSRC}/tools/gupnp-binding-tool
.include <bsd.port.mk>
diff --git a/net/gupnp/distinfo b/net/gupnp/distinfo
index 629606ab4a69..82f7cfda432e 100644
--- a/net/gupnp/distinfo
+++ b/net/gupnp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gupnp-0.18.4.tar.xz) = 6b437d5711b212292c6080626b97480268310da636a6cf937ad6119291af78a1
-SIZE (gupnp-0.18.4.tar.xz) = 361524
+SHA256 (gupnp-0.20.1.tar.xz) = a98ab69289742a075c9a7655650e0d1944a3886bb7851bf40ed82608a9ddac61
+SIZE (gupnp-0.20.1.tar.xz) = 368108
diff --git a/net/gupnp/files/patch-libgupnp_gupnp-control-point.c b/net/gupnp/files/patch-libgupnp_gupnp-control-point.c
index b46b5663ee0f..d06447aec242 100644
--- a/net/gupnp/files/patch-libgupnp_gupnp-control-point.c
+++ b/net/gupnp/files/patch-libgupnp_gupnp-control-point.c
@@ -1,6 +1,6 @@
---- libgupnp/gupnp-control-point.c.orig 2009-08-24 18:29:33.000000000 +0200
-+++ libgupnp/gupnp-control-point.c 2009-12-26 14:32:06.000000000 +0100
-@@ -658,7 +658,7 @@
+--- libgupnp/gupnp-control-point.c.orig 2012-11-29 07:13:43.000000000 +0800
++++ libgupnp/gupnp-control-point.c 2013-03-15 16:00:16.921426942 +0800
+@@ -692,7 +692,7 @@
/* Count elements */
count = g_strv_length (bits);
diff --git a/net/gupnp/files/patch-libgupnp_gupnp-services.c b/net/gupnp/files/patch-libgupnp_gupnp-services.c
index 57ef4ded229b..4d7ba13121ae 100644
--- a/net/gupnp/files/patch-libgupnp_gupnp-services.c
+++ b/net/gupnp/files/patch-libgupnp_gupnp-services.c
@@ -1,26 +1,30 @@
---- libgupnp/gupnp-service.c.orig 2009-12-02 15:27:43.000000000 +0100
-+++ libgupnp/gupnp-service.c 2009-12-26 14:30:23.000000000 +0100
-@@ -30,7 +30,11 @@
+--- libgupnp/gupnp-service.c.orig 2013-02-20 20:35:57.000000000 +0800
++++ libgupnp/gupnp-service.c 2013-03-15 16:04:28.277418472 +0800
+@@ -30,6 +30,7 @@
#include <gobject/gvaluecollector.h>
#include <gmodule.h>
#include <libsoup/soup-date.h>
-+#if defined(__NetBSD__) || defined(__DragonFly__) || defined(__FreeBSD__)
-+#include <uuid.h>
-+#else
- #include <uuid/uuid.h>
-+#endif
++#include <libsoup/soup-date.h>
#include <string.h>
#include "gupnp-service.h"
#include "gupnp-root-device.h"
-@@ -867,9 +871,19 @@
- {
+@@ -43,6 +44,8 @@
+
+ #ifdef G_OS_WIN32
+ #include <rpc.h>
++#elsif defined(__NetBSD__) || defined(__DragonFly__) || defined(__FreeBSD__)
++#include <uuid.h>
+ #else
+ #include <uuid/uuid.h>
+ #endif
+@@ -1100,9 +1103,19 @@
+ #else
uuid_t id;
char out[39];
--
+#if defined(__NetBSD__) || defined(__DragonFly__) || defined(__FreeBSD__)
+ char *myout;
+#endif
-+
+
+#if defined(__NetBSD__) || defined(__DragonFly__) || defined(__FreeBSD__)
+ uuid_create(&id, 0);
+ uuid_to_string(&id, &myout, 0);
@@ -32,4 +36,4 @@
+#endif
return g_strdup_printf ("uuid:%s", out);
- }
+ #endif