aboutsummaryrefslogtreecommitdiffstats
path: root/net/haproxy/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2015-10-21 18:59:46 +0800
committerdemon <demon@FreeBSD.org>2015-10-21 18:59:46 +0800
commit72b21437aa9e523a188df92b552051c353f7f343 (patch)
treea46b15fc32c210b3d01e8adb4c9cb6e79c2574e3 /net/haproxy/Makefile
parent514baeb73bcb614c7558868e323e8ba46e982d89 (diff)
downloadfreebsd-ports-gnome-72b21437aa9e523a188df92b552051c353f7f343.tar.gz
freebsd-ports-gnome-72b21437aa9e523a188df92b552051c353f7f343.tar.zst
freebsd-ports-gnome-72b21437aa9e523a188df92b552051c353f7f343.zip
Update to version 1.6.1.
Diffstat (limited to 'net/haproxy/Makefile')
-rw-r--r--net/haproxy/Makefile31
1 files changed, 28 insertions, 3 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 2f6936486cd7..60ec29c1675c 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= haproxy
-PORTVERSION= 1.5.14
+PORTVERSION= 1.6.1
CATEGORIES= net www
-MASTER_SITES= http://www.haproxy.org/download/1.5/src/
+MASTER_SITES= http://www.haproxy.org/download/1.6/src/
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= demon@FreeBSD.org
COMMENT= The Reliable, High Performance TCP/HTTP Load Balancer
@@ -17,11 +18,16 @@ CONFLICTS= haproxy-devel-[0-9]*
USES= cpe gmake
USE_RC_SUBR= haproxy
-OPTIONS_DEFINE= DOCS EXAMPLES OPENSSL
+DEVICEATLAS_VERSION= 2.1
+DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
+DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
+
+OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE
OPTIONS_RADIO_PCRE= DPCRE SPCRE
DPCRE_DESC= Link dynamically
SPCRE_DESC= Link statically
+DEVICEATLAS_DESC= DeviceAtlas Device Detection support
OPTIONS_DEFAULT= SPCRE OPENSSL
.include <bsd.port.options.mk>
@@ -33,16 +39,35 @@ MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
MAKE_ARGS+= USE_PCRE=1 USE_PCRE_JIT=1
.endif
+
.if ${PORT_OPTIONS:MSPCRE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
MAKE_ARGS+= USE_STATIC_PCRE=1 USE_PCRE_JIT=1
.endif
+.if ${PORT_OPTIONS:MDEVICEATLAS}
+.if !exists(${DISTDIR}/${DEVICEATLAS_DISTFILE}.zip)
+IGNORE?= You must manually fetch the DeviceAtlas Device Detection C API from ${DEVICEATLAS_REGISTRATION_URL} and place it in ${DISTDIR} and then run make again
+.else
+RESTRICTED= The redistribution of the DeviceAtlas Device Detection C API is not permitted
+DISTFILES+= ${DEVICEATLAS_DISTFILE}.zip
+MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_SRC=${WRKDIR}/deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
+.endif
+.if ! ${PORT_OPTIONS:MDPCRE} && ! ${PORT_OPTIONS:MSPCRE}
+IGNORE?= Enable PCRE support to use DeviceAtlas
+.endif
+.endif
+
.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
MAKE_ARGS+= USE_OPENSSL=1
.endif
+.if ${PORT_OPTIONS:MLUA}
+USES+= lua:53
+MAKE_ARGS+= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NAME=lua-${LUA_VER}
+.endif
+
post-build:
cd ${WRKSRC}/contrib/halog && ${MAKE_CMD} ${MAKE_ENV}