aboutsummaryrefslogtreecommitdiffstats
path: root/net/haproxy/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-11-13 20:09:59 +0800
committermarino <marino@FreeBSD.org>2015-11-13 20:09:59 +0800
commit8188c11211fa59b202aa497343cc3f33744b6415 (patch)
tree177d73e53039781f7c52c24a67621017f06b90fd /net/haproxy/Makefile
parentc11c36a49b57500541b5419315fee660a5fbb204 (diff)
downloadfreebsd-ports-gnome-8188c11211fa59b202aa497343cc3f33744b6415.tar.gz
freebsd-ports-gnome-8188c11211fa59b202aa497343cc3f33744b6415.tar.zst
freebsd-ports-gnome-8188c11211fa59b202aa497343cc3f33744b6415.zip
net/haproxy: Move MAKE_ARGS above <bsd.port.options.mk>
If it comes after the inclusion, MAKE_ARGS can't be modified by local Makefiles, e.g. Makefile.local or Makefile.${OPSYS} Approved by: just fix it
Diffstat (limited to 'net/haproxy/Makefile')
-rw-r--r--net/haproxy/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index ae1b80dd2c01..71e62938fd05 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -23,6 +23,9 @@ DEVICEATLAS_VERSION= 2.1
DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
+MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" CFLAGS="${CFLAGS}"
+
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE
OPTIONS_RADIO_PCRE= DPCRE SPCRE
@@ -33,9 +36,6 @@ OPTIONS_DEFAULT= SPCRE OPENSSL
.include <bsd.port.options.mk>
-MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" CFLAGS="${CFLAGS}"
-
.if ${PORT_OPTIONS:MDPCRE}
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
MAKE_ARGS+= USE_PCRE=1 USE_PCRE_JIT=1