aboutsummaryrefslogtreecommitdiffstats
path: root/net/hostapd
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-13 13:01:26 +0800
committermarino <marino@FreeBSD.org>2016-09-13 13:01:26 +0800
commit0f72ec70b5061cea6b3eacb868aad87c67baedac (patch)
tree22a84252850b1d1ee367905fbacd6636fc5b7804 /net/hostapd
parentaaeea5bb53b813c50c6140ae3137639b772851ce (diff)
downloadfreebsd-ports-gnome-0f72ec70b5061cea6b3eacb868aad87c67baedac.tar.gz
freebsd-ports-gnome-0f72ec70b5061cea6b3eacb868aad87c67baedac.tar.zst
freebsd-ports-gnome-0f72ec70b5061cea6b3eacb868aad87c67baedac.zip
net/hostapd: Remove PORTS_SSL option and use SSL_DEFAULT
The port is now configured depending on the SSL base specified by the SSL_DEFAULT variable. Before it would break by default if SSL_DEFAULT was set to non-base. This changes puts hostapd in line with the rest of the ports tree. Approved by: SSL blanket
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile25
1 files changed, 4 insertions, 21 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index f7fa07011982..bd93e7dd6f8f 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hostapd
PORTVERSION= 2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://w1.fi/releases/
@@ -12,31 +12,14 @@ COMMENT= IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
LICENSE= BSD3CLAUSE
-USES= cpe gmake
+USES= cpe gmake ssl
CPE_VENDOR= w1.f1
-USE_OPENSSL= yes
BUILD_WRKSRC= ${WRKSRC}/hostapd
+CONFIGURE_ARGS= --with-ssl-dir=${OPENSSLBASE}
PLIST_FILES= sbin/hostapd sbin/hostapd_cli man/man1/hostapd_cli.1.gz \
man/man8/hostapd.8.gz
-OPTIONS_DEFINE= PORTS_SSL
-
-PORTS_SSL_DESC= Build with OpenSSL from ports (instead of base system)
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MPORTS_SSL}
-.if ${SSL_DEFAULT} == base
-IGNORE= the PORTS_SSL option not allowed when using SSL from base
-.endif
-CONFIGURE_ARGS+= --with-ssl-dir=${PREFIX}
-.else
-.if ${SSL_DEFAULT} != base
-IGNORE= the PORTS_SSL option is required when using SSL from ports
-.endif
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|@$$(E) " CC " $$<|@$$(E) " $$(CC) " $$<|' \
${BUILD_WRKSRC}/Makefile
@@ -52,4 +35,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/hostapd/hostapd.8 \
${STAGEDIR}${MANPREFIX}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>