aboutsummaryrefslogtreecommitdiffstats
path: root/net/icpld
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-07 07:37:03 +0800
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-07 07:37:03 +0800
commit3583bb35552b55b354e85fc002b80d4c8964f1aa (patch)
tree36c43444635de13a559b156f2f77756328b675b5 /net/icpld
parent2af05b1174d4d1787b276e16952cb625efa3fe46 (diff)
downloadfreebsd-ports-gnome-3583bb35552b55b354e85fc002b80d4c8964f1aa.tar.gz
freebsd-ports-gnome-3583bb35552b55b354e85fc002b80d4c8964f1aa.tar.zst
freebsd-ports-gnome-3583bb35552b55b354e85fc002b80d4c8964f1aa.zip
Add icpld-0.5.0,
ICPLD (Internet Connection Performance Logging Daemon) is a daemon which, by sending ICMP requests to an IP address of your choice, monitors whether your machine has a working network connection. It will log any failed attempts, and will stamp a log as soon as a reply is received. It keeps track of when the connection was unavailable, as well as for how long. It records both total down time and each occasion of interrupted connection. The log can also be duplicated in HTML format to put online.
Diffstat (limited to 'net/icpld')
-rw-r--r--net/icpld/Makefile34
-rw-r--r--net/icpld/distinfo1
-rw-r--r--net/icpld/pkg-descr11
-rw-r--r--net/icpld/pkg-plist3
4 files changed, 49 insertions, 0 deletions
diff --git a/net/icpld/Makefile b/net/icpld/Makefile
new file mode 100644
index 000000000000..d694e34ca4c8
--- /dev/null
+++ b/net/icpld/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: icpld
+# Date created: 04.01.2004
+# Whom: krion@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= icpld
+PORTVERSION= 0.5.0
+CATEGORIES= net
+MASTER_SITES= http://www.ibiblio.org/icpld/download/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Internet connection performance logging daemon
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= ${PORTNAME}.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/icpld/distinfo b/net/icpld/distinfo
new file mode 100644
index 000000000000..d541b5002300
--- /dev/null
+++ b/net/icpld/distinfo
@@ -0,0 +1 @@
+MD5 (icpld-0.5.0.tar.bz2) = af513de8607f574c43b8c02432308427
diff --git a/net/icpld/pkg-descr b/net/icpld/pkg-descr
new file mode 100644
index 000000000000..2c328c8453a3
--- /dev/null
+++ b/net/icpld/pkg-descr
@@ -0,0 +1,11 @@
+ICPLD (Internet Connection Performance Logging Daemon) is a
+daemon which, by sending ICMP requests to an IP address of your
+choice, monitors whether your machine has a working network
+connection. It will log any failed attempts, and will stamp a
+log as soon as a reply is received. It keeps track of when the
+connection was unavailable, as well as for how long. It records
+both total down time and each occasion of interrupted
+connection. The log can also be duplicated in HTML format to
+put online.
+
+WWW: http://icpld.northernmost.org/
diff --git a/net/icpld/pkg-plist b/net/icpld/pkg-plist
new file mode 100644
index 000000000000..cc1b7c4634a3
--- /dev/null
+++ b/net/icpld/pkg-plist
@@ -0,0 +1,3 @@
+bin/icpld
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%