aboutsummaryrefslogtreecommitdiffstats
path: root/net/iet
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2011-05-19 07:41:41 +0800
committerdelphij <delphij@FreeBSD.org>2011-05-19 07:41:41 +0800
commit72f74ee2e78fa3b154fcdb1f4cdca29b83923dc6 (patch)
tree64e4e6332f5841f4b289520ac01feff0738798a1 /net/iet
parentdee73c33728813c08314bbc81a1e0356528cf49f (diff)
downloadfreebsd-ports-gnome-72f74ee2e78fa3b154fcdb1f4cdca29b83923dc6.tar.gz
freebsd-ports-gnome-72f74ee2e78fa3b154fcdb1f4cdca29b83923dc6.tar.zst
freebsd-ports-gnome-72f74ee2e78fa3b154fcdb1f4cdca29b83923dc6.zip
Resolve conflict against b.p.m's CONF_* variables.
Submitted by: Chris Rees <utisoft gmail.com> PR: ports/157157
Diffstat (limited to 'net/iet')
-rw-r--r--net/iet/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/iet/Makefile b/net/iet/Makefile
index 3a9d2c8a81f1..21a25fe0c21e 100644
--- a/net/iet/Makefile
+++ b/net/iet/Makefile
@@ -35,8 +35,7 @@ KMODDIR= ${PREFIX}/modules
PLIST_SUB+= KMODDIR=${KMODDIR}
MAKE_ENV+= KMODDIR=${KMODDIR} DATADIR=${DATADIR} SYSDIR="${SRC_BASE}/sys"
-CONFDIR= ${PREFIX}/etc/iet
-CONF_FILES= ietd.conf initiators.allow initiators.deny targets.allow
+IET_CONF_FILES= ietd.conf initiators.allow initiators.deny targets.allow
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel sources to build
@@ -49,11 +48,11 @@ BROKEN= requires 8.0-RELEASE or higher
.endif
pre-install:
- ${MKDIR} ${DATADIR} ${KMODDIR} ${CONFDIR}
+ ${MKDIR} ${DATADIR} ${KMODDIR} ${ETCDIR}
post-install:
-.for f in ${CONF_FILES}
- @[ -f ${CONFDIR}/${f} ] || ${CP} ${DATADIR}/${f} ${CONFDIR}/
+.for f in ${IET_CONF_FILES}
+ @[ -f ${ETCDIR}/${f} ] || ${CP} ${DATADIR}/${f} ${ETCDIR}/
.endfor
.include <bsd.port.post.mk>