aboutsummaryrefslogtreecommitdiffstats
path: root/net/iet
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2011-04-02 01:34:44 +0800
committerdelphij <delphij@FreeBSD.org>2011-04-02 01:34:44 +0800
commit92eccaa68c6a681e3ffd2f4c75cd516feb9b5438 (patch)
treee9ef7adb67341b18ad9852a870ef51f56a0e33c4 /net/iet
parentda41e941adff990f78342c380ef1a7155bdea006 (diff)
downloadfreebsd-ports-gnome-92eccaa68c6a681e3ffd2f4c75cd516feb9b5438.tar.gz
freebsd-ports-gnome-92eccaa68c6a681e3ffd2f4c75cd516feb9b5438.tar.zst
freebsd-ports-gnome-92eccaa68c6a681e3ffd2f4c75cd516feb9b5438.zip
Minor change to make the code match Linux's behavior.
Submitted by: Shivaram Upadhyayula <shivaram.u quadstor.com>
Diffstat (limited to 'net/iet')
-rw-r--r--net/iet/Makefile2
-rw-r--r--net/iet/files/patch-kernel__nthread.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/iet/Makefile b/net/iet/Makefile
index ecc4c41f2013..3a9d2c8a81f1 100644
--- a/net/iet/Makefile
+++ b/net/iet/Makefile
@@ -7,7 +7,7 @@
PORTNAME= iet
PORTVERSION= 1.4.20.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= SF/iscsitarget/iscsitarget/${PORTVERSION}/
DISTNAME= iscsitarget-${PORTVERSION}
diff --git a/net/iet/files/patch-kernel__nthread.c b/net/iet/files/patch-kernel__nthread.c
new file mode 100644
index 000000000000..06a60becde5b
--- /dev/null
+++ b/net/iet/files/patch-kernel__nthread.c
@@ -0,0 +1,11 @@
+--- ./kernel/nthread.c.orig 2011-04-01 10:25:22.720654061 -0700
++++ ./kernel/nthread.c 2011-04-01 10:25:22.790651367 -0700
+@@ -147,7 +147,7 @@
+ set_fs(oldfs);
+ #else
+ uio_fill(&uio, iov, i, len, UIO_READ);
+- flags = MSG_WAITALL | MSG_NOSIGNAL;
++ flags = MSG_DONTWAIT | MSG_NOSIGNAL;
+ res = soreceive(conn->sock, NULL, &uio, NULL, NULL, &flags);
+ map_result(&res, &uio, len, 1);
+ #endif