aboutsummaryrefslogtreecommitdiffstats
path: root/net/ifdepd
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-17 05:23:15 +0800
committerpav <pav@FreeBSD.org>2005-03-17 05:23:15 +0800
commitdfac7dc7131baac95d7d62381983a32c0899073b (patch)
treeec665820331d01682cdf5d0876d15264a27a87ac /net/ifdepd
parent7fa15c074493193d91c5aabd56df1fadfe15dc28 (diff)
downloadfreebsd-ports-gnome-dfac7dc7131baac95d7d62381983a32c0899073b.tar.gz
freebsd-ports-gnome-dfac7dc7131baac95d7d62381983a32c0899073b.tar.zst
freebsd-ports-gnome-dfac7dc7131baac95d7d62381983a32c0899073b.zip
ifdepd implements dependencies between network interfaces in a
reliable way. If any of the source interfaces fails, ifdepd sets all destination interfaces to state down. If all source interfaces are active, ifdepd sets all destination interfaces to state up. For example, it can be used with carp(4) to provide failover functionality on gateways/firewalls. ifdepd is a simple replacement for ifstated and was written because of problems with ifstated. PR: ports/78819 Submitted by: Alexander Hausner <alex@hugo.bmg.gv.at>
Diffstat (limited to 'net/ifdepd')
-rw-r--r--net/ifdepd/Makefile36
-rw-r--r--net/ifdepd/distinfo2
-rw-r--r--net/ifdepd/pkg-descr12
-rw-r--r--net/ifdepd/pkg-message15
4 files changed, 65 insertions, 0 deletions
diff --git a/net/ifdepd/Makefile b/net/ifdepd/Makefile
new file mode 100644
index 000000000000..891e64364a9b
--- /dev/null
+++ b/net/ifdepd/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ifdepd
+# Date created: 03 03 2005
+# Whom: Alexander Hausner <alex@hugo.bmg.gv.at>
+# $FreeBSD$
+
+PORTNAME= ifdepd
+PORTVERSION= 20050303
+CATEGORIES= net
+MASTER_SITES= http://alex.bmg.gv.at/programs/
+
+MAINTAINER= alex@hugo.bmg.gv.at
+COMMENT= Interface Dependancy daemon
+
+INSTALL_TARGET= install install-man
+MAN8= ifdepd.8
+MANCOMPRESSED= no
+
+PLIST_FILES= bin/ifdepd \
+ etc/rc.d/ifdepd.sh
+
+USE_REINPLACE= yes
+PKGMESSAGE= pkg-message
+
+USE_RC_SUBR= yes
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502113
+IGNORE= need link state change notification changes from May 2004
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/ifdepd/distinfo b/net/ifdepd/distinfo
new file mode 100644
index 000000000000..27d564051820
--- /dev/null
+++ b/net/ifdepd/distinfo
@@ -0,0 +1,2 @@
+MD5 (ifdepd-20050303.tar.gz) = c4a8aaae4962796871072bce2a170765
+SIZE (ifdepd-20050303.tar.gz) = 6765
diff --git a/net/ifdepd/pkg-descr b/net/ifdepd/pkg-descr
new file mode 100644
index 000000000000..3a76c22753f1
--- /dev/null
+++ b/net/ifdepd/pkg-descr
@@ -0,0 +1,12 @@
+ifdepd implements dependencies between network interfaces in a
+reliable way. If any of the source interfaces fails, ifdepd sets all
+destination interfaces to state down. If all source interfaces are active,
+ifdepd sets all destination interfaces to state up.
+
+For example, it can be used with carp(4) to provide failover functionality
+on gateways/firewalls.
+
+ifdepd is a simple replacement for ifstated and was written because of problems
+with ifstated.
+
+Alexander Hausner <alex@hugo.bmg.gv.at>
diff --git a/net/ifdepd/pkg-message b/net/ifdepd/pkg-message
new file mode 100644
index 000000000000..a43d962c399b
--- /dev/null
+++ b/net/ifdepd/pkg-message
@@ -0,0 +1,15 @@
+
+*** ATTENTION ***
+
+To run ifdepd from startup, add
+ifdepd_enable="YES" to /etc/rc.conf
+
+Available variables you add/set to /etc/rc.conf.
+- ifdepd_enable (bool): Set to "NO" by default.
+ Set it to "YES" to enable ifdepd.
+- ifdepd_src_ifaces(str): Set to "" by default.
+ Contains a space separated list
+ of source interfaces.
+- ifdepd_dst_ifaces(str): Set to "" by default.
+ Contains a space separated list
+ of destination interfaces.