aboutsummaryrefslogtreecommitdiffstats
path: root/net/java-beepcore
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-06 12:34:23 +0800
committeradamw <adamw@FreeBSD.org>2014-08-06 12:34:23 +0800
commita46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8 (patch)
treed206a205dd3870d245c26875f1da2aaa627aad64 /net/java-beepcore
parent0a17597462ff11896ad3e619b25fc9df0263fcef (diff)
downloadfreebsd-ports-gnome-a46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8.tar.gz
freebsd-ports-gnome-a46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8.tar.zst
freebsd-ports-gnome-a46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8.zip
In some straightforward situations, protect examples behind PORTEXAMPLES,
adding EXAMPLES to OPTIONS_DEFINE where necessary. In a couple instances, correct examples being controlled by the DOCS option.
Diffstat (limited to 'net/java-beepcore')
-rw-r--r--net/java-beepcore/Makefile6
-rw-r--r--net/java-beepcore/pkg-plist22
2 files changed, 14 insertions, 14 deletions
diff --git a/net/java-beepcore/Makefile b/net/java-beepcore/Makefile
index e1b7c907b5fc..ad5005478531 100644
--- a/net/java-beepcore/Makefile
+++ b/net/java-beepcore/Makefile
@@ -18,13 +18,13 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/beep*.jar ${STAGEDIR}${JAVAJARDIR}
- cd ${WRKSRC}/example \
+ (cd ${WRKSRC}/example \
&& ${FIND} -s . -type d -exec ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/{} \; \
- && ${FIND} -s . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/{} \;
+ && ${FIND} -s . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/{} \;)
${INSTALL_DATA} ${WRKSRC}/lib/example.jar ${STAGEDIR}${EXAMPLESDIR}
post-install:
diff --git a/net/java-beepcore/pkg-plist b/net/java-beepcore/pkg-plist
index ffa518c21710..8c0d16749dca 100644
--- a/net/java-beepcore/pkg-plist
+++ b/net/java-beepcore/pkg-plist
@@ -6,15 +6,15 @@
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/README_SASL.htm
-%%EXAMPLESDIR%%/example.jar
-%%EXAMPLESDIR%%/org/beepcore/beep/example/Beepd.java
-%%EXAMPLESDIR%%/org/beepcore/beep/example/Bing.java
-%%EXAMPLESDIR%%/org/beepcore/beep/example/README_EXAMPLE
-%%EXAMPLESDIR%%/org/beepcore/beep/example/beepd-config.xml
-@dirrm %%EXAMPLESDIR%%/org/beepcore/beep/util
-@dirrm %%EXAMPLESDIR%%/org/beepcore/beep/example
-@dirrm %%EXAMPLESDIR%%/org/beepcore/beep
-@dirrm %%EXAMPLESDIR%%/org/beepcore
-@dirrm %%EXAMPLESDIR%%/org
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.jar
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/org/beepcore/beep/example/Beepd.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/org/beepcore/beep/example/Bing.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/org/beepcore/beep/example/README_EXAMPLE
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/org/beepcore/beep/example/beepd-config.xml
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/org/beepcore/beep/util
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/org/beepcore/beep/example
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/org/beepcore/beep
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/org/beepcore
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/org
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%