aboutsummaryrefslogtreecommitdiffstats
path: root/net/kdenetwork4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
commitd65c037b00c46aa7b10d1803dee20b9bbb57e36b (patch)
treeda82a32e8ce2ded995ae7ba320231491c35220ac /net/kdenetwork4
parent051464267aa4627179b870274906053785cee748 (diff)
downloadfreebsd-ports-gnome-d65c037b00c46aa7b10d1803dee20b9bbb57e36b.tar.gz
freebsd-ports-gnome-d65c037b00c46aa7b10d1803dee20b9bbb57e36b.tar.zst
freebsd-ports-gnome-d65c037b00c46aa7b10d1803dee20b9bbb57e36b.zip
Mk/bsd.kde4.mk:
- Don't set CMAKE_BUILD_TYPE for debug builds (cmake.mk already handles it) - Don't set WITH_DEBUG for unstable branch (KDE4_BRANCH) - Remove now useless KDE4_BUILDENV KDE SC ports: - Chase KDE4_BUILDENV removal: replace 'KDE4_BUILDENV= yes' with 'USES= cmake:outsource' and add USE_LDCONFIG if needed
Diffstat (limited to 'net/kdenetwork4')
-rw-r--r--net/kdenetwork4/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index bf9dd1699d14..3b27f0965c2d 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -23,12 +23,13 @@ LATEST_LINK= ${PORTNAME}4
USE_KDE4= kdehier kdelibs kdeprefix libkonq pimlibs workspace \
automoc4 ontologies strigi
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_OPENSSL= yes
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_SQLITE= yes
USE_XORG= x11 xdamage xext xscrnsaver xtst
USE_XZ= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
CMAKE_ARGS+= -DBUILD_kopete=off \